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1 ArcGIS Review  

1.1 Objective 

The first lab has as main objective the refreshment of the main GIS concepts. The focus is placed 

on data type, spatial manipulation, and data editing. 

For those students that have limited knowledge of ArcGIS, you should start by first taking the 

GIS course online offered free by ESRI: Getting Started with GIS, which is around 3 hours long. 

1.2 Software 

The lab, as almost all the course, uses the GIS software developed by ESRI. There are two 

possible avenues to complete this lab and the course: ArcMAP or ArcGIS Pro. The lab is 

developed for ArcMAP, but the concept and interface are almost the same with ArcGIS Pro. For 

people interested in the free version, the QGIS is an option, but the labs are not designed for that 

software. Nevertheless, if one or more students want to use QGIS, I would help them. 

1.3 Files Used in This Lab 

The files used in this Lab are located on Canvas under the Week#1 module, the Lab1 link. The 

files are zipped under the name FE444_Lab01.zip. Inside the zip file there are the following 

spatial files:  

• The shapefile of the stream layer of the HJ Andrews Experimental Forest:  

o HJA_Streams. There are at least 4 files that comprise a shapefile to be used inside 

ArcGIS, which are distinguished by extensions: .shp, .shx, .dbf, and .prj.  

• The shapefile of the boundary of the HJ Andrews Experimental Forest:  

o HJA_Boundary. There are physically 4 files that comprise the shapefile to be used 

inside ArcGIS, which are distinguished by extension: shp, shx, dbf, and prj. 

• The shapefile of the roads from the HJ Andrews Experimental forest area: 

o  Roads. There are physically 4 files that comprise the shapefile to be used inside 

ArcGIS, which are distinguished by extension: shp, shx, dbf, and prj. 

• A Digital Terrain Model of the area containing the HJ Andrews Experimental Forest: 

o HJA_DTM. 

• A Digital Surface Model of a portion of the HJ Andrews Experimental Forest: 

o HJA_DSM. 

1.4 Geographic Information System 

1.4.1 Spatial data types and formats 

Spatial information is usually stored and displayed in two formats: vector and raster. 

Formally, vector data stores the spatial information as coordinates of particular points, such as 

vertices of a polygon, and complete the rest of the figure (if needed) by mathematical 

interpolations. Therefore, vector data are not affected by scale. Vector data can represent points, 

lines, or polygons. The most common file format used for storing vector data is the shapefile. The 

shapefile format was developed by ESRI and is a set of three mandatory files: shp, shx, and dbf.       

The .shp file is the shape format and stores the feature geometry. The .shx format is the 

shape index format and stores the positional index of the feature geometry, which allows quick 



Remote Sensing and Photogrammetry – Forestry Applications 

2 

 

search within the file. The .dbf format is the attribute format, which is a database storing the 

information within the shapefile. The three files are needed for operability; however, a fourth file 

is required for meaningful data analysis, namely the .prj file.  

The .prj file stores the coordinate system and projection information as an ASCII file. 

Without the .prj file, we do not know where the information is located and how large/small it is.  

The roads layer, stream layer, and the boundary layer are three types of vector data: 

two are poly-lines (Roads and HJA_Streams), and one is a polygon (HJA_Boundary). 

 

Raster data represents all the spatial information within the extent of the file using a 

Cartesian coordinate system, similar to the vector data, with the difference that the axis units 

are predefined. The preset of the units discretize the spatial information into cells, which are the 

natural extension of digitization. Simply stated, a raster is an image, and as such depends on a 

scale: below the predefined scale there is no information useful within the raster. Depending on 

the values stored in each cell, rasters have been conventionally classified as discrete rasters, 

which have a small number of values (such as the one that represents land use), and continuous 

rasters, which have a multitude of values (such as the one that represents elevation or 

temperature). Irrespective of the type, the values stored in a raster file is at most the number of 

cells within the raster; therefore, there is a finite number of values. The most common file format 

storing raster data is TIFF. However, .jpg or .png are two other formats that can be used. The 

caveat of using .jpg and .png over .tiff is that they are lossy formats, meaning that information 

will be lost because of the compression. Furthermore, .jpg and .png have the projection store as a 

separate file, called world file, whereas tiff sometimes incorporates this information inside the 

file architecture. The files for this lab called “HJA_DTM” and “HJA_DSM” are continuous 

rasters stored as tiff files.  

 

Question#1 [10%]: Open ArcGIS and load the five files: HJA_DTM, HJA_DSM, 

HJA_Streams, HJA_Boundary, Roads. How many features are in the Roads, HJA_Streams, 

and HJA_Boundary shapefiles? 

How many pixels are in the two raster files? 

 

1.4.2 Coordinate systems and datums 

In remote sensing, a coordinate system is a narrow application of the mathematical complex 

coordinates systems to the Earth. Simply stated, a coordinate system enables specification of 

every location on Earth with a set of three numbers, called coordinates. Intuitively, the 

coordinates represent a vertical position (distance above a surface or point, if we use the center of 

the Earth as origin), and two horizontal positions (distances on the surface used as reference). 

There are two classes of coordinate systems: polar and Cartesian. Irrespective the system, polar 

or Cartesian, there is an origin and three axes: x, y, and z. For the polar coordinate system, the 

coordinates of a point on Earth are defined by the origin, also called pole, and three values 

locating the point: a distance, called the radius, and two angles, usually symbolized by the Greek 

letters θ and φ. When the angle φ is estimated in respect with the first meridian (aka Greenwich) 

is called longitude. If the angle θ is computed in respect with the equatorial plane, rather than 

with the z-axis, basically the complement of θ from Figure 1, then the angle is called latitude. 
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 Polar coordinate systems are known in GIS or remote sensing under the name of geographic 

coordinates. The location of the points on curved surfaces, such as Earth, can be exactly 

computed using polar coordinates, without any loss of information. However, polar coordinates 

have a major drawback: linear and areal measurements are difficult to execute. These 

shortcomings of polar coordinates are not existent in the Cartesian coordinates systems. 

However, conversion between polar and Cartesian systems is not necessarily without sacrifices, 

which can come under the form of a lack of realistic shape or relationship among land-feature 

size. We will learn more about coordinate systems later in the class. But for now, what you 

should know is that conversion from polar to Cartesian, or from a curved surface to a plane is 

defined by two parameters: the location of the perspective point (also known as viewpoint) and 

the surface on which the curved surface will be projected on. There are three types of surfaces on 

which Erath is usually projected on a plane, a cone, or on a cylinder (Figure 2). If the perspective 

point is placed in the center of the Earth, then the projection is called Gnomonic. When the 

perspective point is located on the Earth on the point opposing the tangent point between the 

Earth and the projection surface, the projection is Stereographic. When the perspective point is 

located at infinity, then the projection is called orthographic. The most popular projection system 

is UTM, which stands for Universal Transverse Mercator. Lately, another projection system gain 

traction because of its wide use in GPS technology, namely WGS84. 

The first decision is on what projection system to use in 

locating a point on Earth surface, which in essence will 

convert the two angles θ and φ into points on a straight line, 

therefore inside a plane. Once the selection of a projection 

system is made, next the distance from the pole, meaning 

from the origin of the coordinate system has to be made. In 

GIS and remote sensing the distance from the pole of the 

system is usually estimated not as the distance from the 

origin but as the distance above a solid of revolution, 

commonly an ellipsoid (Error! Reference source not 

found.). The object in respect with which the distance of the point is computed from is called 

datum. Formally, a datum is a mathematical model of the Earth. The datum consists of a set of 

values that define the shape and size of the ellipsoid.   

  

Figure 2. Polar coordinates Figure 1. Perspective points for planar projections 

Figure 3. Datum: ellipsoid and geoid. 
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Question#2 [10%]: What are the coordinate systems of each of the five files (projected or 

geographic coordinate system)?Convert the coordinate system of all files to WGS 84. Provide a 

snapshot of the window or code creating the conversion.  

1.5 Operations with vector data 

Depending on the type of data, many spatial manipulations can be executed. In this section 

of the lab, we will review some of the basic operations on vector data. 

 

Question#3 [5%]: Clipping – lines with polygons  

In many instances, you would like to extract from a larger layer, only the information 

needed to answer a specific question. The information required to be extracted can be of any 

type, raster, or vector, which further can be also a point, a line, or a polygon. In this exercise, we 

will extract the lines following inside a polygon, namely the roads and streams that are within 

HJA Forest. To do so, you should use the Clip procedure located under the Geoprocessing Menu 

option. However, before start executing spatial operations, it is good practice to work with files 

that have the same coordinates system. Therefore, you would use the files converted to WGS84. 

What is the total length of the roads and streams located inside HJ Andrews Experimental 

Forest? Insert a snapshot with the streams and roads that are inside HJA Andrews.   

 

Question#4 [10%]: Measurements.  

In many applications, you are interested in finding the size of the various features, such as length 

or area. Using the stream and road layers inside of the HJ Andrews Experimental Forest, you are 

tasked to find the total length of the stream network. You will accomplish this task in tow steps: 

first, you will create a field in the table called Length_m (meaning length in meters), and second, 

by using the Calculate Geometry option available when the database of the shapefile is open.  

What is the total length of the streams and roads network in kilometers, not in meters? 

 

Question#5 [10%]: Buffers. 

In many instances, you would like to create a buffer around linear features, such as the streams 

from HJ Andrews. In ArcGIS, there are two options on how to create the buffers: as one unit or 

as individual entities, as defined by each feature from the input layer. This option is under the 

Dissolve Type window.  

Create two buffers for the streams inside HJ Andrews with a size of 50 m on both sides; one 

with individual features and one with only one feature (all features merged).  

What is the total area of the two buffers? Why do you think they are different? 

 

Question#6 [20%]. Intersection. 

In many applications, you are interested in an area that is common to different processes or 

properties. In this exercise, you are interested in finding the chance of road-related erosion into 

streams based on their relative position. You could assume that a road located further than 50 m 

from a stream would have a minim amount of sediments reaching the stream; therefore, you will 

intersect the streams buffer layer created in the previous exercise with the roads layer. The 

resulted file should be a line feature.  

Which buffer filed should you use: the one with individual features or the one with all features 

combined (merged)?  

What is the length of the roads that poses a sedimentary risk? 
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Besides the length that possesses the risk to water quality, you could be interested in the area that 

is more susceptible to receive the road sediments. To identify the respective area, you could 

create a buffer around the roads layer (also 50 m wide), then intersect it with the buffer of the 

streams layer. The resulted file would be a polygon feature.  

What is the area likely to receive the sediments from the roads?  Include a snapshot with the 

common area. Is this approach accurate?  

Mention at least one issue posed by the proposed method of identifying the areas that could 

receive sediemnst from the roads. 

1.6 Operations with raster data 

Question#7 [5%]: Information within the raster 

In most instances, when working with rater data, it is important to know the spatial resolution of 

the image, namely the size of the pixel.  

What is the spatial resolution of the HJA DTM and the HJA DSM rasters? 

 

Question#8 [10%]: Crop an image  

In many situations, you are interested in cropping an image according to a polygon, such as a 

DTM to a watershed boundary. You are tasked to crop the HJA Andrews DTM, which is for a 

larger area than the Experimental forest, to the boundary of the HJ Andrews Experimental Forest. 

You can execute this task by using the Clip function from the Data Management→ Raster → 

Raster Processing folder.  

How many pixels are located in the clipped raster?  

What are the minimum and maximum values present in the clipped raster?  

 

Question#9 [10%]: Coloring a raster  

Many images, such as panchromatic images, are not very appealing visually. Therefore, you want 

to create a nicer image. For rasters, this process is very simple if just limited displays are 

required. If you double click the name of the raster file in the Table of Contents, the Layer 

Properties will open, from which you should choose the Symbology Tab. From the available 

color ramps, choose one that you think would produce nice images (like in Figure 4). 

 

→  
Figure 4. Change in the display of information for raster data. 
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Produce an image that uses a color ramp that is visually pleasing but does NOT contain the 

white color. 

 

Question#10 [10%]:  Identify cells above a particular value.  

Rasters are famous for being able to be analyzed with ease. Therefore, you would like to perform 

some statistical analyses on the rasters. One of such simple statistics could be areas above a 

particular value. This question is valid in levies and dikes assessment or tree identification.In 

ArcGIS the answer to this question can be obtained using Map Algebra.  

 

In this question, we are interested in finding tall trees, whose crown can be found using the DSM 

layer. Among a large number of options available in Map Algebra that can answer this question, 

we will be using the Conditional function accessed thru the Raster Calculator. The function Con, 

assign the value 1 when the pixel value is larger than 200 and 0 otherwise. The syntax of the 

function is Con(condition, value when the condition is true, value when the condition is false). 

In our particular case, the function looks like this: 

Con(“HJA_DSM.tif”>200,1,0) 

  
Figure 5. The Raster Calculator interface (left) and the results of the Conditional function (right) 

 How large is the area covered by large trees? You should answer this question by multiplying 

the size of a pixel with the number of the pixels that have the value 1.  

 

1.7 Advanced topics: Introduction to ERDAS IMAGINE 

1.7.1 Objective 

The objective of this lab is to familiarize you with ERDAS IMAGINR interface, also referred to 

as the workspace, and execute some basic image manipulation and information extraction with 

ERDAS IMAGINE. 

1.7.2 Files Used in This Lab 

The files used in Lab#1 are located on Canvas under the Week#1 module. They are associated 

with the Landsat 5 image of the Gulf Islands from the Strait of Georgia acquired in 2006, and are 

presented as ENVI file: 

• LandsatTM.hdr is header file contains metadata for the .dat file. 
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• LandsatTM.dat is the file that contains the actual image, but it cannot be display without 

the hdr file. 

1.7.3 ERDAS 

1.7.3.1 Overview 
Hexagon Geospatial, or Hexagon GSP, claims that ERDAS Imagine is the “world’s most widely-

used remote sensing software package.” ERDAS IMAGINE is a suite of software that bundles 

remote sensing, Photogrammetry, LiDAR analysis, basic vector analysis, and radar processing 

under one umbrella. ERDAS IMAGINE is a raster-based software designed to extract 

information from images. Unlike ENVI, another popular ERDAS for education is equipped with 

a series of additional packages, which are very important in forestry applications, particularly: 

• ERDAS IMAGINE Professional, which is a graphical Spatial Model Editor for building and 

executing re-usable spatial recipes, multispectral image classification, hyperspectral image 

processing, and point cloud tools; 

• IMAGINE Expansion Pack, which includes automated image-to-image co-registration 

(AutoSync), 3D visualization and analysis (VirtualGIS), wizard-based change detection 

(DeltaCue), orthorectifying Radar data (OrthoRadar), NITF support, extracting terrain from 

SAR images, and stereo feature collection; 

• ERDAS ER Mapper, which has advanced image processing and compression capabilities 

geared toward oil, gas, and mineral industries; 

• IMAGINE Photogrammetry, which includes Stereo and multi-image eATE; and  

• IMAGINE Terrain Editor, which includes TE and Stereo. 

 

In this class, we will be using mainly Imagine and Photogrammetry programs from the available 

suite of programs. 

1.7.3.2 Imagine interface 
To start ERDAS application simply press the Windows icon on the screen, then type ERDAS. 

From the available options that will appear choose ERDAS IMAGINE, which will open the user 

interface. The interface contains various panels that allow you to visualize and organize your 

datasets. The basic layout of the ERDAS Workspace contains several major components, such as 

Quick Access Toolbar, Ribbon (with various tabs, such as File Tab), Contents pane, Retriever 

pane, or 2D Viewer, some of which are briefly explained below and presented in the next figure.  
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Quick Access Toolbar includes tools commonly used in ERDAS IMAGINE, such as  save, 

undo, zoom in, zoom out, etc. It is usually at the top of the screen, right beside the Im icon:  

 
The Ribbon contains all the major functions of ERDAS IMAGINE, which can be accessed thru 

the Manu Bar and the Tool Bar.  Inside the Ribbon, you can see several tabs (e.g., Home, 

Manage Data, Raster, etc.), and each tab contains groups (i.e., groups such as Information, 

Edit, and Extent located inside the Home tab). Furthermore, you can find a set of tools inside 

each group. Depending on the active Layer in the Contents pane, you may see changes of tabs. 

 

The Menu bar provide access to all the functions available in ERDAS Imagine. There are many 

options form the Menu bar, such as the File tab, Home, Raster, Terrain or Toolbox.  The File 

tab provides basic functions that allow the user to open layers, save layers, set user preferences, 

configuration, print, etc. The Home tab is the main interface of ERDAS Imagine, as it provides 

the viewer as well as the basic functionality of data inquiry. The Raster, Terrain or Toolbox tabs 

are similar with the Home tab, in the sense that the viewer is still maintained, but the Ribbon 

changes to provide access to the main functions related to the respective tab. One detail that 

should be noticed, is that the lidar options, such as point classification, are found under the 

Terrain tab.  

 

 

The Contents pane hosts the data you have opened in the workspace and Viewers (i.e., 2D 

View#1).  
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The Retriever pane gives quick access to the data by creating a Shoebox file. Shoebox files can 

be made by right-clicking on the Retriever pane. Once you 

added the data into Shoebox files, it allows you to drag-and-drop 

data from the Retriever to the Viewer.  

 

1.7.3.3 Display Images 
1. From the File tab, select File > Open> Raster Layer. A file selection dialog appears. 

Navigate to the data folder by using the Look in drop-down menu. Also, check and 

change the file type as you need. Usually, it is better to select “All File-based raster 

Formats” option in Files of types drop-down menu.  

 

 

 

 

 

 

 

 

 

 

 

 

2. After the navigation to the data folder hosting the Landsat image, select the file 

LandsatTM.hdr. Then click OK.  A simpler option of loading the data is by dragging 

and dropping the file in the Viewer.  

Note: If you want to make the current directory as the default directory, you can click  icon 

(third icon from left). Also, you can select a default output folder by clicking   icon (first 

icon from right). 
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3. Once the image is loaded, go to the Home tab, click Zoom In icon 

to zoom in, and Zoom Out icon  to zoom out. Alternatively, 

you can use the Smart Control option to do the same tasks (i.e., 

Zoom In, Zoom Out, Pan, etc.).   

4. Scale and Angle tool, which works like a dial rotating perpendicular to the screen, 

provides an easy option to change the size of the image and angle of the image. 

5. Hide the Contents pan by clicking AutoHide button .  
 

6. Click the Contents again to expand it. 

 
7. Also, you can drag the two pans if you need to detach them from the user interface. They 

become floating dialogs that can be moved to a second monitor, for example. 

 

8. Clicking the X button in the upper-right corner of the Contents pan or the 

Retriever pan will remove those pans from the main interface. To turn them 

back on go to Home tab, then under the Contents icon select the pan that you 

just closed.  

 

9. To navigate inside the image, click the Pan button in the toolbar, then click and drag on 

the image to move around. You can also use the middle mouse wheel to zoom in and out 

of the image. If you need to fit the image into the window, you can right-click in the 

image in the Contents pan and select Fit Layer to Window option.  
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10. From the Ribbon, select the Raster tab and then the Multispectral tab to adjust the 

image parameters.  

 
 

11. The Bands group allows you to use the spectral reflectance of 

the selected image. If the sensor is known it will be identified in 

the Sensor Type. If the sensor is identified, you can change the 

band combination by using the drop-down menu from the Band 

combination. Select TM True Color, and the image would be 

display as it was seen by human eyes.   

 
12. Select Custom from the drop-down menu and select in order Layer 1, Layer 2, 

and Layer 3, for red, green, and blue color square, respectively. Notice that each 

selected Layer has a color square to its left in the Bands tool. You can create different 

band combinations by changing the Layer number in the color square.  
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13. Adjust Radiometry potion provides different stretches to the original image. Select the 

Equal Percentage option. 

 
 

14. Change the brightness, contrast, and sharpness appropriately using the Brightness 

Contrast and Sharpness tools. Click in the Filtering option and select the Sharpen 

Filter option. 

1.7.3.4 Multiple Views  
At this point, the Contents pane has a single image. If you want to work with multiple images, 

which most likely will be the case, in ERADS you have two options. One, is like in any GIS 

software: have all the images in one place, which in ERDAS will be 

the Contents pane. However, in many remote sensing specialized 

software, like ERDAS, you have another option, namely images 

displayed in different viewers. Instead of overlaying layers and 

toggling them on and off in the Contents pane, you can create 

multiple views to compare images side-by-side using the Add Views 

option. 

1. From the menu bar, select Home tab and click Add Views > 

Display Two Views. A new view appears to the right of 2D 

View#1 window. You can see the newly added view in the 

Contents pan as 2D View#2. Also, 2D View#2 is the active 

view, highlighted with a pale-yellow colored border in the 

Image window. All subsequent navigation and image 

enhancement operations will be in the active view.  
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2. In the Contents pane, right-click on 2D View#2 and open the LandsatTM.hdr file in the 

viewer. Ten select Raster Options tab. Click on Display as drop-down menu select 

Grayscale option. This will display only one band out of the six available. If you want to 

display only the band 4, then select 4 from “Display Layer” option. 

 

 
 

3. A Gray Scale layer is added to the second view. Right-click on the image under 2D 

View#2 and select Fit Layer to Window. 

4. Because LandsatTM is georeferenced to a standard map projection, you can link the 

views by geographic location, meaning the images in the two Viewers would be 

synchronized. From the Home Tab, select the Link Views option (next to Add Views 

option). 

5. To keep both Views on the same band scale, click the Equalize Scales option. Also, you 

can try other Link Views option as well to get familiar with different link views.  

Especially, Sync Views option is useful to move both the images together.  

 

 
 

6. Click the Pan icon in the toolbar and pan around the grayscale image. The color image 

moves as well, and the same area is shown in both views. 
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7. Go to the Home tab, Information group, then select the Inquire 

option, to open Inquire Cursor utility. Now you can see a cross-

hair in both the Views. Also, note in the embedded panel (at the 

bottom of the window) the pixel values for the currently active 

image in the Contents pane (at the location of the Inquire Cursor 

cross-hair displayed).  

This Data table shows the red, green, and blue digital number (DN) values for the active 

view. If you want to see the data for both Views, you can select Show All Layers option 

as well. 

 

 
 

8. Once you select the Inquire Cursor utility, Utility Inquire Tab will open. In the 

coordinate group, you can see the coordinates for the selected pixel. 

 

9. Alternatively, in the Inquire tab, you can select the coordinate option to enter the latitude 

and longitude values of the pixel that you are interested in. Also, you can use Move 

group and Move Cursor Up/Down/Left/Right options to move the cross-hair.  

 

10. Select the Close Inquire option to exit. 

1.7.3.5 Image Meta‐data and Histograms 
These options provide details of Image Metadata, such as image projection and spatial resolution. 

 

1. Select View#1 to activate the color image. Go to Home Tab and click the Metadata 

option. This will open an Image Metadata dialog box that has General information, 

Projection information, Histogram, and Pixel Data.  

2. Click on Histogram Icon or Histogram tab. This will open a histogram where the X-

axis displays the range of possible brightness values, and Y-axis displays the number of 
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pixels for any brightness values. By changing the Layers in the Image Metadata dialog 

box, you can observe respective histograms for each Layer. 

3. Bring the cursor to the top of the histogram; now, you can see the X and Y values 

respective to the courser point.  

4. Select the Pixel data tab on the Image Metadata dialog box. This option will allow you 

to see the pixel value for the selected Layer. 

 

 

 
 

1.7.3.6 Saving the Workspace 
 

1. To save the session, select File > Save As > Session.  

2. This allows you to save the entire workspace, including open Viewers, data, and view 

extents. 
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2 The Electromagnetic Spectrum, ArcGIS and ERDAS 

2.1 Objectives 

• Usage of reflectance in identification of land features 

• Usage of Landsat images 

• Labels in ArcGIS 

• Annotations in ERDAS 

2.2 Description of the files 

• Quickbird from Vancouver BC: Quickbird.tif is a QuickBird multispectral image of Vancouver BC 

• QuickBird from Colorado image: qb_colorado.dat is a QuickBird multispectral image of Boulder, CO 

• QuickBird from Colorado header: qb_colorado.hdr is the header file of the above QuickBird image 

 

2.3 Overview 

The electromagnetic spectrum is the distribution of electromagnetic radiation according to 

wavelength/frequency, and includes radio waves, visible and infrared light, x-rays, gamma rays, 

and more.  In remote sensing, we use the reflective, absorptive, and emissive properties of 

terrestrial features to identify and measure them.  Below is a series of questions.  When 

answering these questions, you do not need to cite your references, but do not copy and paste!  

Put things into your own words.  Copying and pasting/not putting things into your own words 

will result in point deductions.   
 

Q1) Define “atmospheric window.” 
 

Q2) Define the three types of atmospheric scattering.  Compare and contrast them. 
 

2.4 Spectral Reflectance 

Figure 1 shows the reflective characteristics of various materials. Answer the following 

questions. 
 

 

                  Figure 1:  Reflectance characteristics of various features at different wavelengths.   



Remote Sensing and Photogrammetry – Forestry Applications 

17 

 

 

Q 3) What wavelength range has the highest reflectance for snow and ice? 

Q4) In which regions of the spectrum can dry soil be best distinguished from vegetation? 

Q5) What is the reflectance of water at 1.2 µm? What would it look like if we could see at this 

wavelength? 

Q6) From this graph, what color do we think clouds are?  This is not a trick question… 

Q7) Where is the greatest differentiation in reflectance for the two vegetation types? 

Q8) Why is there no separation between vegetation types at 0.6 µm? 

Q9) What is water turbidity? Why are there differences between the clear water vs. turbid water 

spectra? 

Q10) What wavelength region has the largest change in reflectance for vegetation (in other 

words, where is the curve steepest)?  

Q11) List the similarities between the dry and wet soil spectra compared with the clear and 

turbid water spectra. 

Q12) Which cover types look almost identical at 0.85 µm (+/- 10%)?  At 0.4 µm (+/- 10%)?   

Q13) Use the wavelength and percent reflectance data in Table 1 to plot reflectance curves onto 

Figure 1.  These curves can be plotted using MS Excel.  However you want to do this is fine.   

 

Table 1:  Spectral characteristics of five unknown features.  
Wavelength 

(µm) 

Spectra 1 

(%) 

Spectra 2 

(%) 

Spectra 3 

(%) 

Spectra 4 

(%) 

Spectra 5 

(%) 

0.40 17 30 34 32 80 

0.45 18 31.5 37.5 34 80.5 

0.50 15 33 42 36 81 

0.55 12 34.5 44 38 81.5 

0.60 5 35 43 37 82 

0.65  35.5 40 35 82 

0.70  35 37 36 82 

0.75  34.5 38 43 82 

0.80  34 46 49 82 

0.85  33 59 53 82.5 

0.90  32 67 55 83 

0.95  31 70.5 53.5 82.5 

1.00  29 71 51 82 

1.05  26 70.5 46 81.5 

1.10  22 70 41 81 

1.15  17 69.5 36.5 81 

1.20  14 69 33 81 

1.25  10 70 31 81 

1.30  6 71 29 80 

1.35  0 72 27.5 80 

1.40   72 25 80 
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Q14) Identify the five features that are represented by the spectral data in Table 1. Make an 

educated guess based on the known reflective properties of various earth surface materials and 

what you have learned from class/your readings, and explain your reasoning. Take a look and 

compare to the spectra seen in figure 1. This is a difficult task, and educated guesses are all that 

is asked for. You are not expected to get all of these right. However, do a bit of research and put 

some thought into it. Use the curves already identified as your starting point.   
 

2.4.1 Landsat 7 Bands and the Electromagnetic Spectrum  

Table 2 Parameters of Landsat 7’s enhanced thematic mapper (ETM+) sensor.  

Band 
Spectral Range 

(microns) 
Spectral 
Region 

Spatial 

Resolution 

(meters) 

Applications 

1 0.45-0.52 Blue 30 
Coastal water mapping, differentiation 

of vegetation and soils. 

2 0.52-0.60 Green 30 Assessment of vegetation vigor. 

3 0.63-0.69 Red 30 
Chlorophyll absorption for vegetation 

differentiation. 

4 0.76-0.90 Near Infrared 30 
Biomass surveys and delineation of 

water bodies 

5 1.55-1.75 
Middle 

Infrared 
30 

Vegetation and soil moisture 

measurements.  Differentiation of ice 
and clouds. 

6 10.40-12.50 
Thermal 

Infrared 
60 

Thermal mapping, soil moisture 

studies, plant heat stress 
measurement. 

7 2.08-2.35 
Middle 

Infrared 
30 Hydrothermal mapping. 

8 0.52-0.90 
Green, Red, 

Near Infrared 
15 

Panchromatic band.  Large area 

mapping, urban change studies. 

 

Figure 2 shows individual Landsat 7 ETM+ channels in grayscale.  Notice how the reflectance 

characteristics of various features (e.g. urban areas, water and ocean sediment, forests) changes 

with different wavelengths.      

 

In a true color image, the computer display represents each band using the same color that the 

sensor measured when the data was acquired. In other words, in a true color image, Landsat band 

1 (blue) is displayed through the computer monitor’s blue gun, band 2 (green) is displayed 

through the computer monitor’s green gun, and band 3 (red) is displayed through the computer 

monitor’s red gun. Any combination where this is not the case (which includes any other 

combination), is a false color composite. 

 

In false color composites, image data are displayed using wavelengths other than the wavelengths 

that were measured. False color composites are necessary because human sight can usually only 

perceive the visible portion of the spectrum (of course!), while sensors on remote sensing 

platforms can measure a much broader range of wavelengths than humans can see. As a result, in 

order to present these data visually for humans, they must be assigned to the part of the spectrum 

that humans can see.  
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Band 1 - Blue 

 
Band 2 - Green 

 
Band 3 - Red 

 
Band 4 Near IR 

 
Band 5 – Mid IR 

 
Band 7 – Mid IR 

Figure 2:  Individual Landsat 7 bands shown in gray-scale. 
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Figures 3a to 3g display color composites of Vancouver created from Landsat 7 ETM+ sensor 

data.  For each composite, the order of the Landsat band number indicates which color gun it is 

being displayed through (red, green, and blue).  All composites follow the same color order, be it 

RGB = 321, RGB = 432, RGB = 543, etc., this just means that this first number (which represents 

the corresponding Landsat band (i.e., 1-7) is being represented by the color red in the image, the 

second number (Landsat band) is being represented by the color green, and the third number 

(Landsat band) is being represented by the color blue. 

 

Examine Figures 3a to 3g and answer the following questions, keeping in mind the relationship 

between the electromagnetic reflectance and absorbance of terrestrial features and the color gun 

representations. 

 

Q15) Why does vegetation appear red in Figure 3b, but blue in Figure 3g. 

 

Q16) Which composite is best for mapping ocean sediments?   

 

 
Figure 3a:  RGB = 321 true color composite. 
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Figure 3b:  RGB = 432 standard false color composite. 

 

 
Figure 3c: RGB = 543 false color composite. 
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Figure 3d: RGB = 742 false color composite. 

 

 
Figure 3e:  RGB = 743 false color composite. 
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Figure 3f: RGB = 753 false color composite. 

 

 
Figure 3g: RGB = 754 false color composite.   
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2.5 ArcGIS 

2.5.1 Basic image analysis 

ArcGIS, developed by ESRI, is the de-facto software used in geospatial manipulations. ArcGIS 

works with both vector and raster data, and lately with point clouds. Therefore, it is very 

important for you to be familiar with the features that ArcGIS has, particularly in the Remote 

Sensing area. We will start by uploading a Quickbird image of the city of Vancouver BC, which 

has all three geomorphologic features (planes, hills and mountains), as well as three types of 

water bodies: ocean (salty), river and lakes (fresh water). The image is a panchromatic tiff file 

with the name Quickbird.tif.  

 
 

Look up the Quickbird sensor using Google and briefly read about its characteristics. Answer the 

following questions: 
 

Q17- This image is panchromatic, what does that mean? 

Q18- What is the spectral range of the QUICKBIRD panchromatic band?  

 

Q19 – What is the spatial resolution of the image? You could find this information in the Source 

tab of layer’s properties.  

 

Q20 - What does spatial resolution means in respect with reality, or with the ground, to be more 

specific? 

 

Q21- North is straight up in this image. Given this information, what is the position of the sun 

and what effect does this sun position have on the image? 
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Q22- Move to a portion of the image covering water. Some areas of the sea are black; others 

have patterns and are lighter. Provide some possible explanations for this variation in the water. 

 

2.5.2 Labeling 

ArcGIS is a platform for spatial data analyses. Therefore, most of the work is done within 

ArcGIS environment. However, once the analysis is completed, usually maps and other products 

are produced. Each map must contain at least three elements: the north direction, the scale bar, 

and a legend. In many instances the besides these three elements, maps contain labels that 

enhance the map. In ArcGIS, there are three methods of labeling a map:  by adding text boxes, by 

turning on the labeling option associated with each layer, and to use annotations. We will explore 

only two of them in this lab, as the native labeling option available under the Properties window 

is meaningful only for vector data, not for raster. We will use all three of them using the 

qb_colorado image, which is an image acquired by the Quickbird satellite of a portion of 

Colorado state. that is store in an ENVI format, meaning there is a .dat file and a .hdr file. The 

ENVI header file contains metadata for ENVI-format images. ENVI creates a new header file 

whenever you save an image to ENVI raster format. The header file uses the same name as the 

image file, with the file extension .hdr. To load the image, open the ArcGIS and drag and drop 

the qb_colorado.dat  from the Windows Explorer inside ArcGIS. 
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2.5.3 Text boxes 

The natural way to add a label to a feature is by adding text boxes over the area that you want to 

label.  To execute this task, you have to switch from the Data View to the Layout View first. The 

button that implements this task is located in the lower-left corner of the image viewer. 

  
Within the Layout Viewer, the Insert option from the Menu bar offers the possibility to add Text 

to the map.  

 
Selecting Text will add a text box in the middle of the screen, but with limited visibility. 

 
To ensure that the label is position properly and visible, you should drag it over the feature that 

you would like to label. Let say that you want to label the filed in the right upper corner as 

“Central Park”. This means that you want to change the default text within the box, which is 

“Text” with “Central Park”. To execute this task with right-click on top of the text box or double 

click the box, which will open the Properties window. 
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In this window, you will replace the default text with Central Park, change the font type from 

Arial to bold Courier New of size 25, and the font color from black to red. Also, rotate the box 

with 30 degrees, such that will fit better on the diagonal of the park. All these options are 

accessible by clicking the Change Symbol… button. Once finished, click Apply button to see the 

changes. If you like them, Press OK. To position the label on top of feature, drag the textbox on 

top of the feature. 

 

Q23. Include a snapshot of the final labeling. It should look like the image below: 
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NOTE: The text box option is not recommended, except in limited situations, as the box location 

is NOT synchronized with the image. This means that if you pan the image, the box will not 

move with the image. 

2.5.4 Annotations 

Using annotation is another option, the preferred option, in ArcGIS for storing Text to place a 

raster that is a part of a map. Annotation can be used to describe particular features or add general 

information to the map. With annotation, the position, text 

string, and display properties are all stored together and are 

all individually editable. Annotation provides flexibility in 

the appearance and placement of your Text because you can 

select individual pieces of Text and edit them. 

 

However, annotations for raster are available only thru 

geodatabase—that is, an annotation feature class stored in a 

geodatabase. ArcMap can be used to create and edit 

annotation features. 

To create an Annotation feature first, you simply right click 

on the geodatabase that will store the Annotations, in this 

example, the Default.gdb, then select the New… option. 

 

 

This will open a new window from which you should 

choose the Feature Class. The new windows triggered by 

your selection will lead you to the creation of an empty 

annotation layer. From the Type drop-down menu, select 

Annotation Feature and give it a name, such as FE444Anno 

(no space in the name). 

 

Click Next when finished, which will open the coordinate 

system window. Because you would like to have related to 

the raster, you should choose the Layer option from the 

three available options, then select the WGS_1984_UTM_zone13N, which should be the only 

available option there (if more layers are added to the map, then more coordinates system could 

be there). Click Next when done, and choose the default XY Tolerance of 1 mm.  

 

The Next press will trigger the reference scale for the annotations, which is usually defined by 

your project and size of the area covered by the image. Let's choose in this case 1:24000. For the 

next option, choose the default values. Once completed, a new layer will be added to the map, 

called FE444Anno. 
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To start adding labels to the image the editing option would be used, which basically will identify 

a label with features with the FE444Anno layer. This is executed similarly to any editing icon in 

ArcGIS. First, you turn on the edits by choosing the Start Editing from the Editor toolbar. Then 

choose the Create Features button: 

 
This will open a new window on the right of the map that controls the creation of new features, 

basically labels. 

 
Now you are able to create your first label, which again will start with the word Text. Delete it, 

and type Central Park. When completed, place the label in the area that you consider appropriate. 

If you want to rotate it do so, but you can alter it later on the angle. After you place your first 

label, you can click the arrow within the editor toolbar, which will stop creation, for the moment, 

of labels or annotations. 

 
Now select the label that you created and change the color and font to red and Times New 

Roman, respectively. This option is available thru the Attribute tab, located at the bottom of the 

Attribute Editing window. If you want to change the angle you can to also this. Once done, press 

Apply. You started from something like the left image and ended with something like the right 

image. 
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Once done with adding labels (annotations), press Stop Editing, then save your edits. 

 

NOTE: Panning or zooming the image will preserve the relative location of the lalbels (also move 

the labels), which is what you want. 

 

Q24. Create a new personal geodatabase, FE444, inside which you will place you annotations. 

Q25. Include a snalshot of your annotation. 

2.6 Advanced topics: ERDAS 

2.6.1 Load an image 

Load the panchromatic QUICKBIRD (Quickbird.tif) image of Vancouver. To load this image, in 

the main menu bar (above) go to File/Open, and then navigate to the place on your computer 

where you have the files associated with this lab. Once selected, the image will then appear in the 

main window and the layer details will show in Layer Manager area. Also, you can go to 

File/Open/Data Manager, and then navigate to the place on your computer where you have the 

files associated with this lab. If you want to move the image, click  on the above tool bar.  The 

display image shows below.  

 

 
 

Q26. Include one snapshot with the window showing the coordinate system and the datum. 
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2.6.2 Annotations 

Annotation is typically Text, but it can also include graphic shapes—for example, boxes or 

arrows—that require other types of symbology. Annotations are stored in the annotation layer. 

All features in an annotation feature class have a geographic location and attributes.  

2.6.2.1 Creating an Annotation Layer 
In the steps below, you will create one annotation layer. Annotation layers and vector layers are 

different in that you can have multiple annotation item types within an annotation layer. A single 

annotation layer may contain a combination of text, polygon, symbol, and other annotation items. 

 

1. Load the QUICKBIRD image of Boulder, CO (qb_colorado.hdr) to the main View.  

2. Once you added the image to the main View, Raster | Multispectral tab will activate. 
 

3. The Bands group under the Multispectral tab allows 

you to use the spectral reflectance of the selected image. 

If the sensor is known, it will be identified in the Sensor 

Type.  However, if you can not see the correct Sensor 

Type for qb_colorado.hdr, you can choose QucikBird-2 

as the Sensor type. You can change the band 

combination by using the drop-down menu from the 

Band combination. Select True Color, so the image 

would be displayed as it was seen by human eyes. 
 

4. From the menu bar, select File > New > Annotation Layer (under 2D View #1 New 

Options). Then Annotation Layer dialog appears. 

5. Enter “Boulder_Anno” as the File Name. 

6. Click OK. ERDAS adds the new annotation layer to the Content pane. 

7. Once you click on the “boulder_anno.ovr” file in the Contents pane, the Annotation Tab 

will enable.  

 

 

 

 

 

 

 

 

 

 

NOTE: When you are performing Annotations, check whether the annotation layer 

(boulder_anno.ovr) is active. If not, select it and start working on annotations.  

Always keep the annotation layer on top of the content pane list. If not, you can drag it and 

place it on the top of the list.  

2.6.2.2 Adding and Saving Annotation Items 
In the steps below, you will add several types of annotation items. When you created the 

annotation layer, the Text Annotation tool was automatically enabled.  
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1. In the Image window view, find a park area in the scene to label. 

 

2. Navigate to Annotation | Drawing > Insert Geometry group. From that group, select Text 

icon . Now you can see that the cursor has changed into I shape. 

 

3. Place your cursor in the middle of the park and type Central Park. The annotation item is 

added to the Annotation Layer. Now click the cursor somewhere in the image, and you will 

see that the cursor symbol has changed to an arrow mark again. 

 

4. Now you can click on the text, and it may look like this . Also, you can see 

the features in the Annotation| Drawing tab are active now. Change the font type and size 

appropriately so that you can see the text.  

 

NOTE: You can use the Fron/Size group under Drawing Tab to specify 

how you want text to appear. If the annotation is georeferenced, then 

you can specify the size, position, and other element properties in either 

map or paper units. This works in conjunction with Font Units option. 

Your selection not only affects the numbers that you use, but the way 

that your elements may be displayed in a View, Map View, or on paper 

when printed. 

Map: The annotation size is related to the geographical coordinates. 

Paper:  The annotation size is related to units of the View or related to paper size. 

(source: ERDAS Image Help) 

 

5. Select the “Central Park” text box again and go to Annotation | Format. Form Styles group, 

you can select an appropriate style for the text box. Also, you can change the Area fill and 

Line-color/style as well.  
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6. Use the Pan tool  to find a different park in the scene. 

7. Now select the “qb_colorado.hdr” image from the Content pane. Navigate to Google Earth 

Tab and Connect to Google Earth.  

8. Select Match GE to View and Export View Footprint. A separate Google Earth Window 

will open and zoom in to the image area. Select the Places Checkbox, so you can see the 

names of places. 

  
9. Now you can identify another park located in the lower part of the “qb_colorado.hdr” image 

with the help of Google Earth. 

10. Redo steps 2 and 3, name the park. You may have to select the annotation layer gain to 

perform this task.  

11. Change the Font Type to Times New Roman, the Font Size to 14, and change the font color 

to red. 

12. Select and double click on the text box. The Text Properties dialog box will open.  
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13. Set the Angle to 20 degrees and set the Vertical and Horizontal positions as Center.  

14. Using the previous settings, label two more items as text annotations. 

15. Save the annotation layer before you continue—Right-click on Boulder_Anno in the 

Content Pane and select Save Layer.  

 

Next, you will add symbol annotations to the scene. 

 

1. Click the Annotation Layer again and navigate to Annotation | Drawing and select 

Point icon . Now you will see that the Styles group under the Format tab is 

activated.   

2. Click on the small arrow button in Styles Group . 

 

3. Symbol chooser dialog box will open. From there, you can select different types of 

symbol categories by clicking the drop-down menu.  

 

 

 

 

4. Scroll down and select GPS symbols, then select Circle/Triangle Filled. Change the 

color of the symbol to red using the color selection window. 

5. Select map for units. Now you can navigate the cursor to the roundabout that is located 

between two parks and click. Now you can see that GPS symbol is added to the 

annotation layer.  
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6. Select Place Geo point Properties icon from Insert Geometry group under the Drawing 

tab. Next, the Utility tab will open. Select Place GeoPoint tab in Utility | GeoPoint tab. 

Navigate to the roundabout and click the top of it.  

 

 

 

 

 

 

  

 

 

7. You will see that GPS location of the roundabout has been added to the annotation layer.  

8. Add two other GPS symbols to the annotation layer.  

 

Now add some arrow annotations. 

 

1. Click the Annotation Layer again and navigate to Annotation | Drawing and select 

Point icon . Now you will see that Styles group under Format tab is activated.   

2. Use Symbol chooser dialog box to select Arrows category. From there, you can 

select different types of arrows by clicking the drop-down menu. 
 

3. Once the Symbol chooser dialog box opened you can select different types of arrow 

symbol categories by clicking the drop-down menu. Also, you can change the color of 

the symbol using the color selection window. 
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4.  You can select map for units. Click Apply and check how well fits your size and 

color for the arrow symbol. Make any appropriate changes if it is necessary and click 

OK. 

 

Next, add rectangles and resize them. 

 

1. Click the Annotation Layer again and navigate to Annotation | Drawing and select 

point icon . Now you will see that Styles group under Format tab is activated.  

2. Draw a rectangle that covers a block of buildings. Click to of the rectangle and set the 

line style to 4 pt and color to red. Change the area fill to blue color.  

3. You can copy and paste this rectangle by clicking Ctrl+C and Ctrl+V. Paste it to an 

adjacent set of a housing block.  

 

 

 

 

 

 

 

 

 

 

4. Click the Annotations drop-down on the toolbar and select Rectangle Annotation. 

5. Resize the rectangle you drew by clicking and dragging on the selection handles. 
 

6.  Save the layer—Right-click in the annotation layer on the Content pane. 

 

In the final steps for annotations, you will rotate the image and the annotation items. 

1. Click Home tab > Scale and Angle group  > User-Defined Angle. Then Rotate 

Image dialog box will open. You can set the Rotation Angle to 20 degrees and select 

Counter-Clockwise as Positive Direction. Then click Apply and Close. 
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2. By default, polygon, polyline, rectangle, ellipse, and arrow annotations rotate with the 

underlying image. Text, picture, and symbol items do not rotate with the image. 
 
 

3. You can save the layer by selecting Select File > Save > Top Layer to save the annotation 

layer. You can select File > Save As >  Session to save the entire work. 

 

NOTE: You can open the attribute table for the annotated layer by clicking the Annotation | 

Table. 

This table will help you to see the details of each item you added to the annotation layer.  

 

 
Q27. Identify two other areas in the image that could be a park/ housing scheme and label them 

as you see fit (you can use Google Earth for this), create the annotations, and include a snapshot 

with the two labels together with all the annotation items you have added so far.   

Q28. Include a snapshot of the Attribute table of annotations.  
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3 Basic Image Analysis: Visual analysis and PLSS  

3.1 Objectives: 

• Loading and exploring different types of remotely sensed images 

• Making colour composites 

• Displaying individual spectral bands 

• Viewing pixel grey values (digital numbers) 

• Histograms 

• Image Enhancements 

• Working with PLSS maps 

• Extract information from US Topo 7.5” maps 

3.2 Description of the files 
 

• Quickbird.tif is a QuickBird multispectral image of Vancouver BC, Canada 

• Landsat7-pan.tif a panchromatic Landsat 7 ETM+ image of Vancouver  

• Landsat99.tif is a Landsat 7 ETM+ of Vancouver BC, Canada from 1999 

• Landsat85.tif is a Landsat 5 of Vancouver BC, Canada from 1985 

• VanTM is a Landsat TM of Vancouver BC, Canada from 2006 

• WestVan.tif is an image of Vancouver BC, Canada 
 

3.3 Visual image analysis  

3.3.1 Basic visual image analysis 

The first image is a panchromatic QUICKBIRD (Quickbird.tif) image of Vancouver. To load this 

image, click on  in the main menu bar and then navigate to folder where you saved the 

images for lab 3. If you cannot find the folder, then in the Add Data window, click and 

connect to the folder where the images for the week 3 were saved. Once selected, the display 

image should look like below. 
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The second image to load is the “Landsat7-pan.tif (Figure 1). Once two images are loaded, the 

images will be shown on the table of contents.  

 

 
Figure 1.  This is what should appear on screen when the first two images have been displayed. 
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The second image is a panchromatic Landsat 7 ETM+ image of Vancouver. Briefly familiarize 

yourself with the characteristics of the Quickbird and Landsat ETM+ sensors., either by 

searching online or in the textbook.   

 

To examine the information of the images, right-click on the image layer in the table of contents, 

then select Properties. Here you can find the image information by clicking on the Source tab. 

To manage the visibility of the image layers, in Table of Contents, check in the box next to the 

layer to display it and uncheck it to turn off the layer.   
 

Q1- What is the spatial resolution of the Quickbird and Landsat 7 images? For full credit, 

provide at least TWO ways of finding the spatial resolution. 

 

Q2. Why the spatial resolution of the panchromatic image is smaller than the spatial resolution 

of multispectral bands for Landsat image? Think on the reflectance – sensor interaction. 

 

Q3- Zoom over Stanley Park and list 4 differences you observe between the Landsat image and 

the Quickbird image. 

 
 

Q4- List two possible uses/applications/advantages of using this Landsat scene over the 

Quickbird image. 
 

The third image we will look at is the “Landsat99.tif” image. Load this image in the same manner 

you loaded the last one. This time, you can see the image is colored, which is different than the 

other two. This is a “true-color” composite image taken at the same time as the panchromatic 

image that we just looked at. Remember what true-color means in relation to the last lab.  
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Q5- Based on what you see in the images, how can you tell this true-color composite is from the 

same exact time as the panchromatic image?  

 

Q6- What does true-color mean? Think on the relationship between the recorded wavelength and 

the displayed wavelength. 

 

Q7- What is the spatial resolution of the Landsat99 image? 
 

The fourth image to open is the “Landsat85.tif”, which is also a true-color image from 1985. This 

means it must be displayed in the same manner as RGB color. This image has roughly the same 

spatial extent as the Landsat99 image.   
 

Q8- Zoom onto the UBC campus and list two obvious differences between 1985 and 1999 based 

on image comparison. What could cause the changes? 

 

Q9- Why is the water around land from the Landsat85 image shown differently than water 

farther from the coast? 
 

Next, you will load the “WestVan.tif” Image. This is an image with a spatial resolution of 60 m. 

This image has a coarse (comparatively) spatial resolution for a reason. This reason relates to the 

part of the spectrum that it is representing. To answer the next question, think back to your first 

lecture (in relation to wavelengths and frequencies) and the last lab (in relation to the 

characteristics of a certain sensor that were provided). 
 

Q10- What part of the spectrum is this image representing and why does this mean its spatial 

resolution has to be 60 m (coarser than all of the other spatial resolutions we’ve been dealing 

with so far in this lab)? 
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Q11- This image is from the early morning in summer time. As a result, the urban areas are 

whiter than the forests and the water. Why? 

 

Remove all the images that have been opened by right-clicking the image layer, and choose 

Remove. The next image we will look at, vantm, is a Landsat Thematic Mapper (TM) image of 

Vancouver from 1984. The image consists of 512 lines and 512 cell (columns), forming a grid of 

512 x 512 pixels. The image file has seven bands, identified as bands 1 through band 7. 
 

1. Add the image vantm.tif to ArcMap.  

2. In Table of Contents, click on band Red, set Red to band 3; 

similarly, set Green to band 2, and Blue to band 1. And the image 

will be shown as below.  
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To create false-color composite, just repeat the steps above but assign Red: 7, Green: 5, Blue: 2.  
 
 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Q12- What makes this a false-color composite?  What bands are represented by what colors?  

What parts of the spectrum do these bands represent? 

 

You can experiment with 

different band combinations by 

loading different bands as Red, 

Green, and Blue.  A standard 

false-color composite, for 

instance,  has Band 4 on Red, 

Band 3 on Green, and Band 2 on 

Blue.  

 

To display band 1 as greyschale 

image, assign Red: 1, Green: 1, 

Blue: 1 by using the same step as 

before.  
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3.3.2 Viewing image coordinates and grey values (digital numbers) 

For most remote sensing based applications, you need to know the image coordinates.  The 

coordinates of any pixel can be displayed using the Cursor Value tool.  Similarly, the value of 

digital numbers at any given point (based on cursor 

position) is also displayed. 

1. Select identify   from the tollbar 

2. Move your cursor over the image and examine 

the changes in DN values and coordinates by 

clicking on pixel of interest.  

3. To change the coordinate units, click on the 

dropdown list in Location, then you can choose 

the interested units.   

3.3.3 Statistics 

Summary statistics for DN of each band can be 

examined in the Properties of the data layer. Right-

click on the image layer in Table of Contents. Under the Source tab of Layer Properties dialog 

box, scroll down, you will see the band statistics.  
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 

3.3.4 Image enhancements 

The pixels in a data file that make up an image can have any value: negative, positive, integer, or 

floating point. When the image data are visualized on screen, they are displayed as brightness 

values for each screen pixel. A data pixel with a larger value will be brighter than one with a 

smaller value. However, unlike the image data, screen pixels can only have 256 unique brightness 

values, varying as integers between 0 and 255 (if the screen display is 8 bit). Clearly, this 
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limitation prevents the data from being displayed with brightness exactly equal to their real value. 

For example, how would you display a negative data pixel or floating point data ranging between 

zero and one? 
 

Stretching the image data refers to the method by which the data pixels are rescaled from their 

original values into a range that the monitor can display — namely, into integer values between 0 

and 255. For example, if the image data were floating point values that ranged between -1.0 and 

1.0, the image might be stretched such that data value of -1.0 is assigned a brightness of 0, and 

data with values of 1.0 is assigned a brightness of 255. All of the intermediate data values would 

have new stretched values based on a simple model or stretch type. Commonly, a linear stretch 

type is used so that the stretched data values maintain the same relationship to each other as the 

original data (e.g., the relative distance between two stretched values is the same as the relative 

distance between the two original data values). Other stretch types use different models to assign 

the intermediate values, such as gaussian, equalization, or square root functions. 
 

1. Display the first band of the vantm.dat image. 

2. Open Identify  by click  

3. Roam around in the display window and try to find some of the brightest and darkest 

pixels in the image (you can zoom in or out to use the resolution you think it is 

appropriate for you to operate). 

4. Using the Identify widget, note the data value, the corresponding screen value (i.e., the 

stretched value), and the image coordinates for one of the bright and dark pixels. 

 

Q13- bright pixel: coords: ________________data value: ______ 

Q14- dark pixel: coords: _________________data value: ______ 
 

The exact method that is used to rescale the image data into brightness values can make a drastic 

difference in the way that the image looks. Thus, it is quite common to adjust the parameters of 

the stretch in order to maximize the information content of the display for the features in which 

you are most interested. This process is referred to as contrast stretching because it changes 

contrast in the image -- the relative differences in the brightness of the data values (i.e., 

increasing contrast means that the dark pixels are darker, and the bright pixels are brighter, so the 

brightness difference between the two is increased). 
 

For example, consider an image whose data numbers (DN) are integers that range between 35 

and 85 (only 51 different data values). If this image was stretched with a simple “one-to-one” 

model where a data value of 0 is assigned 0 brightness, and a data value of 255 is assigned 255 

brightness, then the image display will be quite dim (since the brightest pixel is only a brightness 

of 85). This stretch produces a low contrast image because a difference in data value of 1 unit is 

represented by a difference in brightness of 1 unit. Furthermore, much of the range of available 

screen brightnesses is not being used because there are only 51 different values in the image data 

(i.e., there are no pixels with a brightness between 51 and 255, so these brightnesses are unused).  

The image contrast could be maximized by assigning a brightness of 0 to the minimum data value 

of 35, a brightness of 255 to the maximum data value of 85, and linearly stretching the remaining 

49 data values through the rest of the available brightness range. This increases the contrast 

because adjacent data values now differ by several units of brightness rather than just 1, making it 

easier to visually distinguish slight differences in the data values.   
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5. There are several ways in ArcGIS you can use to stretch the images: 

 

1) Right-click on the image layer → 

Properties, choose Symbology, and 

you can specify the stretch type. Esri is 

the default stretch type of ArcMap. 

Other stretch types are standard 

deviation, histogram equalize, 

minimum-maximum, histogram 

specification, and percent clip.  

 

 

 

 

 

 

For the details of each stench type, you browse the ESRI website. 

 

2) You also use Image Analysis to change the stretch type. In the main 

menu, choose Windows → Image Analysis. In the Display panel, 

you can choose the image stretch type.  

 

Q15- Display the image with Percent Clip stretch. What features does this 

Percent Clip stretch highlight? 

 

Find an area in the image with the very brightest pixels that are nearly 

saturated with white pixels). Zoom in on this white patch so that the zoom 

window contains mostly saturated white pixels. Using the Identify, note that 

even though the pixels in the Zoom window all appear to have the same 

brightness, they actually do have slightly different data values. 
 

Contrast stretching an image for display does not affect the original image 

data. It is important to remember that whenever numerical processing is 

performed; the original data from the file are used, not the contrast 

stretched data that are displayed. 

 

6. Add vantm.dat again to ArcMap, and display it as a grayscale 

image. The two images will probably look quite different, but 

remember the data in each view are actually identical; it’s only the 

stretch that is different. Using the notes you wrote down in step 4, 

Use “Go To XY”  in the main menu to get the cursor value for the 

new stretching image. Next, record the value of the same pixel from the vantm image that 

has the PercentClip stretch. 
 

Q16-  What data value is reported by the Cursor Location/Value? 
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Both images should report the same data value for the same image coordinate, regardless of the 

stretch applied.  
 

3.3.5 Custom stretching 

In this exercise, you will learn how to use ArcGIS’s tools for complete 

manual control of the image display’s contrast stretch. 

1. Set the image (vantm.dat) to display as Red: 7, Green: 5, and 

Blue: 4. 

2. Open Image analysis, click Interactive Stretch       .  

3. Adjust the stretching range of each band; you will see the change 

of image effect.  

 

 

 

3.4 PLSS and Map reading 

3.4.1 Overview 

For foresters and other resource professionals, map reading, and the ability to make calculations 

from maps is an invaluable skill. This lab will present you with several general problems of 

distance and bearings and other map-reading information needs.  You will be working with a 

digital map, and for several of the problems, you will need to zoom in to the area and then print 

out a hard copy to make your measurements from. 
 

Step 1 (NOTE: USGS changes their website frequently, the steps to obtain the PDF may be 

different by the time you are doing this lab) 

a. Open an internet browser and navigate to http://store.usgs.gov 

b. Press the Find Map By Location box, , then select US Map locator  

c. A new window will appear and in the Map Locator search bar, type in “Marys Peak OR. 

If the search does not work, then scroll down to Find out more about the following maps 

and select the US Topo Quadrangles icon:  

 

d. In the new interface, choose the country USA, and type in the keyword box “Marys 

Peak”. If more products are available choose “MARYS PEAK, OR” with the following 

attributes: 
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o MARYS PEAK, OR TNM GEOSPATIAL PDF 7.5X7.5 GRID 24000-SCALE 

TM 2016Survey date: 2020 

o Scale:  1:24,000 

o Format: Flat 

e. Press on View/Download Free PDF of the 2020 USGS US Topo 7.5 minutes  

f. This should start downloading a pdf file that contains the 7.5 minute map. If the PDF 

opens in your browser, click the ‘download’ button on the PDF, next to the print icon. 

Step 2. Open the map in Adobe Acrobat or whatever PDF viewer you use 

 
a. For each question or set of questions, you may want to zoom in on the area and print that 

section out rather than work from the screen 

Note that the sections are generally standard 1 mile sections, in other words, each side is 5280 

feet long in ground distance units. When you print out an enlarged section, you can use this as a 

ratio to get other ground distance lengths. 

For example, if the side of a section is 3.5” in length and you have a distance of some other 

measure that is 1.8” in length: 
5,280 𝑓𝑡

3.5"
=

𝑥

1.8"
 

The new distance in ground units is    
(1.8")𝑥5,280 𝑓𝑡

3.5"
= 2715.4 𝑓𝑡 

 

3.4.2 Exercises 

3.4.2.1 Distances 
Locate the road end in the northeast ¼ of section 16, T12S, R7W. There is a small hilltop with an 

elevation of about 1800 feet. The watershed boundary runs through this point. If you were to 

follow approximately this watershed boundary and hike to the top of Mary’s Peak: 

 

Q17 - How far would you have to hike? In feet and in miles? 
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Q18 - What would be the average percent grade of the hike? 

 

To answer Q17 and Q18 you should use the measuring feature option from Adobe Acrobat 

Reader that lets you measure objects on the map. The tool is located in many instances on the 

right side of the screen (depending on where you have the toolbar located): . If you do not 

find it just search for it in the Search tools box. Once you press it, a new toolbar will appear on 

top of the image:  

Once you are selecting the Measuring tool, you have the option to measure distance, perimeters, 

and areas:  

3.4.2.2 Coordinates and Bearings 
A helicopter has been ordered to do a water drop on a small fire burning on a saddle ridge in the 

NE ¼ of section 19, T11S, R7W. The fire center is near the peak with an elevation of 1120’. The 

nearest water source is a small pond in the SW ¼ of section 21 (the smaller of the two ponds 

shown on the map). 

 

Q19 - What are the UTM coordinates of the pond center? 

Q20 - What are the straight-line distance and the compass bearing from the pond center to the 

saddle ridge area? 

3.4.2.3 Measurements of an area 
 

Q21 - You are interested in purchasing section 13, T12S, R8W. How many acres of non-forest 

land are approximately in the section? Measure the square feet and then convert to acres. 

Remember that you can use the Measuring tool in Adobe. 

3.4.3 Descriptions 

Answer the following from the information on the map 

 

Q22 - What data were used to compile the map? 

Q23 - What is the contour interval of the map? 

Q24 - What are the horizontal and vertical datum of the map?  

Q25 - If you needed more map information to the southeast of this map, which map would you 

order? 

Bonus question: What projective surface was used to create the map: cone, plane or cylinder? 

How do you know that? 
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3.5 Advanced Topics: Basic Image Analysis with ERDAS 
Lab developed by Sudeera Galapita and Dr. Strimbu from Dr. Hilker, ENVI and ERDAS documentation.  

3.5.1 Objectives 

• Exploring different types of remotely sensed images 

• Making colour composites 

• Viewing digital numbers 

• Histograms 

3.5.2 Description of the files 

• Quickbird.tif is a QuickBird multispectral image of Vancouver BC, Canada 

• Landsat7-pan.tif a panchromatic Landsat 7 ETM+ image of Vancouver  

• Landsat99.tif is a Landsat 7 ETM+ of Vancouver BC, Canada from 1999 

• Landsat85.tif is a Landsat 5 of Vancouver BC, Canada from 1985 

• VanTM is a Landsat TM of Vancouver BC, Canada from 2006 

• WestVan.tif is an image of Vancouver BC, Canada 
 

3.5.3 Exploring remotely sensed images  

3.5.3.1 Load images 
  

The first image is a panchromatic QUICKBIRD (Quickbird.tif) image of Vancouver.  

 

1. To load this image, in the main menu bar, go to File  > Open > Open Raster Layer and 

then navigate to the place on your computer where you have saved the files associated 

with this lab.  

2. Once selected, the image will appear in the main window, and the layer details will appear 

in the Content Pane area. Alternatively, you can right-click on the main View and select 

Open Raster Layer option and navigate to the place on your computer where you have 

the files associated with this lab.  

 

NOTE: If you cannot see the files after you navigated to the data folder, click Files of type drop-

down menu in the Select Layer To Add dialog box. Select the All File-based Raster Formats 

option from the drop-down menu. Now you will see the related image files in the data folder.  
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If you want to move the image, click  on the above toolbar. The display image shows 

below.  

 
 

The second image to load is the “Landsat7-pan.tif”.  

3. To do this, first go to Home > Add View. Then select Display Two Views. A second 

View will add to the Content pane.  
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4. Select the second View and then go to File and select Open > Raster Layer. Navigate to 

the data folder and select “Landsat7-pan.tif”. Right-click both Views and select Fit to 

Frame option.  

At this point, you should have both of these images (Quickbird panchromatic and Landsat7-pan) 

appearing in the Content pane, and both of these images displayed simultaneously on your 

screen. 

 
 

The second image is a panchromatic Landsat 7 ETM+ image of 

Vancouver. You shoul familiarize yourself with the characteristics of 

the Landsat ETM+ sensor by visiting NASA or Wikipedia webpage. 

Also, think back to Lab # 2, and remember the information provided 

regarding this sensor.   

 

Now we are going to see four additional images; therefore, we need 

four more additional Views.  

5. Go to Home > Window group. Select Add Views and a drop-

down list will appear.  

6. Select Display Four Views. Now you will see the main 

window with four windows where the bottom two windows are 

empty. 

7. To add two more additional Views, we are going to split the 

bottom two windows into four Views.  

8. Now, select 2D View#3 in the main window and select Add 

Views. Then select Split Current View Vertically.  

9. Now you will see that a new window has been added.  

10. Perform the same steps to 2D View#4 and add another view to 

the main window (sixth View: 2D View#6). 
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11. Go to the third window and right-click. Then select Open Raster Layer and navigate to 

the data folder and select “Landsat99.tif”. 
 

This time, you can see the image is colored, different from the first two. This is a “true-color” 

composite image taken at the same time as the panchromatic image that we just looked at. 

Remember what true-color means in relation to the last lab. To know more information about 

images, you can right-click the image name on the Content pane and Select Metadata to see the 

details of your photos.  

 

12. The fourth image to open is the “Landsat85.tif” (this will result in View # 4), and you can 

follow the same steps as previously to open it. 

 

This is also a true-color image from 1985, which means that the displayed colors should match 

the recorded colors by the sensor. This image has roughly the same spatial resolution as the 

previous image.   
 

13. Next, you will load the “WestVan.tif” Image to View window (View#5), which has a 

spatial resolution of 60 m. This image has a coarse (comparatively) spatial resolution 

because of to the part of the spectrum that it is representing.  
 

14. Up until this point, we have been looking at .TIF images. The next (and last) image we 

will look at is an ENVI formalt Landsat Thematic Mapper (TM) image of Vancouver 

from 1984 (vantm.hdr → View#6). 

 

NOTE: This image is stored in ENVI’s native format and consists of two files: a flat binary file 

without embedded non-image data, and an ASCII header file containing all of the information 

needed to open the file. The image consists of 512 lines and 512 cells (columns), forming a grid 

of 512 x 512 pixels (from picture elements). The image file has seven bands (channels), identified 
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as bands 1 through band 7. The ground resolution of each pixel in bands 1 – 5 and 7 is 

approximately 30 x 30 m. For band 6, the ground resolution is roughly 120 x 120 m. 

 

At this point, you have 

had open all the images 

for the first part of this 

lab exercise.  

 

You should have a main 

window similar to this 

figure.  

 
 

 

 

 

 

Q1 (10%): Include a snapshot of the main window with all the six images opened.  

 

Next, close all the Views in the main window that you have had opened for the first part of the 

lab.   

 

For the second part of the lab, please follow these steps: 
 

3. Go to File and select Recent option. Now you will see all the recent image files you had 

opened. 

4. Select “vantm.hdr” and open it. 

5. As before, the file’s bands will be available in the Content pane. 

6. Once the image is added to the main View, the Raster 

Tab will activate. Select Raster | Multispectral and use 

Band Selection to select RGB Color. Assign the bands as 

follows:   

a. Band 3 to R  

b. Band 2 to G 

c. Band 1 to B 

 
 

A color-coded three-band image of the Vancouver area opens similar to the following:  
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3.5.4 Making false color composites 

 

Add “Vantm.hdr” to a new view. This time you will create a false color composite by selecting 

different wavelengths to be displayed as red, green, and blue. 
 

1. Try to assign this band combination: Band 7 → R, Band 5 → G, Band 2 → B 
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You should have two display open, One for the true color composite and one for the false-color 

composite. You can experiment with different band combinations by loading different bands on 

the Red, Green, and Blue boxes.   

NOTE: A standard false-color composite, for instance,  has Band 4 on Red, Band 3 on Green, 

and Band 2 on Blue. 

You can also link your display groups so that navigation in one is matched in the others. From 

one of the displays, select Link Views and Sync Views options available under Home Tab. 

Also, Select Equalize Scales as well form window group under the Home tab.  

 

 

Try navigating around the image in one of the display groups by using the pan option. 

Once you click the Equalize Scales icon, the movements will be matched in the other display 

groups.     

3.5.5 Displaying individual spectral bands 

1. Remove View#2 from the Content pane and assign true color configuration to the image 

in View#1. 

2. From the Home tab, select the Inquire option. Now you will see Inquire tab is activated.  

This tab contains tools for measuring raster values at a specific point and helpful for 

finding the coordinates of a point on a raster. 

3. Now, look at the attribute table at the bottom of the main window. This table shows the 

band combination of the current image display. More importantly, it shows the pixel 

values of the point (where the inquire point located) and their affiliated details. 
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NOTE: Elements of the Attribute table  

Band: Displays which layers that are assigned to the red, green, and blue color channels  

FILE PIXEL: Displays the actual pixel value from the image file. 

LUT VALUE: Displays the lookup table value for the pixel. 

HISTOGRAM: Displays the number of pixels (histogram) in the image that have this 

pixel value. 

Lookup table:  IMAGINE and Lookup Tables 

It is rare that the file values that are stored in a raster image can be used as brightness values. 

• In image files of interval or ratio data such as remotely-sensed data, the file values are 

often low and too close together to create an image with discernible contrast. 

• In image files of normal or ordinal data, the file values do not relate to brightness or color, 

but to a class number. 

The transformation of file values into brightness values in IMAGINE takes place with the use 

of lookup tables. A lookup table is an ordered set of numbers, which is used to perform a 

function on a set of input values. To display or print an image, lookup tables translate file 

values into brightness values. 

For example, the following lookup table translates numbers from the range 30 to 40 to the 

range 0 to 255: 

30 >> 0 

31 >> 25 

32 >> 51 

33 >> 76 

34 >> 102 

35 >> 127 

36 >> 153 

37 >> 178 

38 >> 204 

39 >> 229 

40 >> 255 
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Three lookup tables are used in IMAGINE -- one for each color filter or gun. The source 

and function of the lookup tables depend upon the type of image displayed. 

• In true color and grayscale images, lookup tables are viewed and edited using contrast 

adjustment. 

• In pseudo color images, lookup tables are stored as a color scheme. 

 

Q2 (10%): Include a screenshot of your main window that includes the attribute table.  

 

4. Now navigate to Raster | Multispectral and change the band combinations as follows:  

Red → B1, Green → B1, and Blue → B1. 

5. Observe how the image and attribute table changed.  Because now you are displaying 

band 1 for the image. 

 

Q3 (10%). Include a screenshot of your main window that includes the attribute table. 

 

6. You can move your inquire cursor by using the Move options available under the Utility 

| Inquire tab. Observe changes of the File, LUT, and histogram values by moving the 

inquire cursor.  

 

3.5.6 Viewing image coordinates and digital numbers: DN 

 

For many applications, you may need to know the image coordinates (pixel and scan in the case 

of raw images, UTM coordinates in the case of georeferenced images).  These coordinates can be 

displayed using the Inquire tool.  Similarly, the value of digital numbers at any given point 

(based on cursor position) is also displayed. 

4. Select the Inquire tool. 

5. Move your cursor over the window in the display and examine the changes in DN values 

and coordinates. You can use the drop-down menu in the Move group under the 

Utility | Inquire tab.    

 

 

 
6. You can use the Coordinate Group in the Utility | Coordinate tab to observe the 

coordinates of the selected pixel.   
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3.5.7 Histograms 

 

In ERDAS, we can use Breakpoint Editor to view, edit, and rescale the histograms and lookup 

table graphs for the red, green, and blue. 

We can perform this when we have a color image displayed on the main View.  

 

1. Adjust “vantm.hdr” image band 

combination to true-color 

configuration (refer step 4 on page 6). 

You can select Breakpoint Editor by 

right-clicking the true color layer on 

the Content pane > select 

Breakpoints.  

2. Now Breakpoint Editor For 

vantm.hdr dialog box will open. To 

get a better look, you can maximize 

this dialog box.  

3. Let’s look at some features available 

in each graph. 

 

  



Remote Sensing and Photogrammetry – Forestry Applications 

60 

 

 

1 Gray histogram - histogram of data values of the input image 

2 Red histogram –histogram of brightness values of the Display device, in the color 

corresponding to this band. Can be Red, Blue, Green for multispectral images, and 

Yellow for panchromatic images. 

3 Pointer - location of the cursor 

4 X axis –  

Range of data values sampled in the statistics. 

0 - Minimum data value; also darkest values of a continuous image 

110.431 - Data value (X-value) at pointer location in histogram 

256 - Maximum data value; also lightest values of a continuous image 

5 Y axis –  

Contains two values because there are two histograms. 

Gray histogram - Range of frequencies of input data values is 0 - 29283 (upper number). 

Red histogram - Range of Display output brightness values is 0 - 255 (lower number). 

0 - Minimum Display output brightness value 

10036 - Data frequency value (Y-value) at pointer location in histogram 

122 - Display output brightness value (Y-value) at pointer location 

29283 - Maximum frequency value 

255 - Maximum Display output brightness value 

6 Breakpoint - Drag to define segments of the Lookup Table and to move these segments 

with the mouse. 

7 Rescaling arrows 

(Source: ERDAS IMAGINE help) 

 

4. Click on Add breakpoint   icon and you will see your cursor changed into + mark. 

Now you can click on the graph (lookup table) where you want to add a breakpoint.  

 

NOTE: If you need to delete a breakpoint, you can use Delete breakpoint  icon. 

 

5. Drag your point, and you will see the changes in the lookup table graph. You can use 

 Apply LUT icon in the histogram section or the Apply All button in the dialog box to 

see the changes you just made to the image. 

6. Apply steps 5 and 6 for Green and Blue histograms as well and see how your “vantm.hdr” 

change.  

 

Q4 (15%). Include a snapshot of your image along with the Breakpoint Editor dialog box.   

 

7. Now go to the red histogram, click Lookup Table CellArray icon . A separate dialog 

box will open, which is the lookup table editor for the respective color.  
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8. In this table, you can see two different sections, including Lookup values and 

Breakpoints. 

 

NOTE: Lookup Values table has two columns, Input column that contains the pixel data value 

of the input data. The output column shows the brightness value of the display device. You can 

change the X and Y coordinates of existing breakpoints located on the lookup table graph in the 

Breakpoint Editor in the Breakpoint table.  

 

9. You can enter different y values and see how those values affect the respective graph and 

overall image presentation. Press enter once you enter a new value and click   Apply 

LUT to update the changes.  

 

Q5 (15%). Include snapshots of the Lookup Table for each band along with their Lookup 

table graphs. Also, include a snapshot of your main View after you apply all the changes.  
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3.5.8 Image enhancements 

The pixels from an image can have any value: negative, positive, integer, or floating-point. When 

the image data are visualized on screen, they are displayed as brightness values for each screen 

pixel. A data pixel with a larger value will be brighter than one with a smaller value. However, 

unlike the image data, screen pixels can only have 256 unique brightness values, varying as 

integers between 0 and 255 (where 0 is black and 255 is white). Clearly, this limitation prevents 

the data from being displayed with brightness exactly equal to their real value. For example, how 

would you display a negative data pixel or floating-point data ranging between zero and one? 
 

Stretching the image data refers to the method by which the data stored by each pixel is rescaled 

from original values into a range that the monitor can display — namely, into integer values 

between 0 and 255 (if the monitor has a color depth of 8 bits). For example, if the image data 

were floating-point values that ranged between -1.0 and 1.0, the image might be stretched such 

that data values of -1.0 are assigned a brightness of 0, and data with values of 1.0 are assigned a 

brightness of 255. All of the intermediate data values would be assigned new stretched values 

based on a simple model or stretch type.  

 

Commonly, a linear stretch type is used so that the stretched data values maintain the same 

relationship to each other as the original data (e.g., the relative distance between two stretched 

values is the same as the relative distance between the two original data values). Other stretch 

types use different models to assign intermediate values, such as gaussian, equalization, or square 

root functions. 
 

7. Display the first band of the “vantm.hdr” image. 

8. Open the Inquire attribute table by clicking Inquire icon  . 

9. Roam around in the display window using Move Cursor up/down/left/right option

 available in Utility | Inquire tab. Try to find some of the brightest 

and darkest pixels in the image (you can zoom in or out to use the resolution you think it 

is appropriate for you to operate). 

10. Using the Attribute table, note the data value, the corresponding screen value (i.e., File 

Value and LUT value), and the image coordinates for one of the bright and dark pixels. 

To answer the next questions, include a snapshot of the area used, attribute table 

and coordinate values: 

11. You can utilize options available in the Coordinate group under the Utility | Inquire tab 

to record the respective coordinate values for bright and dark pixels.  

 
 

The exact method that is used to rescale the image data into brightness values can make a drastic 

difference in the way that the image looks. Thus, it is quite common to adjust the parameters of 
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the stretch in order to maximize the information content of the display for the features in which 

you are most interested. This process is referred to as contrast stretching because it changes 

contrast in the image -- the relative differences in the brightness of the data values (i.e., 

increasing contrast means that the dark pixels are darker, and the bright pixels are brighter, so the 

brightness difference between the two is increased. 

 

 For example, consider an image whose data numbers (DN) are integers that range between 35 

and 85 (only 51 different data values). If this image was stretched with a simple “one-to-one” 

model where a data value of 0 is assigned 0 brightness, and a data value of 255 is assigned 255 

brightness, then the image display will be quite dim (since the brightest pixel is only brightness 

of 85). This stretch produces a low contrast image because a difference in data value of 1 unit is 

represented by a difference in brightness of 1 unit. Furthermore, much of the range of available 

screen brightness is not being used because there are only 51 different values in the image data 

(i.e., there are no pixels with a brightness between 51 and 255, so this brightness are unused).  

The image contrast could be maximized by assigning a brightness of 0 to the minimum data value 

of 35, a brightness of 255 to the maximum data value of 85, and linearly stretching the remaining 

49 data values through the rest of the available brightness range. This increases the contrast 

because adjacent data values now differ by several units of brightness rather than just 1, making it 

easier to visually distinguish slight differences in the data values.   
 

Through careful adjustment of the image stretch, it is possible to highlight certain features in an 

image, and ERDAS provides several sophisticated tools for this purpose.  ERDAS’s default 

stretch (defined in the configuration file) is Standard Deviation Stretch. By default, this process 

uses the data between -2 and +2 standard deviations from the mean of the file values 

and stretches those values to the complete range of output screen values.  

 

12. You can choose 

different type of 

stretching options by 

selecting the Adjust 

Radiometry icon in 

Enhancement group 

under Raster | 

Multispectral tab. Be 

familiarized with 

different starching 

options available under 

this drop-down menu. 
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13. Also, you can select the General Contrast option from the Adjust Radiometry drop-

down menu. A separate window will open and maximize the window size.  

Here you can select different starching methods, and all of them will add the Previews 

window. So, you can select the best option for your image enhancement. 

  

 

 

 
 
 

Several 

of the 

commonly used contrast stretches can be applied to the displayed image without having to 

manually define the parameters for the stretch. The Linear stretch sets the data minimum and 

maximum to screen values (brightnesses) of 0 and 255 and stretches all other data values linearly 

between 0 and 255. 

14. Now     Click and drag the zoom wheel to enlarge or reduce size 

of chips in Preview pane. 

15. Select Standard Deviation from the drop-down menu. Then set Standard deviation to 

2. 

16. Click add new Preview image  icon, this will add another Standard deviation 

preview (Std Deviation #2) to the Previews window. 

17. Change the Standard deviations to a lower number (i.e., 1) and compare it with previous 

image (Standard deviation =2). 

 

Q6 (10%). What features does this stretch highlight (by lowering the standard deviation 

value)? 
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18. Select the image with Standard Deviation 2 and click apply. This will add to the main 

View and Minimize the Contrast Adjustment dialog box. 

 

Find an area in the image with the very brightest pixels that is nearly saturated with white 

pixels). Zoom in on this white patch so that the zoom window contains mostly saturated white 

pixels. 
 

19. Using the Inquire icon  , note that even though the pixels in the Zoom 

window all appear to have the same brightness, they actually do have slightly different 

data values (refer to the attribute table)  
 

20. You can use Show Neighbor Values option to study the brightness values in adjacent 

pixels. To perform this task, you can select Show Neighbor Values icon in the 

Neighbors group under Utility | Inquire.  

 

21. Select Center cursor and setup Neighbor Row = B1, Neighbor column = File, and Focus 

value to 8. 

 

22. You can see the attribute table results at the bottom of the main View. Your selected pixel 

will be highlighted.  

 

Q7 (15%). Include a screenshot of the main View that includes the attribute table. 
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Contrast stretching an image for display does not affect the original image data. It is important to 

remember that whenever numerical processing is performed; the original data from the file are 

used, not the contrast stretched data that are displayed. 

 

1. Now Restore down the Contrast Adjust dialog box and setup you screen similar to 

following setup. Also deactivate the Show neighbor Values tool as well.  
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2. Navigate to the Coordinate group and enter the coordinate values you have recorded 

from step 4 in section 3.6. You will see that Inquire cross hair will move to the same 

exact place you had previously in section 3.6. 

3. Now go to Contest Adjust window and change constant adjust methods one by one form 

the Methods drop down menu. Each time click apply, so you can see the change of image 

enhancement from the main window. 

4. Save your work. File > Save As > Session > Lab3_yourname. 
 
 
 

 
 
 
 
 
 
 

 

Q8 (15%). Compare the data (in File column) you recorded in Section 3.6 with the data 

recoded from above step (step 3). Do you observe any changes when you changing different 

stretching methods? Explain your answer. Use appropriate screenshots if it is necessary. 

 

Please submit the answers to questions on Canvas as a pdf file. Also include the question and 

question number with your answers.  
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4 Stereopsis & Photo Typing  
 

Lab developed by Dr. Strimbu from the notes of Dr. Hilker.  

4.1 Objectives 

• Use stereo vision 

• Interpret orthorectified images 

• Estimate areas on an orthorectified image 

 

4.2 Stereopsis 

4.2.1 Overview 

When aerial photographs are obtained in sequence by an aircraft traveling at a defined height and 

speed, the characteristics of an object can be measured in three dimensions. The capacity to 

measure objects when seen from different positions (perspectives) is using the perception of 

depth. The ability to identify 3-dimensional structures from binocular vision is called stereopsis. 

 

Stereoscopic coverage is obtained where two photos overlap. If your left eye looks directly at an 

object on the left-hand photo, while your right eye looks directly at the same object in the right 

photo, your brain puts together a 3-D image of the object because of the difference in the two 

angles of view.  

 

A stereoscope is used to achieve the required optical isolation of each eye, as well as to provide 

magnification for air photo interpretation. Because the distance traveled by plane between the 

times the two photographs were taken greater than the distance between your eyes, the vertical 

dimension is greatly exaggerated in aerial photography, and slopes can look like precipices.  

A pair of successive overlapping photographs along a flight line constitute a stereo pair. A stereo 

pair may be viewed with a stereoscope to produce a three-dimensional representation called a 

stereo model.  
 

How to see Stereo? 

1. Select a pair of photos and make sure they form a stereo pair (provided by the instructor).  

2. Look for a feature which you can see in both photos. Place the two photos side by side on the 

table under a stereoscope, make sure that they are lined up correctly along the line of flight. 

They should be spaced apart approximately the same distance as the lenses of the stereoscope. 

3. Move the photos gently around beneath the stereoscope until the images come into focus, and 

the illusion of three dimensions is created.  

 

The following method may be useful to achieve a stereoscopic view.  

1. Put the tips of your index fingers on the same object in the left and right photos.  

2. Move the fingers until the fingers are fused, then remove fingers and leave photos intact.  

 

Tips: 

    1. Make certain that the photos are properly aligned, preferably with the shadows falling 

toward the viewer. 
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    2. Keep the eye base and the long axis of the stereoscope parallel to the flight line. 

    3. Maintain an even glare-free illumination on the prints or transparencies. 

    4. Arrange for comfortable sitting and sufficient illumination. 

    5. Keep the lenses of the stereoscope clean, properly focused, and separated into your inter-

pupillary distance.  

 

Select a set of photographs and attempt to see them in stereo. Take your time and relax. If you 

cannot see stereo in the first attempt, select a new set of photos and try again. If you still have 

trouble select an urban stereo pair, or one with topographic relief, as they as sometimes easier to 

see on stereo. 
 

4.3 Visual Image interpretation 

4.3.1 Tree and Tree Species Identification 

Look at the sets of prints of individual trees. The photos have been taken on a very large scale (1: 

600). The prints cover several common tree species in Oregon (Figure 6).   

 
Figure 6. Stereo pair from Oregon 

 
Q1.[10%] Different features: List four (4) different features of the trees in the scene.  
 

No. Feature 

Example Size of Crown varies between species 

1  

2  

3  

4  

 

Species identification.  
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Try to identify different tree species visually based on the features shown below. How do you 

think the tree crown of a conifer might look like as opposed to an Alder tree? Where would you 

look for Alder trees? Try to identify a few unique features about the tree species 
 

Q2. [20%]In the table below, complete two more features for each crown. 
 

Species Feature 1 Feature 2 Feature 3 Feature 4 

Alder Net shaped pattern Smooth texture   

Douglas fir Arrow shaped branches Tall   

Western Hemlock  Skinny branches Lots of branchlets   

Cedar Spindly crowns Lighter in tone   

 

4.3.2 Stand delineation 

A forest is comprised of individual stands. A stand is formally defined as a managed ecosystem 

with trees as the main species. In most instances, age or species composition will differentiate 

stands. An area with hardwoods would be constitute a different stand than an area with conifers. 

Similarly, an area with 100-year-old trees would form a different stand than an area with newly 

planted trees. Theoretically, stand delineation is objective, but in practice, different people may 

look at the same forest and draw different stand boundaries, which make it in fact a subjective 

process. For instance, consider a mixed conifer stand forest with a small pocket of hardwoods in 

the middle. Is the pocket of hardwoods a separate stand, or is it incorporated as part of a larger, 

mixed-species stand? In many instances, these questions often come down to personal preference. 

However, operationally a stand is defined strictly by the organization managing the land, such as 

a stand cannot be less than 1 ac, for example. This choice is defined by the smallest areas that can 

be managed independently. In the case of the pocket of hardwoods in an otherwise coniferous 

stand, is the pocket large enough to support its own harvesting operation? If yes, you might 

consider this a separate stand. If not, it might be better incorporated as part of the larger, 

surrounding stand. For accurate stand delineation, it is advisable to look at aerial images as well 

as walking thru the forest and examine it on the ground.  

 

Delineation of stands, or boundaries identification, is a subjective process, but it is advisable to 

start at a known location within your forest, such as an intersection of roads, a house, or a pond. 

Next, look for areas that have the same tree species composition, basically,  shape and color, 

similar ages, which means the same texture. Using the main visual interpretation tools mentioned 

in the lecture and in the textbook, identify areas of the forest look the same and what areas look 

different. 

 

Q3 [10%] What are the main tools used in image interpretation?  
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Figure 7. Stand delineation following visual image interpretation 

Figure 7 shows the stand boundaries drawn on the aerial photo, which can now serve as a stand 

map. Notice the difference in color and texture between the different stands.  

 

Once you have identified your stands, give each one a name to identify it. There are two common 

systems of naming stands: one that is database-driven, on which each stand is named with a 

string of letters and numbers meaning something from a data management perspective (such as 

A1A1, A1A2, etc.), and one that is personally driven, such as the stand name means something to 

the user or owner, such as John_DF2011LakeNorth, meaning the stand of Douglas fir planted in 

2011 north of the lake on John Road. 

1. Choose a forested area of approximately 1 square mile around Blodget, OR from Google 

Earth. 

2. Delineate at least 5 adjacent stands using the Add polygon tool   

available in Google Earth. 

Q4 [5%] Include a snapshot of the map with the boundaries of the stands.  

 

Note: You could enhance your polygons by choosing a 100% transparency and a boundary line 

thicker than the default 1 point. You can get access to these features by right-clicking the polygon 

and selecting the properties option. Then you will see the Google Earth- Edit polygon dialog box 

where you can change transparency and line thickness.  

4.3.3 Estimate area of a stand 

In the field, it is helpful to estimate the acreage of a stand from an orthophoto. Usually, this is not 

exact, but a reasonable estimate should work fine in the field for the purpose of course estimation 

of resources. The current technology allows you to measure areas with various GIS software on 
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portable devices, such as Google Earth, and lately, Adobe has a tool that lets you measure the 

acreage inside the pdf file. Nevertheless, in many instances, such as lack of battery or power 

supply, you could be tasked to estimate the area of a stand in the absence of software, using only 

the aerial orthophoto. In these situations, the easier way is to use a dot grid.  

 

 
Figure 8. Area of a polygon estimated using a dot-grid (image from Koester et al. 2004. Sweep Width 

Estimation for Ground Search and Rescue) 

 

A dot grid is a series of evenly spaced dots (Figure 8), often printed on a clear plastic sheet. 

These grids are available from forestry supply merchants. You can also make your own using a 

piece of graph/grid paper. The method of measuring the area is very simple and relies on the 

scale of the orthophoto. The procedure is very simple: 

1. Overlay the grid on your map/photo,  

2. Count the squares or dots that cover each stand,  

3. The area is simply the product between the number of dots within the stand with the area 

represented by each dot.  

The first step is either to acquire a grid or to create one. If you have a dot-grid, then you can skip 

the creation of a grid part, but if you don’t, you should continue reading. A grid can be created 

easily using a transparent sheet of plastic (provided) and an engineering paper. Overlay them, 

with the clear sheet on top, then with a sharp pen, pencil, or needle mark the corners of the 

engineering paper.  

The dots would cover a square with at least 100 dots, meaning 10 x 10. The next step is to 

determine the area represented by each dot. To do so, you should measure the distance between 

the dots then convert it to units. For example, if the distance between two dots is 1/8 inch and the 

scale of the map is 1:24,000, then the distance between dots is 3000 inches or 250 feet. Each dot 

represents a square with the side distances between the dots, as shown in Figure 8.  Therefore, the 

area represented by each dot is the square of the distance between dots, in the example 6.250 ft2 

or 0.1434 ac. 
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Once you know how much area each dot represents, then you should count how many dots are 

inside the stand.  

Figure 9 shows a dot-grid overlaid on an aerial photo of a stand. Let assume that inside the stand, 

you have counted 214 dots. 

The final step is to estimate the area of the stand, which is the number of dots multiplied with the 

area represented by each dot. Therefore, the stand area is 214 x 0.1434 acres or 30.4 acres. 

 

Q5 [25%]. Print the Google Earth image with the delineated stands from Figure 7 (be sure that 

scale bar is included in the print). Using the dot-grid and the scale bar, estimate the areas of 

the five stands. 

 

Figure 9. Dot-grid overlaid on an image on which the boundaries of a stand are drawn. 

4.4 Landforms and Land uses in Google Earth.  

In your lab, there is a .kmz file which contains questions that are tied to locations in Google 

Earth. Double click on the GoogleEarth.kmz file to start Google Earth. Then, double click on 

each of the questions, and it will bring you to the location that this question relates to. The 

questions are also printed below. 

Q6 [5%] What do you think is happening in the forested areas at this location? 

Q7 [5%] What caused this feature? (Zoom in with the little yellow person for a better 

appreciation of it) 
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Q7 [5%] What kind of housing is this (directly under and immediately surrounding the pin)? 

Q8[5%] Starting at the pin and extending north along the coast for almost 6 miles, what do you 

think is happening in this area? 

Q9 [5%] What large structures do the large grey roads provide access to? Approximately how 

large do you think they are (use things visible in photo to get a scale approximation).  What do 

the smaller, tire track roads seem to provide access to? This answer is not as apparent as the 

previous one and requires consideration of where the image is located (the state should help). 

Q10 [5%] What are the new features added to the river (clearly seen in 3/10/2005) that were 

not present in the 1994 photo? What do you think they are used for? 
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4.5 Advanced topics: Photogrammetric Point Clouds 

 
Lab developed by Dr. Strimbu using data from Vernon Parish, Louisiana.  

 

Objectives 
• Basic operation with point clouds 

• Generate Photogrammetric point clouds from airborne stereo images 

• Knowledge on high-resolution aerial images 

 

1 Files Used in this Tutorial 

 

The lab will use four files, three aerial stereo images, and one a block file. The aerial images were 

acquired with an UltraCam X Camera, produced by Vexcel Imaging GmbH from Austria. 

 

• The image files are LA001_0003.tif, LA001_0004.tif, and LA001_0005.tif. To ensure 

that the images are positioned correctly, another file is created during the 

photogrammetric process, which is not presented in this lab: the aux file. The aux file, 

which is an abbreviation from the auxiliary file, is used in conjunction with non-native 

ERDAS IMAGINE files accessed thru the dynamic library Raster DLL and stores 

information not normally supported by the .tiff file. 

 

• The block file is: FE544LA.blk and contains the photogrammetric information of the 

images, particularly the Interior and Exterior Orientation Parameters, the Coordinate 

System, the Average Flying Height, the Sensor Model, and Camera calibration 

information. 

Q1. [10%] What are the wavelengths recorded by the UltraCam X? 

Q2. [10%] What is the pixel size of the UltraCam X sensor? 

 

BEFORE YOU DO ANYTHING ELSE: Retrieve the data for this lab from your course drive. 

The data for this lab can be found on T drive under Teach/Classes/FE444/2020/Lab4/. Download 

all the files locally, on the computer, as they are very large (more than 1 GB/file). 
 

 

2 Background 

The remote sensing files stores spatial information in two formats: raster, which is based on 

matrices, and vector, which is based on points and relationships between points. Both types can 

store planar coordinates (i.e., x and y) as well as three-dimensional coordinates. When the 3D 

information is stored in a raster format, the files are commonly named digital elevation models, 

whereas, for vector format, the files are commonly referred to as point clouds. There are two 

types of point clouds, one obtained from passive sensors, like images, referred to as 
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photogrammetric point clouds, and the other obtained  from active sensors, like laser, referred to 

as lidar point clouds. Photogrammetric point clouds are obtained using stereometrics principles, 

which rely on the observation that the perception of depth is obtained by observing the same 

object from different viewpoints (locations). To make exact measurements using stereopsis, there 

are several details that must be known for each image, among which the following are the most 

important one: 

• Image id 

• Interior Orientation Parameters 

• Exterior Orientation Parameters 

• Coordinate System 

• Average Flying Height 

• Sensor Models 

• Camera calibration information. 

Once the images are properly aligned and positioned, dimensional measurements are possible, 

including elevation. The process of correctly position the images is mandatory and requires 

several steps, some iterative. Because of the length of the lab, the positioning of the images is 

not included. The file containing all the information needed for 3D measurements is called the 

block file (it has the extension blk), which is provided. If dimensions are needed in a raster 

format, then digital elevation models are produced from the stereo pair. However, if the vector 

type format is required, then point clouds are produced. In this lab, we are focusing on the 

creation of point clouds.  
 

3 Generation of a photogrammetric point cloud from stereo images 

1. To generate point clouds from stereo images; first, you must open the block file. This is 

achieved by pressing File → Open → . Then navigate to the block file 

on your computer, which is named FE544LA.blk: 

 
 

After you open the block file, the information needed to extract the 3D data is displayed in four 

windows: Contents, 2D View #1, 2D View#2, and the Images.  
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NOTE: The Contents window shows the main parts of the block 

file, namely the images, the terrain model, the tie points, the 

checkpoints, and the control points. The block file also contains 

the Orthophotos, if they are produced. 

 

 

 

 

 

 

The 2D View #1 shows the footprint of the images used in the generation of the point clouds, 

whereas the 2D View#2 shows the points used to connect the images. As we see, only tie points 

are present. 

 
 

The Images window shows the image ID and whether the orientation parameters are present or 

not. The image ID from the block file corresponds to a physical file, which is identified by its 

path that is shown in the Image Name column. If the Image Name does not match the path, 

which is very likely given the relocation of the files between computers, the Online column 

would be red, meaning that a new synchronization of the image ID with the Image name should 

be done.  
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2. To rebuild the relationship between the information stored inside the block file and the 

physical images, press the red cell under the Online column corresponding to each image and 

navigate to the correct location of the image 

 

 
3. In the new window, click Attach to navigate to the image location: 

 
 

NOTE: If you can not see the image files after you navigated to your lab folder, you may need to 

select the “All File-based Raster Formats option from the “Files of type” drop-down menu.  

 

If the new folder location contains all the file from the block, they will be shown: 

 
4. Choose the appropriate one, then press, OK. Once the file is added, the cells under the Online 

and Pyr (from Pyramid) column would turn green, which symbolizes that the file is ready to be 

used (if the Interior and exterior parameters are also green). Repeat the previous steps such that 

the rest of the tree images are ready for processing. 
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5. Once the images are properly connected within the block file, you can see them in the viewer 

by turning each one off then on in the Content pane. 

 

 
 

6. The point cloud generation process is executed with the Photogrammetry tab by selecting 

Generate, then eATE (enhanced Automatic Terrain Extraction). 

 
 

7. When eATE starts, only the image footprint is displayed. 
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8. To display the images you 

should first check the box 

under the Visible column 

from the table located under 

the viewer.  

 

9. Next, press the Display 

raster images button from 

the  toolbar:  

NOTE: The Project panel 

displays the information 

used to produce the 

photogrammetric point 

cloud: the images to be used, 

the area for which the point 

cloud will be generated, the 

DEM, the algorithm 

generating the point cloud, 

and the Processing element. 

 

 If you click on each folder, 

you will see that Images, Seed Source and Strategy have subsets, whereas AOI and the 

Processing Element does not. We will see later how to populate the empty options. 

 

The images to be used in point cloud generation are the ones correctly positioned with the block 

file. The area for which the point cloud will be generated could be for the entire overlapping area 

or only for a smaller one, called Area of Interest (AOI). If you do not select any AOI, the point 

cloud will be generated for the entire region that has overlapping images. However, In this lab, 

we will choose a small AOI to speed up the computation process, considering that the images are 

very large (more than 1 GB).  

10. To choose an AOI, press Start AOI Tool, , which will open the window called Region 

Delineation Tools. Press create rectangle AOI icon, then draw a rectangle on the image, like 

below: 
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After you selected the AOI, you should save it by pressing the Save icon 

located under Region Delineation Tools. After you save it, the name of the 

file with the AOI will open  in the AOI folder.  

 

The DEM provides the starting point for the extraction algorithm and can be either a general 

planetary surface or one that is more adjusted to the area. By default, the global DTM is used; but 

the accuracy can be increased is better DTM is used during the point extraction process.  

 
The Strategy link shows the parameters used to generate the point clouds. 

Once you are familiar with the icons on the Project pane, you can start the actual process of 

generating the photogrammetric point cloud.  

To generate the point cloud, you should start by establishing the Process Engine Settings . 

The settings values have a significant impact on the processing time and the quality of the point 

cloud.  The Process Engine Settings window has three tabs: General, Format, and 

Radiometry. 

I. In the General tab, the Stop at Pyramid Level establishes which datasets to be 

used. A value of 0 means that all data would be used, which will take longer but 

will produce better quality point clouds. A value of 1 or 2 would be faster at the 

cost of accuracy. In this lab, you should choose the value of 1. 

II. The Point sampling density decides if all pixels will be used (a value of 1) or 

every other pixel (a value of 2) or forth (a value of 4) etc. Smaller values lead to 

better results at the expense of processing time. In this lab, choose the value of 2. 

III. Pixel Block Size defines the number of pixels used during the processing at any 

moment. Leave it at 500. 
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IV. The Format tab hosts information on the output files, which should be left as  

LAS, the maximum number of points (which should also be left at 50 million), 

and whether a colored point cloud will be produced (check the RGB Encoding) or 

not. 

 
V. The Radiometry tab sets up the Gradient Threshold if the image has poor 

contrast or fidelity. Increasing values will lead to more matching points but will 

take more time to process. Leave it at 2.5%, as the images have good contrast.  

   
You can Click OK once you have finished the Process Engine Settings.   

 

11.The next step in ensuring that the point cloud is generated appropriately to check the Output 

Settings: . Similarly to the Process Engine Settings, there are several tabs in the Output 

Settings.  

 

I. The General tab establishes where the files will be saved thru the Project File Directory 

box, so navigate to a folder that is easy to be found. If the folder does not exist, you will 

be asked if you wanted to create it or not. The rest of the options are self-explanatory, as 

they are estimated from the block file and the DTM.  

II. The Output files tab chooses which outputs will be produced: point clouds in a vector 

format, las file (Output Original Points checkbox), Rater format, or in a Nongridded 

format. You should choose the las output.  

III. The Split tab lets you divide the output point clouds into tiles if the cloud is too big. Do 

not divide the output.  

IV. The Thin tab lets you choose fewer points from the original point cloud if the point cloud 

is very large. You should not thin the point cloud.  
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V. The last tab, Classification, let you classify the points into various classes. Classification 

is very important, and we will discuss it during the lidar part of the class. For the time 

being, you should not classify the point cloud. 

  
 

Click OK once you have chosen the appropriate settings, as described above. 

 

The next step in the production of photogrammetric point clouds is the selection of the algorithm 

and its parameters that estimate the location of each point. This task is achieved in the Strategy 

Manager window. ERDAS recommends to let the options unchanged unless you are familiar 

with the procedures. In this lab, we will be leaving the options unchanged.  

12. Once all the settings are established, press the Generate Processing Elements button . 

This will add configuration files, cfg. Each file defines the element boundaries that can be 

distributed across processors. To see the boundary of each element, press each configuration file. 

As you see, the boundary area is the overlapping area of the images. 
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With all the details needed to generate the point cloud from images defined, the last step is to 

generate the points.  

13. This task is executed by pressing the Batch Run the eATE Process icon: . This will open 

the Batch Command Editor that defines the computational details. You should see the two 

configuration files from the Processing Element folder listed as Inputs.  

14. To finalize the generation of the photogrammetric point cloud generation, press the Submit 

button. In the Submit window, you have the option to start the process immediately after you 

press OK or at a later date. Choose the Start Process Now option.  

 

If you have a multicore processor, which most likely is true, you can distribute the computations 

among CPUs; therefore, choose a number larger than 1 to speed up the process. In this case, you 

should choose 2 under Simultaneous Process because we have 2 configuration files, which 

means that each .cfg file will be executed on a dedicated processor. Once you press OK, the point 

cloud generation starts. 

 
 

NOTE: Depending on the computation power, the image size, and the area for which the point 

cloud is generated, this process can take from a couple of minutes to hours.  

 

Q3. [80%]. Generate point clouds for two areas of interest, one a small rectangle and one for 

the entire overlapping area of two images (for example, the purple area in the image below). 

 

 
 

The results should contain three files: 

• A Word or pdf file that has snapshots with the Process Engine Settings Dialog windows, 

namely General and Format tabs. 

• Two las files.  
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5 Ortho-rectification 
 

Lab developed by Rong Fang and Dr. Strimbu from ENVI and ArcGIS documentation. 

 

5.1 Objectives: 

• Orthorectify an image using RCP 

• Automatically generate GCPs from an orthophoto base layer  

• Assess the errors of individual GCPs and the overall model accuracy. 

• Georeference an image using a vector map 

5.2 Overview 

An orthorectified image (or orthophoto) is one where each pixel represents a true ground 

location, and all geometric, terrain, and sensor distortions have been removed to within a 

specified accuracy. Orthorectification transforms the central perspective of an aerial photograph 

or satellite-derived image to an orthogonal view of the ground, which removes the effects of 

sensor tilt and terrain relief. Scale is constant throughout the orthophoto, regardless of elevation, 

thus providing accurate measurements of distance and direction. Geospatial professionals can 

easily combine orthophotos with other spatial data in a geographic information system (GIS) for 

city planning, resource management, and other related fields. 

 

An RPC model is a type of model that maps the physical relationship between 3D ground points 

and 2D image points. RPCs are not the same as a map projection. Most modern high-resolution 

sensors such as WorldView-3 and Pleiades include pre-computed RPCs with their imagery. 

The ENVI RPC Orth rectification tools use RPCs—along with x/y/z data from GCPs and 

elevation data from a high-resolution DEM—to create an orthorectified image.  

 

Automatic GCP generation is based on image matching between the reference and source images, 

so the scene contents should not be vastly different. Automatic GCP generation is more robust if 

the reference image and input image have a similar resolution. If the reference image has a much 

higher resolution than the input image (i.e., the ratio is greater than 2.5), down-sampling the 

reference image should be executed first. The DEM must cover at least the spatial extent of the 

input raster.  

5.3 Description of the files 

• OrbViewSubset.dat is a spatial subset of an OrbView-3 panchromatic image of Coral 

Springs, Florida, acquired on 16 January 2006. The image has the RPC information 

embedded in the hdr file. 

• NAIPReferenceImage.dat is a spatial subset of a National Agriculture Imagery Program 

(NAIP) image, acquired on 07 August 2007. 

• DEM.dat is a spatial subset of a National Elevation Dataset (NED) DEM image at 1/9 arc-

second resolution. 

• BolderSPOT.dat is a SPOT image of Boulder, CO from 1998. 

• Roads is a vector format of some roads from Boulder, CO, which are stored as a shapefile. 

The shapefile is made up of at least four files: .shp, .shx, .dbf, and .prj.  
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5.4 Orthorectification using RPC and DEM 

Most images supplied by an airborne or spaceborne sensor are unrectified, therefore there is 

distortion across the image caused by the terrain. The orthorectification process of an image 

removes the distortions and creates a planimetric image at every location (orthorectified) with a 

consistent scale everywhere within the image. In summary, orthorectification applies a 

transformation (stretches) to the image to match the spatial accuracy of a map by considering 

location, elevation, and sensor information. 

 

An accurately orthorectified image can be produced using the rational polynomial coefficients 

(RPCs) in conjunction with an accurate digital elevation model (DEM). Many companies, such as 

Digital Globe or GeoEye, deliver some of their images with the RPCs, which can be used to 

geometrically correct the unrectified image. DigitalGlobe stores RPC information in a .rpb file, 

whereas GeoEye images have the RPC information stored in a rpc.txt file. ArcGIS automatically 

reads RPC information in the associated text file (if it can be found next to the image file) and 

applies the RPC transformation (image correction) on the fly when displaying it in ArcMap. 

However, RPC information can be stored in the files defining the image, which is the case of 

ENVI images. The dat files used by ENVI store the RPC information inside the header file, hdr, 

which is in essence, an ASCII file. 

 

Q1 [10%]. Why orthorectification is important (at most three sentences)? 

 

Q2 [10%]. What is the main difference between parametric and nonparametric 

orthorectification (at most two sentences)?  

 

Q3 [10%]. Are RPCs popular in airborne or spaceborne orthorectification (at most two 

sentences)? 
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As you see, there is no coordinate system inside the header file, just the RPC info, which means 

that the image needs to be orthorectified and georeferenced. Usually, this process happens 

simultaneously in almost all the packages used for orthorectification. Therefore, the tools used for 

orthorectification will include the georeferencing tools too.  
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Launch ArcGIS, and choose a blank ArcMap page. Do not forget to save the file often, such that 

you will not lose a lot of your work in eventuality that ArcGIS or the PC will crash. 

1. In the main menu, click the Open button . 

2. Navigate to the directory where you saved the Lab data. Use Ctrl-click 

to select the OrbViewSubset.dat, NAIPReferenceImage.dat, and the 

DEM.dat 

3. Click yes for creating pyramids. 

 

The image will be displayed as follow: 

  
 

To start the orthorectification process, you should turn on the 

interface responsible for orthorectification, which is accessed by 

choosing Windows -> Image Analysis. This will open the Image 

Analysis windows.  

  

1. Under image analysis, select OrbViewSubset.dat and DEM.dat. 

Click Orthorectify button: . A temporary orthoimage is 

created (Ortho_OrbViewSubset.dat), which is shown on the top 

of the Table of Contents. The orthoimage is overlapped on the 

top of the reference image with a roughly similar location.  

 

 

 

2. In the main menu, choose Customize → Toolbars → 

Georeferencing. This will display the georeferencing toolbar.  
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3. After the image was orthorectified, it should be accurately georeferenced. In this lab, we will 

georeference it using another image, namely the NAIP imagery. In the Image, Analysis 

windows check the Ortho_OrbViewSubset.dat and NAIPRefereneImage.dat. In the 

Georeferencing toolbar, select Ortho_OrbViewSubset active image, and click on  , the 

Auto Registration icon.  

 
 

4. Auto registration will generate a series of ground control points (GCPs) to link the two 

images.  
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5. Click on View Link Table  in the georeferencing toolbar; you will see the summary of 

link table.  

 



Remote Sensing and Photogrammetry – Forestry Applications 

91 

 

6. You can examine the total Root Mean Square Error (RMSE). Display the links by descending 

order, to reduce the total RMS by deleting some of the links. To delete links with big error, 

select the link and click on the Delete Link icon .  

Q4 [10%]. What is the GCP with the smallest Error Magnitude value? And what is your total 

RMS Error? 

 

7. Exam the GCPs on the images. If you find the same GCP link is distant in the image, you can 

adjust their position to be as close as possible or delete it. For example, the pair of point 21 is 

far from each other, and you can move the point by using the Select Link icon (in 

georeferencing toolbar)  , or delete them. After the adjustment, reexamine the table of 

links. Repeat this step until all the pairs of links are within an acceptable distance.  

 

8. Save the link after you finish correcting the error. Open the table of link by click on . And 

in the table of link, click on , and save the .txt file under the folder of Week 5. Name it 

GCPs_Lab5.  

9. Rectify and create a new image file. After you finish correcting the links, select Rectify under 

Georeferencing (You may have to select the lab folder as the Output location).  

 
Leave all the settings as default. Save the image as Ortho_OrbViewSubset1.tiff.  

10. Click on Add the Ortho_OrbViewSubset1 layer to ArcMap.  

11. Compare Ortho_OrbViewSubset1 with NAIPReferenceImage. In the main menu, click on 

Customize →Toolbars, select Effects. Turn on the Effects toolbar. Click on  to swipe the 

image for comparison.  
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Q5 [10%]. Include snapshots of view with all the links (GCPs) distributed and Views of the 

image Ortho_OrbViewSubset1.  

 

 

5.5 Georeferencing an image using a map (vector) 

In many instances, the image is orthorectified but lacks the coordinate system. Therefore, you 

have to position the image in the correct location and to scale properly the image. When 

georeferencing using a vector layer, you should identify well-defined objects within your images, 

such as road intersections or land features, that can be found also in the vector. The selection of 

obvious land features ensures that the same locations in both the raster and the vector layer(s) are 

referenced.  

The data used for this exercise is the SPOT image for the city of Boulder, CO, from 1998, and the 

road network from the same area is stored as a shapefile (Roads.shp). The SPOT image does not 

have coordinates, and therefore must be georeferenced. To georeference an image in ArcGIS, we 

will be using the georeferencing tool that was used before.  

To display the Georeferencing toolbar, click the Customize menu and click Toolbars > 

Georeferencing.  

1. Upload the two files in ArcGIS: BoulderSPOT.dat and Roads.shp. 
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2. From the Georeferencing toolbar, click the drop-down arrow and select BolderSPOT.dat if 

its not already selected. 

 
3. Click Fit To Display (under Georeferencing drop-down menu), which will show the 

image in the same area as the target layers. You can Shift and Rotate the raster as needed. To 

see all the datasets, adjust their order in the table of contents.  

4. To georeferenced the image, you will use the same procedure as in the previous exercise, 

namely, find points that are visible in both files, then match them. Therefore, Click the Add 

Control Points tool  to add control points. To add a link, first, you should click a known 

location on the raster dataset, then click a known location on the vector layers in the Roads 

map, which serves as the reference data. You should be aware that the Rotate and Shift tools 

are not available after you place the first link. 

5. Add at least 10 links to georeference the image. Remember that you need a minimum 3 links 

for a first-order polynomial, 4 links for a projective transformation, 6 links for a second-order 

polynomial, and 10 links for a third-order polynomial or spline transformation. You should 

notice that as soon as you add points, the image starts being moved to its possible location, 

making the selection of points easier.  
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Image located after the first link 
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Image located after the second link 

 

6. To evaluate the transformation, click the View Link Table button  , where you can 

examine the RMSE for each link. If you're satisfied with the registration, meaning a 

RMSE<1, then you can stop entering links. To adjust the transformation, you can delete any 

unwanted links from the Link table. Remember that selection of the points is a tedious 

process that requires patience, as many points should be selected, deleted, or adjusted. 
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Link table for the first 6 links. 

 

7. Once you reach a comfort level in respect with the RMSE and number of links, click the 

Georeferencing drop-down menu and click either Update Georeferencing or Rectify. 

Updating the georeferencing will save the transformation information with the image as well 

as its auxiliary files, whereas Rectifying will create a new file with the georeferencing 

information. 

Q6 [10%]. Identify the links with the largest and smallest RMSE. Provide a snapshot with the 

Link table. 

 

Q7. [10%] Why there is a need of more than 3 links for an affine transformation (first-degree 

polynomial)? 

 

Q8.[10%]. Execute a first, second, and third-order polynomial transformation. What do you 

notice that happens to the image? Answer with at most five sentences.  

 

Q9. [10%]. Why you are recommended to spread the links (you can think on them as GCP) 

thought-out the image rather than on corners or on a line across the image? Provide a short 

answer, no longer than 3 sentences.  

 

Q10. [10%]. Include snapshots with all the steps needed for georeferencing.  
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5.6 Advanced topics: Ortho-rectification and Georeferencing 

Lab developed by Sudeera Wickramarathna and Dr. Strimbu from ERDAS documentation.  

 

5.6.1 Objectives: 

• Learn two different methods for performing rational polynomial coefficients 

(RPC) orthorectification 

• Automatically generate GCPs from an orthophoto base layer,  

• Use GCPs interactively to orthorectify the image 

• Assess the errors of individual GCPs and the overall model accuracy. 

• Automatically generate GCPs and perform RPC orthorectification in one step 

• Extract Ground Control Points (GCPs) from a vector layer (of roads) 

• Image to map registration:  

o build a warp model and georegister a SPOT scene to the map projection of the 

vector roads layer 

o use RMS error values to fine tune and adjust your warp model 

• use a vector layer (in this case the roads) to assess the accuracy of the registration results 

• automatic registration of image to image 

 

5.6.2 Overview 

An orthorectified image (or orthophoto) is one where each pixel represents a true ground 

location, and all geometric, terrain, and sensor distortions have been removed to within a 

specified accuracy. Orthorectification transforms the central perspective of an aerial photograph 

or satellite-derived image to an orthogonal view of the ground, which removes the effects of 

sensor tilt and terrain relief. Scale is constant throughout the orthophoto, regardless of elevation, 

thus providing accurate measurements of distance and direction. Geospatial professionals can 

easily combine orthophotos with other spatial data in a geographic information system (GIS) for 

city planning, resource management, and other related fields. 

 

An RPC model is a type of model that maps the physical relationship between 3D ground 

points and 2D image points. RPCs are not the same as a map projection. Most modern high-

resolution sensors such as WorldView-3 and Pleiades include pre-computed RPCs with their 

imagery.The ERDAS RPC Orthorectification tools use RPCs—along with x/y/z data from GCPs 

and elevation data from a high-resolution DEM—to create an orthorectified image.  

 

Automatic GCP generation is based on image matching between the reference and source 

images, so the scene contents should not be vastly different. Automatic GCP generation is more 

robust if the reference image and input image have a similar resolution. If the reference image has 

a much higher resolution than the input image (i.e., the ratio is greater than 2.5), down-sampling 

the reference image should be executed first. The DEM must cover at least the spatial extent of 

the input raster.  
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In many applications, it is critical to have an image align with either another image or a map.  

For instance, one major application where alignment is critical is image change detection.  If you 

wanted to compare two images from different dates to see where change had occurred, unless 

those two images matched up well (in terms of the geographic positions that they represent), 

accurate change detection would be impossible.  In order to ensure that images match up with 

each other, they must be represented by the same coordinate/reference system.  The process of 

Image georectification/ georegistration involves associating a remotely sensed image with a 

particular coordinate/ reference system.  There are many ways that this can be done, two such 

approaches being image to map registration and image to image registration. 

 

5.6.3 Description of the files 

• OrbViewSubset.dat is a spatial subset of an OrbView-3 panchromatic image of Coral 

Springs, Florida, acquired on 16 January 2006. 

• NAIPReferenceImage.dat is a spatial subset of a National Agriculture Imagery Program 

(NAIP) image, acquired on 07 August 2007. 

• DEM.dat is a spatial subset of a National Elevation Dataset (NED) DEM image at 1/9 arc-

second resolution. 

• BolderSPOT.dat is a SPOT image of Boulder CO from 1998 

• Roads.evf is a vector format of some roads from Boulder CO. 

• ikonos_4.0m.dat is IKONOS true-color image of Boulder, CO, at 4 meter spatial 

resolution 

• ikonos_4.0m.hdr is the header file of ikonos_4.0m.dat 

• quickbird_2.4m.dat is QuickBird true-color image of Boulder, CO, at 2.4 meter spatial 

resolution 

• quickbird_2.4m.hdr is the header of the quickbird_2.4m.dat 

 

5.6.4 Rectification Workflow 

1. In the File Tab, click the Open button, and then Raster Layer option in 2DView #1. 

2. Navigate to the Lab 5 directory where you saved the Lab data. Select and open 

OrbViewSubset.hdr file. 

 

NOTE: If you cannot find the respective images/files after navigating the Lab folder, you may 

need to select All File-Based Raster Formats from the Files of Types drop-down list. 

 If you want to make the current directory as the default directory, you can click  icon (third 

icon from left). Also, you can select a default output folder by clicking   icon (first icon from 

the right). These options will help you to select and add the files quickly to the ERDAS Content 

pane.  

 



Remote Sensing and Photogrammetry – Forestry Applications 

99 

 

 

3. Now right click on the image and select Fit to Frame to see the entire image. Then click on 

the Metadata option in the Home Tab so that you can view the image metadata.  

4. Once the Image Metadata dialog box is open, check the Projection Info: You will notice this 

image is missing spatial reference information. 

In the next steps, we are going to add spatial information to this image with the rectification 

process. Check if any other ERDAS windows opened. If so, close them. 

5. Go to Raster|Panchromatic Tab and click Control Points option  under 

Transform and Orthocorrect group.  

6. Next, Set Geometric Model dialog box will open, select 

Model List option, and scroll down the Select Geometric 

Model list. Select the Polynomial model from the list. 

 

7. GCP Tool Reference Setup dialog box will open and select 

the Image Layer option and click OK. 

 

8. Now Reference Image Layer will open, and you can enter 

the image that we are going to get the geographic reference 

points. Select “naipreferenceimage.img” as the reference 

image. 

 

9. The Reference Map Information dialog box will open with 

the Reference information. Check the information and click 

OK. 

 

10. Then Polynomial Model Properties Box will appear. You can select the Polynomial Order 

as 1 by using the up-down arrows. 

NOTE: If the Apply button is not activated yet, you can change the Polynomial Order to 2 and 

then the down arrow to return it to 1. This will allow you to be active in the Apply option. 

 

11. Click Apply and close the dialog box. Now, you should get a separate window (Multipoint 

Geometric Correction (MGC)) as follows:  

NOTE: This MGC window has two major panels. The right-hand side panel has the NAIP 

image, which is the reference image with geographic reference information. On the left-hand side 

panel, we have the uncorrected aerial image that is going to be rectified/georeferenced. Also, you 

will notice that each major panel has three windows. These windows help you to zoom and 

navigate to the exact position you are interested in. The white square box also will help you to 

focus on the areas you are interested. You can click on the edges of this white squares to change 

the relative scene of the pane it represents. Take some time to orient yourself to zoom and pan the 

images. 

o Left-hand side panel: Your Input image: Orbvirwsubset.img 

o Right-hand side panel: Your reference image: Naipreferenceimage.img 
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12. Now you need to find some geographical landmarks in the NAIP reference image. So, zoom 

in and zoom out the reference image (right-hand side image) and select some landmarks such 

as road intersections, buildings, or other permeant structures. You should not select structures 

that may change their appearance with time, such as river banks, trees..etc.  

 

13. Try to identify exactly the same landmarks in the left-hand side image as well. You can 

utilize options available in the MGC window to browse the landmarks easily. Also, you can 

always right-click on each image and fit the image into the window by selecting the “Fit 

Image to Window” option. 

   
 

 

14. Now select Create GCP option   from the MGC tool window. Now go to the left-hand 

side image panel (input:orbviewsubset.img) and select the highest zoom pane and click on the 

object you need to select. 
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15. Now go to the NAIP reference image (naipreferenceimage.img) panel and find the exact same 

point you selected on the input image. Click the Create GCP icon and click on the matching 

object in the Reference pane with the highest zoom. 

 

16. Now you will see that you have created the GCP in the reference image, and the points have 

been added to the attribute table at the bottom of the MGC window. Your input point data 

added to X Input and Y Input columns, and your reference point data added to X ref. and Y 

ref. Columns.  

  
 

17. You can continue the above steps and can add a minimum of 20 control points. Once you 

have enough control points, click Solve Geometric Model with Control Points icon . 

 

18. Also, you may need to save your work regularly. You can save your results by selecting 

options available in the File menu. Select Save Input As… to save points in the input image 

(left side of the screen) and select Save Reference As… to save the points on the reference 

image (right side of the screen). Save both files in the Lab 5 data folder with appropriate 

names.  
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NOTE: When you select the points, you may need to select the control points that cover the entire 

image. Also, check the Root Mean Square Error (RMS Error) column as well. If you can get a 

lower RMS error, it would be better for the results.  

However, if you think you need to delete a point due to higher RMS value or if you think points 

are clustered and need to remove some extra points, you can select the respective row by clicking 

the Point # column. Then right-click and select Delete Section.  

 

NOTE: X residual and Y residual give you an understanding of the contribution to the error by 

direction. So, you can decide which direction you should move your cursor to reduce the residual 

errors. RMS value is the resultant product of both X and Y residuals. Therefore, you may have to 

pick GCP’s with lower X and Y residuals to get a lower RMS Error.  

 

19. Once you have reached to the lowest RMS value that you can gain, now you can resample the 

input image pixels into geographic space. Click  icon to open the Resample dialog to 

specify the output file, resample method, and output information. 

20. You can save the output file as “resample_orbview.img” by navigating to the Lab 5 data 

folder. Make sure to keep the resampling method is Nearest Neighbor, and you can leave 

other values as it is (default values). Click OK. Close the process list table once the rectifying 

task is completed.  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

NOTE: This 

step may take 5-10 

minutes to 

complete (or more); once the progress is 100% complete, close the Process List dialog box and 
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MGC window as well. You can save the output of MGC in the data folder with an appropriate 

name (e.g., MGC_Orbviewmodel.gms). Now you have successfully completed the rectifying 

step. You can load the rectified image to the main View by navigating to the Lab 5 Data folder 

and selecting Open> Raster Layer. 

 

21. Add the “resample_orbview.img” to the main View and open the Metadata and check the 

projection information. 

Q1: Include a screen-shot of the metadata dialog box together with 

“resample_orbview.img”. 

 

5.6.5 Orthorectification  

 

1. Open a new window in ERDAS IMAGINE and add the image that you need to 

orthorectify. In this exercise, we will add Orbviewsubset.hdr image.  

2. Navigate to Raster| Panchromatic and select the Transform and Ortho group. Click 

the drop-down menu and select Ortho With Model Selection. 

3. Check Model List from Select the Model From. Then and select GeoEye/OrbView - 

Orbital Pushbrrom from the Select Geomaertic Model list. Click OK. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

NOTE: GeoEye/OrbView - Orbital Pushbroom  

Use this model for GeoEye or OrbView images in which RPC data is not available. This 

model is for data collected by GeoEye-1 satellite, developed by GeoEye, a company formed 

through the combination of ORBIMAGE and Space Imaging, as well as data collected by 

OrbView-3 satellite, built for Orbital Imaging Corporation (now GeoEye) (source: ERDAS 

IMAGINE (E.I.)). 
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Elevation Source for Orthorectification 

 

1. Once you have completed the above steps, another dialog box will open that is related to 

GeoEye/OrbView - Orbital Pushbroom RPC Model Properties. 

 

2. Elevation Source under the General tab allows you to set the elevation source for an 

image data file. This option is enabled for an image with a geometric model that uses 

an elevation value (Z).  

NOTE: This function is useful when you have several neighboring images because it will align 

them all to the same elevation source. You can set the elevation source to be a DEM file, a Z 

constant value, or use an Elevation Library. 

NOTE:  

File →  Click this radio button to obtain the elevation data from a DEM file. Select the File in 

the Elevation File field, below. 

Constant →   Click this radio button to use a constant value as the elevation information. 

You enter that value in the Elevation value field, below. 

Elevation Library → Click this radio button to use the data in the Elevation Library as the 

source. 
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3. Now you can navigate to your DEM file (DEM.dat) location and add it as the elevation 

source.  Click Apply 

4. Next, Resample Window will open.  

 

 

5. Check 

the 

Resample to 

output file 

option and 

name the 

File 

as“resample_ortholab5.img” 

NOTE:  If you want to attach a sensor model to an image without performing resampling, click 

to uncheck this checkbox. Then you can select Update Calibration option and write the 

geometric model information and elevation information to the *.aux file or image metadata as 

appropriate without producing a resampled image (E.I.). 

6. Under the Calibration option, you can select File and navigate to the DEM file 

DEM.dat  and add it. Calibration solutions report the current geometric model that you 

have assigned and allow you to select an elevation source for orthorectification.  

NOTE: Elevation Source provides the elevation source to be used in the geo correction. By 

default, Global Elevation Source proxy file, stored in the Elevation Library, will be 

available.   

7. You can select the Nearest Neighbor option as the Resampling Method. You can 

leave the rest of the features as default values and click OK. 

NOTE: Nearest Neighbor →  Assigns the value of the closest pixel. 

Bilinear Interpolation  →  Uses the data file values of four pixels in a 2 x 2 window to 

calculate an output value with a bilinear function. 

Cubic Convolution  →  Uses the data file values of 16 pixels in a 4 x 4 window to 

calculate an output value with a cubic function. 
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Bicubic Spline →  Uses a block size of 5 x 5 or larger. This method fits a cubic spline 

surface through the current block of points. The output value is derived from the fitting 

surface that retains the values of the known points. This option may be available 

depending on which type of data is currently displayed or used in a process. 

8. Now, navigate to the output file you just saved and open it in a new View. Compare it 

with the initial image. Add the “resample_ortholab5.img” to the main View and open 

the Metadata and check the projection information. 

Q2: Include a screen-shot of the metadata dialog box together with 

“resample_ortholab5.img”. 

 

 

 

5.6.5.1 Orthorectifying Without GCP (form ERDAS IMAGINE HELP) 
 

This workflow uses the method in which you do not have to load the image into a View. If the 

image is already loaded, you can still use this workflow. 

Select the Geometric Model 

1. Click Raster tab >  Geometric Calibration > Orthorectify without GCP. 

The Geo Correction Input File Selector opens. 

2. In File Selector, navigate to the image file to be orthorectified and select it. This File 

may typically be a TIFF file and has been rectified. Click OK. 

3. The Set Geometric Model dialog opens. 

4. If the specific sensor corresponding to your data is available, then click the [specific 

sensor name] - Orbital Pushbroom option. If the specific sensor is not available, 

click Orbital Pushbroom. Click OK. 

Select the Elevation Source 

The Orbital Pushbroom Model Properties dialog opens. 

1. In Elevation Source option, click File to navigate to the elevation source file and select 

it. 

Click Apply. 

The Resample dialog opens. 

Resample the Image 

http://localhost:8080/imaginehelp/html/index.htm#warptool_setmodelframe_lite.htm
http://localhost:8080/imaginehelp/html/index.htm#gi_gop_warppropframe.htm
http://localhost:8080/imaginehelp/html/index.htm#warptool_resampleframe.htm
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Resampling is the process of calculating the file values for the rectified image and creating the 

new File. All of the raster data layers in the source file are resampled. The output image has as 

many layers as the input image. 

ERDAS IMAGINE provides these widely-known resampling algorithms: Nearest Neighbor, 

Bilinear Interpolation, Cubic Convolution, and Bicubic Spline. 

 See Resampling Methods section in Producer Field Guide for more information. 

Resampling requires an input file and a transformation matrix by which to create the new 

pixel grid. 

1. In Resample dialog under Output File, enter a name such as [file_name_ortho.img] for 

the new resampled data file. This is the output file created from orthorectifying the 

rectified File. 

2. Under Resample Method, select Bilinear Interpolation. 

3. In Elevation Source, note that the elevation source file name that you selected is shown 

in DTM File option. 

4. Note the Output Cell Size values. The editable X and Y values are expressed in 

angular units of decimal degrees for a Geographic (Lat/Lon) projection. The non-

editable X and Y values are the nominal output cell sizes expressed in meters or feet as 

indicated, according to the Feet/Meters Units option. 

The software calculates recommended values, but you can change the values by 

clicking Feet/Meters Units button to open Nominal Cell Sizes dialog. In this dialog you can 

enter values expressed in meters or feet, and the software calculates the decimal degrees 

values. 

5. Click Ignore Zero in Stats., so that pixels with file values of zero are omitted when 

statistics are calculated for the output file. 

6. Click OK in Resample dialog to start the resampling process. 

The Process List dialog opens to let you know when the processes complete. 

7. Close the Process List dialog when the job is 100% complete. 

Verify the Orthorectification Process 

One way to verify that the input image has been correctly orthorectified is to display the 

resampled image and the input image and then visually check that they conform to each other. 

1. In a 2D View, load the input image. 

2. Click Home tab > Add Views > Create New 2D View. 

3. Open the orthorectified image in the second 2D View. 

https://hexagongeospatial.fluidtopics.net/reader/uOKHREQkd_XR9iPo9Y_Ijw/khBQoaH4ne8R6PVMWZ7Ubw
https://hexagongeospatial.fluidtopics.net/reader/uOKHREQkd_XR9iPo9Y_Ijw/khBQoaH4ne8R6PVMWZ7Ubw
http://localhost:8080/imaginehelp/html/index.htm#warptool_resampleframe.htm
http://localhost:8080/imaginehelp/html/index.htm#UnitsofMeasure.htm
http://localhost:8080/imaginehelp/html/index.htm#warptool_nominalframe.htm
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4. Click in 2D View #1 to make it active. Click Home tab >  Link All Views. 2D 

View #2 is now linked to 2D View #1. 

5. Click Home tab >  Inquire Cursor to open an Inquire Cursor in both Views. 

The Inquire Cursor (a cross-hair) is placed in both Views. An Inquire Cursor dialog also 

opens. 

6. Drag the Inquire Cursor around to verify that it is in approximately the same place in 

both Views. Notice that, as the Inquire Cursor is moved, the data in the Inquire Cursor 

dialog are updated. 

7. When you are finished, close the Inquire Cursor dialog. 

RPC Model 

In this workflow you are going to orthorectify an image by using an RPC model, which is 

typically used when rational polynomial coefficients (RPCs) are provided with the data. The 

RPC file contains a mathematical model of the image geometry, such as exterior orientation of 

the satellite when the data was collected. 

The RPC file contains rational function polynomial coefficients that are generated by the data 

provider based on the position of the satellite at the time of image capture. This File should be 

located in the same directory as the image(s) you intend to use in orthorectification. 

In the case of an NITF file, the RPC File field displays the image you are currently using in 

geometric correction because the NITF file contains RPC data internally. You can use an 

external RPC file if you wish. 

There are various RPC models available that use specific sensor systems. 

Select the Geometric Model 

1. Click Raster tab >  Geometric Calibration > Orthorectify without GCP. 

The Geo Correction Input File Selector opens. 

2. In File Selector, navigate to the image file to be orthorectified and select it. This File 

may typically be a NITF file. Click OK. 

3. The Set Geometric Model dialog opens. 

4. If the specific sensor corresponding to your data is available, then click [specific sensor 

name] RPC option. If the specific sensor is not available, click NITF RPC. Click OK. 

The RPC Model Properties dialog opens. 

5. Note the RPC File field. 

http://localhost:8080/imaginehelp/html/index.htm#warptool_setmodelframe_lite.htm
http://localhost:8080/imaginehelp/html/index.htm#gi_ikonos_warppropframe.htm
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This field displays the RPC file associated with the image. The RPC file contains rational 

function polynomial coefficients that are generated by the data provider based on the position 

of the satellite at the time of image capture. This File should be located in the same directory 

as the image(s) you intend to use in orthorectification. 

In the case of an NITF file, the RPC File field displays the image you are currently using in 

geometric correction because the NITF file contains RPC data internally. You can use an 

external RPC file if you wish. 

Select the Elevation Source 

1. In Elevation Source option, click File. This opens an Elevation File field where you 

can navigate to the elevation source file and select it. 

Click Apply. 

The Resample dialog opens. 

Resample the Image 

1. Follow the steps in Resample the Image section. 

Verify the Orthorectification Process 

1. Follow the steps in Verify the Orthorectification Process section. 

Orthorectify the Active Image 

To orthorectify an image that is loaded in a View, you choose a workflow depending on 

whether or not your sensor model is associated with the image. 

Sensor Model is Associated 

If the sensor model is associated with the image (calibrated), follow this workflow: 

1. Click Multispectral, Panchromatic, Thematic, or Relief tab (depending on the image 

type) >  Transform & Ortho  > Ortho Using Existing Model. 

The Resample dialog opens. 

2. Select the Elevation Source file in Resample dialog. 

3. Follow the steps in Resample the Image section. 

4. Follow the steps in Verify the Orthorectification Process section. 

Sensor Model is Not Associated 

http://localhost:8080/imaginehelp/html/index.htm#warptool_resampleframe.htm
http://localhost:8080/imaginehelp/html/index.htm#warptool_resampleframe.htm
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If the sensor model is not associated with the image (not calibrated), follow this workflow: 

1. Click Multispectral, Panchromatic, Thematic, or Relief tab (depending on the image 

type) >  Transform & Ortho  > Ortho with Model Selection. 

2. The Set Geometric Model dialog opens. 

3. Click the respective sensor model for your image, depending on whether the image has 

an RPC file associated with it or not. Click OK. 

Specify your Elevation Source file in RPC Model Properties dialog (for RPC data), or 

in Orbital Pushbroom Model Properties dialog (for non-RPC data). Click Apply. 

The Resample dialog opens. 

4. Follow the steps in Resample the Image section. 

5. Follow the steps in Verify the Orthorectification Process section. 

 

5.6.6 Registering an image to a vector map 

 

Vector data are stored as lists of coordinates, rather than as raster grids of numbers.  

These coordinates can be used to define points, lines, and polygons.  We are interested in vector 

data because map data, such as roads and forest cover, are usually stored in vector format.  

Vector layers that are already projected to represent specific reference/coordinate systems can be 

used as a reference in the image to map registration.  

To perform image to map registration process, ground control points (GCPs) are selected 

using the full resolution and Zoom windows. Coordinates are displayed for both base and 

uncorrected image GCPs, along with error terms for specific warping algorithms. Warping is 

performed using rotation, scaling, and translation (RST), polynomial functions (of order 1 

through n), or Delaunay triangulation. Resampling methods supported include the nearest 

neighbor, bilinear, and cubic convolution. A comparison of the input and reference images using 

multiple Views allow quick assessment of registration accuracy. 

 

The exercise below concentrates on just one form of Image to Map registration.  

 

1. In the File Tab, click the Open button, and then Raster Layer option in 2DView #1. 

2. Navigate to the Lab 5 directory where you saved the Lab data. Select and open 

“bldrspot.hdr” file. 

3. Now right click on the image and select Fit to Frame to see the entire image. Then click on 

the Metadata option in the Home tab so that you can view the image metadata.  

4. Once the Image Metadata dialog box is open, check the Projection Info: You will notice this 

image is missing spatial reference information. 

 

http://localhost:8080/imaginehelp/html/index.htm#warptool_setmodelframe_lite.htm
http://localhost:8080/imaginehelp/html/index.htm#gi_ikonos_warppropframe.htm
http://localhost:8080/imaginehelp/html/index.htm#gi_gop_warppropframe.htm
http://localhost:8080/imaginehelp/html/index.htm#warptool_resampleframe.htm
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In the next steps, we are going to add spatial information to this image with the rectification 

process. Check if any other ERDAS windows opened. If so, close them. 

5. Go to Raster|Panchromatic Tab and click Control Points option  under 

Transform and Orthocorrect group.  

 

6. Next, Set Geometric Model dialog box will open, select Model List, and scroll down the 

Select Geometric Model list. Select the Polynomial model from the list. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

7. Next, GCP Tool Reference Setup dialog box will open and select the Vector Layer option 

and click OK.  

 

NOTE: Vector Layer (New Viewer) is used to collect reference points from a vector layer 

loaded in the Reference Views in the Multipoint Geometric Correction workspace (source: 

E.I). 

 

8. A new dialog box will open ( Reference Vector Layer), and you need to navigate to your 

Lab 5 folder and select “Roads. shp”  file and click OK.  If you cannot see the Roads 

shapefile in the dialog box, you may need to select “All File-based Vector Format” from 

the drop-down menu under files of type.  

 

9. Next, Reference Map Information dialog box will open. It will show you the Projection, 

Datum, and Horizontal Unit of the vector file. Click OK. 

10. Then Polynomial Model Properties Box will appear. You can select the Polynomial Order 

as 1 by using the up-down arrows. 

NOTE: If the Apply button is not activated yet, you can change the Polynomial Order to 2 and 

then the down arrow to return it to 1. This will allow you to be active in the Apply option. 

 

11. Click Apply and close the dialog box. Now, you should get a separate window named 

Multipoint Geometric Correction (MGC). 
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12. Now Reference Vector file and Input image have opened in the MGC window. You can see 

that the Reference Vector File is containing a road network. We can use this file to collect 

reference points for the georeferencing process.  

 

13. Right-click on each pane (Left-hand side and Right-hand side) and select “Fit Image to 

Window.”  

14. Before we start creating GCPs, we may have to change the color of the GCPs.  Go to the 

Color column and select the first row. You will see an arrow mark for a drop-down menu to 

select a color. Select an appropriate color (do not add white). You can add color for GCPs in 

the reference image by following the same procedure as well.  

 

15. You can click Create GCP   icon to create new GCPs. The cursor will turn into a cross-

hair in the View. This tool must be locked to create GCPs repeatedly without having to click 

on this again. 

NOTE:     Click to unlock the tool currently in use. Once unlocked, you can enable 

different tools.     Click to lock the tool currently in use. 
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16. Next, you can select your first 

GCP in the input image by 

navigating to a road intersection 

that is clearly visible in both 

input and reference images. For 

this process, you can use 

zooming windows to select 

GCP accurately. 

 

17. Once you have placed your GCP in the Input image, you can move to the reference window, 

find precisely the same road intersection, and place your GCP cursor on that intersection.  

NOTE: You may have to check the nearby objects as well to confirm that you are selecting 

the same points in both images. 

 

18. When you are selecting the GCPs, you need to distribute them evenly throughout the image. 

Continue the above steps and can add a minimum of 30 control points. Once you have 

enough control points, click Solve Geometric Model with Control Points icon . 

19. Also, you may need to save your work regularly. You can save your results by selecting 

options available in the File menu. Select Save Input As… to save points in the input image 

(left side of the screen) and select Save Reference As… to save the points on the reference 

image (right side of the screen). Save both files with an appropriate name in the Lab 5 data 

folder. 

 

NOTE: When you select the points, you may need to select the control points covering the entire 

image. Also, check the Root Mean Square Error (RMS Error) column as well. If you can get a 

lower RMS error, it would be better for the results.  

However, if you think you need to delete a point due to higher RMS value or think points are 

clustered and need to remove some extra points, you can select the respective row by clicking the 

Point # column. Then right-click and select Delete Section.  

Also, You can move the GCP points over the image by clicking and dragging them to the place 

you need to move.  

 

NOTE: X residual and Y residual give you an understanding of the contribution to the error by 

direction. So, you can decide which direction you should move your cursor to reduce the residual 

errors. RMS value is the resultant product of both X and Y residuals. Therefore, you may have to 

pick GCP’s with lower X and Y residuals to get a lower RMS Error.  

 

20. Once you have reached the appropriate number of GCPs, you can now resample the input 

image pixels into geographic space. Click  icon to open the Resample dialog to specify the 

output file, resample method, and output information. 
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21. You can save the output file as 

“resample_bldr.img” by 

navigating to the Lab 5 data 

folder. Make sure to keep the 

resampling method is Nearest 

Neighbor, and you can leave 

other values as it is (default 

values). Click OK. Close the 

process list table once the 

rectifying task is completed.  

 

 

 

22. Now can go back to the 

ERDAS IMAGINE main 

window and add a new View. Once you added a new window, you can add 

“resample_bldr.img” that is just completed. Navigate to Road.shp file and add it to the same 

View.  

23. You can see that the Road network overlaps with the actual road network on the 

“pldrspot.hdr” (Satellite image) image.  
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24. Click on Road.shp on the Contents pane. A new Vector Tab will be open. Go to 

Vector|Style and select appropriate color and line style so that you can see the road network 

clearly on the satellite image.  

Q3: provide a snapshot of your rectified image with the road network. Also, provide a 

snapshot of the metadata window for the resample_bldr.img. 

 

 

5.6.7 Image to image registration 

 

Image to image registration, also know and image co-registration, is the process of 

geometrically aligning two or more images to integrate or fuse corresponding pixels representing 

the same objects. You can typically obtain the geometric relationship between an input image and 

a reference image through many tie points, and you can model the relationship using 

transformation capabilities, such as polynomial functions or affine transform. Run APM tool 

allows you to automatically generate tie points, thus making fully automatic image registration 

possible. 

The IMAGINE AutoSync Workstation is a comprehensive tool to perform manual 

orthorectification and geo-correcting for images. Using this workstation, you can load input and 

reference images (when geo-correcting images), select a sensor model, run automatic point 

measurement (APM), rectify images, create an AutoSync summary report, and output image 

verification. You can also manage your AutoSync project, modify parameter files, and perform 

data visualization. Use the IMAGINE AutoSync Workstation for complex workflows since it 

provides more flexibility and tools for visual results inspection and manual digitizing. All areas 

of the workstation are resizable except for the menu bar and the toolbars (source: ERDAS 

IMAGINE). 

In this lab, you will use the IMAGINE AutoSync Workstation in different scenarios to 

geometrically align two overlapping images with different viewing geometry and different terrain 

distortions into the same coordinate system so that corresponding pixels represent the same 

objects. In the following steps, you will perform image registration by selecting input and 

reference images, setting parameters to generate tie points, reviewing and editing those tie points, 

and generating an aligned output image. 
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1. You can start the IMAGINE AutoSync process by navigating to Toolbox Tab. Now, 

select the AutoSync Workstation icon  and 

select  AutoSync Workstation option. 

2. A new dialog box will open. If you are doing this process for the 

first time, you can select Create a new project.  

3. Now you will see the Create New Project dialog box, and you can 

select Workflow as Georeference and type Project File as 

“Autosync_lab5”. Then select the Resample option for 

Geocorrection and leave other settings as default.  

4. You can go to IMAGINE AutoSync Workstation window and 

add the input image and the reference image to the project using the 

left-hand side panel.   

Input image: ikonos_4.0m.hdr 

Reference image: quickbired_2.4m.hdr 

 

5. Now you can select the input image by right-

clicking the Input Images tab and select Add 

Input Image. Navigate to your Lab folder and 

select “Ikonos_4.0m.hdr” as the input image. 

6. Then you can select the Reference Image by 

right-clicking the Reference Images Tab and 

select Add Input Image. Navigate to your Lab 

folder and select “quickbird_2.4m.hdr” as the reference image. 
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NOTE: You can check the Metadata for both the images by selecting the icon in the 

Workstation window.  

 

Q4: include the snapshot of Metadata for both the images.  

 

Now we will create tie points to establish the initial spatial correlation between the input 

image and the reference image.  

 

7. You can choose specific tie points manually by selecting specific locations such as road 

intersections or corners of buildings. 

8. First, select the Create CGP icon and select a road intersection in the input image 

and then select the same location in the reference image. You can select the magnifier 

windows to zoom locations you are interested in.  

9. Add only two GCPs to be familiarized with selecting the points.  

NOTE:  When using the Georeferencing workflow, you can adjust the algorithm settings that 

control the placement of automatically generated tie points in your images on the APM 

Strategy tab. Automatic point measurement (APM) identifies similar features between the input 

image and the reference image. Depending on the quality and type of imagery, you may need to 

try different strategies to find a large number of high-quality points (source: ERDAS IMAGINE 

(E.I.)). 

 

10. Now we can run the APM by Selecting Run APM option by Clicking Process from the 

Imagine AutoSync Workstation menu bar. 

11. Now you will see automatically generated APM points in both input and reference 

images. Check the RMSE value and record the value.  
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12. Let us look at some important settings behind the APM process. Go to process and select 

Project Properties. IMAGINE AutoSync Project Properties dialog box will open.  

 

13. Go to the APM strategy tab and check the Starting Column, Starting Line, Column 

Increment, Line Increment, and Output Geometric Model Type under the Geometric 

Model. Record this information. You need this information to answer the questions in the 

later part of this section.  

14. Now let's look at some features available in the APM strategy tab. 

Defined Pattern: This has many options, including Starting Column, Starting 

Line, Column Increment, Line Increment, Ending Column, and Ending Line. Using 

those options, you can define the exact placement of tie points throughout the images of 

the block. With this option, you also define the intended number of points per pattern. 

 

NOTE: If you want to define a tie point pattern, select the Defined Pattern. However, you 

should consider the overlap percentage when you define your own pattern and try to get each 

pattern location inside as much of the overlap as possible (source:E.I). 

Under Defined Pattern:  

• Starting Column and Starting Line have setup the default value as 128. These 

values are important if APM does not find enough points along the edges of the 

overlapping area, then reduce the size of the Starting Column and the Starting Line. 

• Column Increment and Line Increment have set up the default value as 256. 

These values are important if the overlapping area between the images is not big 
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enough, or if APM does not find enough tie points, then reduce the size of 

the Column Increment and Line Increment. 

 

 
 

15. Run the APM process with default values (click OK). Look at the RMS value and record 

it. Also, take a snapshot of IMAGINE AutoSync Workstation and save it to refer to the 

distribution of tie points later.  

NOTE: You need to select (if it is not selected by default) Automatically Remove Blunders 

checkbox to remove blunders (wrong tie points) automatically from the APM generated tie 

points.  

When this option is selected, the points that do not fit well with the majority of tie points are 

considered as blunders and are discarded. By default, this option is selected. You should deselect 

this option only if you suspect that it is removing correct tie points. For example, you should 

deselect this option when most of the APM tie points are wrong or when there is a large 

difference in the terrain between the two images. 

 

Maximum Blunder Removal Iterations: This option becomes available when you 

choose Automatically Remove Blunders option. The default is 2. In most cases, increasing this 

number means more iterations of the blunder removal algorithm will be run. As a result, more tie 

points will be considered as blunders and discarded (source: E.I.). 
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16. Now, you can do the APM process again by changing the default values. Try to assign the 

Starting Column and Starting Line values to 64 and Column Increment and Line 

Increment values to 128. Check the RMS value and distribution of tie points. Record 

the RMS value and save the snapshot of IMAGINE AutoSync Workstation. 

Q5: Describe the observations you just made by changing the values, particularly how the 

RMS values changed. You can add saved snapshots to illustrate your answer.   

 

17. Now navigate to the Geometric Model tab on the 

IMAGINE AutoSync Project Properties. You can do this by Clicking Process 

> Project Properties... from the IMAGINE AutoSync Workstation. Then, click the 

Edit Project Properties icon  on the toolbar. 

 

18. You well see the Output Geometric Model Type as Affine transformation by default. 

This  Affine geometric model allows the image to be flipped, rotated, or scaled. The 

results you obtained so far are related to Affine transformation. 

19. Now, you can try to change the Output Geometric Model by selecting the option available 

in the drop-down menu. Select the Polynomial option. By selecting this option, you can 

use the polynomial function to perform surface approximation.  

NOTE: The polynomial geometric model uses polynomial coefficients to map between image 

spaces. This option corrects the remaining error and refines the mathematical solution. This is the 

fastest algorithm but does not produce the best results. 

 

20. Once you have selected the Polynomial geometric model type, you will see the 

Maximum Polynomial Order option.  

NOTE: This is the maximum polynomial order allowed 

for polynomial approximation. The 1st order is an affine 

transformation. The 2nd order results in a second-order 

transformation; the 3rd order a third-order 

transformation (source: E.I).  

The higher the transformation order, the more 

complex the distortion that can be corrected. However, 

transformations higher than third order are rarely 

needed. Higher-order transformations require more 

links and, thus, will involve progressively more 

processing time. 

In general, if your raster dataset needs to be stretched, scaled, and rotated, use a first-order 

transformation. If, however, the raster dataset must be bent or curved, use a second- or third-order 

transformation. 

(Source: ESRI ArcMap, Fundamentals of georeferencing a raster dataset: 

https://desktop.arcgis.com/en/arcmap/10.3/manage-data/raster-and-images/fundamentals-for-

georeferencing-a-raster-dataset.htm). 

 



Remote Sensing and Photogrammetry – Forestry Applications 

121 

 

21. If you need to use a higher order of transformations, you need to have more GCPs. In 

order to achieve the best rectification results, you may need to collect more than the 

minimum number of GCPs, and the GCPs need to be well-distributed and as precise as 

possible.  

22. If you do not observe improvement after you run the polynomial model by selecting the 

 icon or process> Solve models, you can change the Maximum Polynomial Order 

into 2. Report your RMSE value. Have you noticed an improvement in RMSE value?  

 

23. Alternatively, you can sort the Error column and can delete the rows with higher error. 

Once you delete those tie points, you can re-run the model and observe the RMSE value.  

 

24. To finish this process, you can right-click on “ikonos_4.0m.hdr”  on the left-hand side 

panel, and select Calibrate/Resample. 

25. Now you see the output image and reference image have been added to the main window. 

Also, the output image is added to the lefthand side pane under the Output Image option. 

 

26. So, we can do some qualitative assessment by comparing the output image and the input 

image by utilizing the Start Swipe Tool in the toolbar. 

27. You can move the Swipe Position bar to see how the input image and output image 

matching each other.  

 
 

 

Q6. Include a snapshot of your Output image with your reference image. 
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6 Image Classification 
 

Lab developed by Rong Fang and Dr. Strimbu from the notes of Dr. Hilker and ENVI documentation.  

 

Note: throughout this lab, the terms class, category, and land-cover type can be taken to mean 

the same thing and are used interchangeably. 

6.1 Objectives 

• Define areas of interest (ROI) 

• Exploring spectral properties with 2D Scatter Plots 

• Execute supervised classification of images 

• Assess the quality of the classification 

6.2 Files to be used in the Lab 

• LandsatTM is a Landsat 5 image of the Gulf Islands from south BC acquired in 2006. 

Before beginning the lab, you should visit the last page and examine the Submission section. 

6.3 Supervised Classification 

Supervised classification of remotely sensed data begins with delineating boundaries around 

groups of spectrally similar pixels, known as “training areas”, which are representative of specific 

land-cover types.  The location of training areas might be determined in the field using GPS; 

interpreted directly from other forms of remotely sensed data (e.g., aerial photography); or from 

other sources available for use in GIS software (i.e., existing digital maps). Training areas (i.e., 

groups of spectrally similar contiguous pixels) representing specific land-cover classes, once 

delineated, are used to calculate statistics characterizing the distribution of pixels’ Digital 

Numbers (DN) in all bands/channels representing each particular land-cover type.  Some of these 

statistics include Minimum, Maximum, Mean, and Std. Dev.  These statistics are used to assign 

membership to a class/category (land-cover type) for each and every image pixel through the 

application of an image classification algorithm (e.g., Maximum Likelihood).   
 

In summary: groups of spectrally similar contiguous pixels are delineated and act as training 

areas representing specific land-cover types/classes/categories.  The digital numbers/values 

associated with these training areas are then summarized.  The summaries facilitate assigning 

membership to all other pixels in an image.  Membership for each individual pixel is assigned 

based on the values representing a particular class that are closest to the values contained in an 

unclassified pixel. The end result is a classified image displayed with colors assigned to represent 

each class/category/land-cover type. 
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6.3.1 Image Overview 

The data used in this lab is a Landsat TM image acquired on July 23 2006. The image contains 

six bands: b1 (blue); b2 (green); b3 (red); b4 (near-infrared (NIR)); b5 (shortwave infrared 

(SWIR)) and b7 (SWIR).   

Q1 [10%].  Landsat band 6 is not included in the layer stack and is therefore purposefully 

excluded from this classification exercise.  What portion of the electromagnetic spectrum 

does this band represent, and why do you think it is not included (two sentences)? 
 

From the available bands list, display an RGB color composite, using bands 1 (blue), 2 (green) 

and 3 (red).    
 

Q2 [10%]. What is a true color composite (one sentence)?  What region of the 

electromagnetic spectrum defines it (one sentence)? 

 

Open ArcGIS, and save your project immediately, even that is empty. Add the LandsatTM image 

from Week6_Data. Set the display band as Red: band 3, Green: band 2, and Blue: band 1. 

Change the layer name to “LandsatTM_TrueColor”, by right-clicking on the layer, and choose 

Properties → General, then typing LandsatTM_TrueColor in the Layer Name box.  

 

Add Base Image provided by GIS as reference. Click  → Add Basemap → Imagery → 

Add. The Basemap layer will appear in the Table of Contents. Right-click on the 

LandsatTM_TrueColor layer, choose Zoom to Layer. The Basemap contains layers with a 

resolution of 15m, 60cm, and 30cm.  

6.3.2 Collecting training area of classes 

1. To classify an image using supervised methods, first, you must start the Classification 

menu. Therefore, in the main menu, choose Customize → Toolbars → Image 

Classification.  Make sure LandsatTM_TrueColor appears in the drop bar of Image 

Classification.   

 
 

Supervised classification requires identification of training areas. We are using the Base Image 

provided by ArcGIS as a reference in the delineation of training and testing areas.  DO NOT 

define the training areas in the Base Image itself, because this may take up too much memory. 

The polygons should be drawn in the Landsat imagery. If the LandsatTM layer is under the Base 

Image, drag it above the Base Image in Table of Contents.  
 

2. To best utilize the Base Image as reference, open Effect toolbar, in the main menu 

Customize → Toolbars → Effects, set LandsatTM_TrueColor as the active image in the 

Effect toolbar. Use the Swipe tool  to swipe the Landsat image to compare it with the 

Base Image.  
 

To classify the Landsat TM image, we will delineate polygons for several land-cover categories. 

There is no specific rule dictating how many land-cover categories should be created; however, 
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bear in mind that a land-cover class is only realistic if it is spectrally unique and observable at the 

spatial resolution of the imagery.  In other words, the spatial and spectral resolution of Landsat 

imagery in most cases allows for distinguishing between taxonomic tree types, such as broadleaf 

and coniferous, but do not permit separating specific tree species, such as Douglas-fir and 

Western redcedar.  Therefore, defining broadleaf and conifer as target land-cover categories is 

practical and achievable, as these are realistic spectral classes, whereas classes based on specific 

tree species (e.g., Douglas-fir and Western redcedar) are unrealistic as these information classes 

(i.e., species type) are not spectrally distinguishable by the Landsat TM sensor. 

 

When considering Landsat imagery, beyond forests, other types of vegetation can be 

distinguished.  For instance, oftentimes, areas dominated by herbs, shrubs and/or agricultural 

growth will appear spectrally different to forests in Landsat imagery; however, these non-forest 

vegetation types may appear spectrally similar to each other.  An exception to this relates to 

vegetation health, which can be associated with things such as stress (due to water shortage 

and/or pest infestation).  Furthermore, the time of year is important.  Due to phenological 

properties, vegetation may appear very differently in July and January. 
 

Beyond vegetation, other types of land-cover features are spectrally identifiable in Landsat 

imagery. These may include classes relatable to water and/or man-made features. 
 

Q3 [10%]. When classifying images using spectral information, what characteristics of the 

image are not considered explicitly (one sentence)? To answer this question, think back to 

the advantages provided by remote sensing, such as nadir view or information on 

wavelength invisible to the human eye. 
 

3. To distinguish vegetation from the rest of the land cover better, add LandsatTM again, 

and display it as false color. You should set band 4 as red, band 3 as green, and band 2 

as blue. Name the newly added false-color image as LandsatTM_FalseColor. Compare 

the different land covers (vegetation, water, urban, pasture, etc.) in the three images 

(Landsat true color, Landsat false color, and base image).  
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4. To begin the classification process, in the Image Classification toolbar, click on Draw 

Polygon  , which will turn on the drawing option. If the true-color image is not used 

than make sure that is selected. If the polygon option is not selected, then choose to draw 

polygon from the drop-down menu. Navigate to an area of interest (that you belief to 

represent a specific land-cover category).  Also bear in mind that your Draw Polygon 

only corresponds to one of your active images displays.    
 

5. Once you have outlined the shape/perimeter of a feature/area of interest, double clicks 

will close the polygon. If you are unhappy with the polygon that you have just completed, 

at any point, you can delete the polygon by clicking Clear Training Samples icon   

in the image classification tool. Keep delineating more training areas for one class. To see 

all the polygons belong to different classes, you should click the Training Sample 

Manager icon  in the Image Classification tool, which will open the Training Sample 

Manage. To create a class from the delineated polygons, you must group them.  

 

6. Select all the polygons belonging to one class by simultaneously pressing Shift and the 

left mouse button. Once all the polygons were selected, press Merging Training 

Samples icon  , and all the classes will be integrated into one. It is good practice to 

change the Class Name, Value, and Color of the class that you just created to something 

that is easy for you to identify. Repeat these steps to create at least six classes. For 

example, the six classes could be Water, Conifers, Broadleaf, Grass, Developed area, 

and Bare land. If they were delineated in that order, the corresponding indexing values 

would be 1, 2, 3, 4, 5, and 6.  
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Q4 [10%]. What properties of vegetation are mainly responsible for reflective/absorptive 

characteristics in the red and the NIR (one sentence)? 

 

NOTE: SAVE YOUR FILE OFTEN!  In Training Sample Manager, click then, save the 

training polygons as a shapefile. If you close the program, the polygon file with the selected 

training area will still exist. 

 

You can also use the help from World Imagery to identify the land use/land cover class and 

delineated the polygons if it is difficult to identify the objects.  
 

• For every land-cover class, you need multiple polygons.  It is better (and required!) to have 

numerous small class-specific training areas spread out throughout the image than it is to have 

only a couple of very large training areas.   
 

• To capture class variability, you should have at least 10 different polygons per class as evenly 

spread throughout the image as possible.   

 

Q5 [10%]. Why it is recommended that the training areas to be spread across the image? 
 

• The total number of pixels occupied by all polygons in a class should be at least 100, but in 

general, it should be much larger (i.e., > 1000). Remember that the number of pixels is class-

specific.   
 

• For vegetation classes and water, you are REQUIRED to have 10 polygons per class totaling > 

250 pixels (per class).   
 

• For all other classes (i.e., barren and exposed; low density developed; high density developed; 

and any additional classes you may have defined) you are required to have 10 polygons per class 

with at least 100 pixels per class.  

Merge multiple polygons 

to a single class 
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Q6 [10%]  How many land-cover categories are you using?  What are the areas described 

by each (i.e., water, trees, grass, buildings, bare, etc.)?  Provide a screenshot of your 

training polygons distribution in your final submission.  

6.3.3 Image Classification 

Once the training areas are delineated, you can classify the Landsat TM image. In this lab,you 

will be using the Maximum Likelihood classification algorithm and all 6 bands as input.  Save 

the final selected training polygons as the LandsatTM_class.gsg file. By clicking on the Create 

Signature file icon    available in the Training Sample Manager window. In the drop-down list 

of the Image Classification tool, choose Interactive Supervised Classification. Classification 

will be executed with maximum likelihood by using the sample data. The classified layer will be 

automatically added in the Table of Contents.  

 

 

Q7 [10%]. Provide a screenshot of your classified image of the true color image, with Table 

of Contents showing the classes as below:   

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Q8 [10%].  Briefly describe (2 sentences) the nature of Maximum Likelihood classification. 
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6.4 Classification Accuracy 

6.4.1 Visual examination  

 

We will now explore the quality of the classified image. For visual purposes, you can change the 

colors assigned to your classes to make the classes more distinguishable. Use the Effects toolbar 

to set the classified image as an active image.  

 
 

1. Now, navigate around the classified image and compare it to the original image and the 

false-color image. Ask yourself:  was this a successful classification?  Does the 

distribution of classes make sense?  Are there any areas of major misclassification?  

Would you feel comfortable and confident passing along this map to someone who would 

then make “real world” decisions based on it? 

 

Q9 [10%]. Justify the visual quality of the image by describing two issues and two successes 

of the classification (four sentences). 

6.4.2 Formal assessment of accuracy using Ground Truth Regions of Interest 

To formally assess the accuracy of the classification with the ground truth sample, we need to 

create a layer of ground truth, which will be compared with the classified image.  

2. Open ArcCatalog , and navigate to the week 6 folder. Right-click the folder, choose, 

and New → Shapefile. Name the shapefile as GroundTruth and select type point. Set 

the coordinate system the same as the Landsat image. Click Edit, and click  to choose 

Import. Navigate to folder were you save the Landsat TM image and select LandsatTM. 

Click OK. Projected coordinate system: UTM_Zone_10N and Geographic Coordinate 

System: GCS_WGS_1984 are selected. Click OK.  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Next, we need to point the ground truth sample data. Let’s take the class Water as an example.  
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3. Enable the edit of GroundTruth layer.  

Open Editor Toolbar: in the main menu, choose Customize → Toolbars → Editor. In 

the drop-down list of Editor, select Start Editing. Choose GroudTruth as the layer for 

editing. And click OK. In the editor toolbar, click Create Features icon . In the 

Create Features window, click GroundTruth, and in the Construction Tools, choose 

Point. Now you are able to choose the reference points on the top of the LandsatTM 

image.  

 

 

 

   

 

 

 

 

 

 

 

 

4. Choose reference ground truth points of water.  

Make the false-color Landsat image on the top of all raster images for the best visual 

effect.  Put points on the top of the water in the Landsat image. At least ten points need to 

be selected. Same as the training data for supervised classification, the reference points 

need to be evenly distributed among the entire image, covering a wide range of water 

(fresh and saline water). You can change the color and the size of the points for better 

examining the distribution of them. To change the size and color of the points, in the table 

of contents, click on the symbol of the layer GroudTruth.  After finishing selecting the 

water points, in the Editor toolbar, choose Save Edits and Stop Editing.  

 
 

5. Editing the attribute table of layer GroundTruth.  
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In the Table of Contents, right-click the layer GroundTruth, choose Open Attribute 

Table. We need to create two other columns to give the identity of the selected points. In 

the attribute table, click the Table Options icon . Choose Add Field. The first field is 

the Land cover is the Name , and select  text for the type field. The second field is Class 

identify, and it is a short integer type. Set the two fields as below.  

 

 

 

 

 

 

 

 

 

 

 

6. Add value to the Landcover field. Right click on the title of the Landcover column. 

Choose Field calculator. Add the newly selected point land cover type as “water”. Since 

Land cover is string type attribute, you need add quote to the text when adding it in field 

calculator.  Type “Water” in the Field Calculator as follow. Water is added to the 

Landcover column of the selected points. Similarly, the class of the water should be given 

as 1. To make sure the attribute table can be edited with Field Calculator, you need 

Save edits and Stop Editing, every time you finish editing one type of ground truth 

points.  

 

 

 

 

 

 

 

 

 

 

 

7. Repeat step 1 ~ 3 to select reference points of the second class. Take Conifers as an 

example—selected reference points located on the dark red vegetation area with the rough 

texture.  
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Editing the attribute table of the newly selected points is a little 

different from the first class. Open the attribute table again. You 

will see the class column of the newly selected conifer points is 

0. Let us only work on the conifer points. In the attribute table, 

click , choose Select By Attributes. 

 

In the Select by Attributes window, type selection criterion: 

“Class” = 0. In the attribute table, items with class value 0 are 

highlighted. Click  to make only selected items are shown. 

Follow step 3 to make the Landcover type as Conifers and 

Class as 2.  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Repeat step 1 ~ 4 to finish selecting reference points for other classes according to your 

classification. In my case, the six classes are Water, Conifers, Broadleaf, Pasture, 

Developed, and Bare land.  

 

8.Convert the shapefile to raster.  

To compare the ground truth layer to the classified image, you need to convert the 

shapefile to a raster file. Before conversion, make sure the attribute table GroundTruth 

point is deselected. Open the attribute table of GroundTruth, click   to clear the 

selection.  

Open Toolbox , choose Conversion Tools → To Raster → Point to Raster. Type 

the parameters in Point to Raster as below. Set Class to Value field. Save the output 

raster file under the folder Week 6, and name it as RefRaster.tif. Make sure the Cellsize 

is 30, which is consistent with the Landsat TM image. The raster layer will be 

automatically added to ArcMap.  
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9.Combine the reference layer and the classified layer.  

Export the classified layer. Right-click the classified layer, choose Data → Export Data. 

Name the file as ClassifiedTM.tif , and save it in folder Week 6. Select yes to add the 

exported file as a new layer.  

  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Next, we need to use Spatial Analyst Tools in the Toolbox. So make sure your Spatial 

Analyst Tools is enabled. In the main menu, choose Customize → Extensions, and check 

the box of Spatial Analyst. Open Toolbox , navigate to Spatial Analyst Tools → 

Local → Combine. Choose the ClassifiedTMand RefRaster as the input rasters. Save the 

output raster at the Week 6 folder. Name it as Combined. The layer Combined will be 

automatically added to the ArcMap. Right-click the layer Combined, and open the 

attribute table.  

Next, we need to export the attribute table and work it in Excel. In the attribute table, 

click  and select Export. Name the exported table as ConfusionMatrix and save it as 

.txt type at the folder Week 6.  
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10. Create confusion table in Excel. 

Find the file ConfusionMatrix in the folder Week 6. And change the extension name of 

the ConfusionMatrix from .txt to .csv. Open Excel and open the file ConfusionMatrix 

from folder Week 6 by using File/Open. Delete the column Rowid and Value. Select all 

the columns and choose Insert in the main menu. Choose PivotTable . In the Create 

PivotTable window, click OK.  

 
 

In the Pivot Table sheet, you will see the Pivot Table Fields. Choose or drag Rows: 

RefRaster, Columns: ClassifiedTM, and Values: Count. The two-way table will be 

created as below.  
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Copy and paste the two-way table in a new sheet.  

 
Change the titles of the classes to their land cover types.  

 

 

 

 

 

 

In the two-way table, the count in the diagnosis is the number of pixels that are correctly 

classified. Let’s take class Conifers as an example. In the Ground Truth sample, there are 

51 pixels selected as the Conifers class. However, 50 of the 51 conifer pixels are correctly 

classified as conifers in the classified image, and 1 of them are classified as pasture. 

Totally, 56 pixels of the ground truth raster are classified as Conifers. However, only 50 

of the classified conifer pixels are correctly classified in the right class.  

 

The omission error of Conifers classification: 

(1/51) * 100% ≈ 2%. 
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That can be explained as classification fails to classify 2% of the reference conifer sample 

to the right class.  

 

The commission error of the Conifers classification: 

(6/56) * 100% ≈ 11%. 

That can be explained as 11% of the classified conifer pixels are wrongly classified.  

 

Let’s update the confusion matrix. The table below shows the red parts are wrongly 

classified, and the green parts are correctly classified. The yellow parts are the total 

number of pixels classified to a certain class. The blue parts are the number of pixels that 

belong to each ground-truth class. Commission error is calculated as the sum of red 

number in each column divided by the yellow parts (sum of the pixels in the classified 

raster). Omission error is calculated as the sum of the red number in each row divided by 

the blue parts (sum of the pixels in the ground truth reference raster).  

 
 

Q10 (10%). What are omission error and commission error? Provide a screenshots of your 

final confusion matrix.  

 

6.5 Advanced topics: Image Classification with ERDAS  
 

Lab developed by Sudeera Wickramarathna and Dr. Strimbu from the Dr. Hilker and ERDAS documentation.  
 

Note: throughout this lab, the terms class, category, and land-cover type can be taken to mean 

the same thing and are used interchangeably. 

6.5.1 Objectives 

• Exploring spectral properties with 2D Scatter Plots 

• Execute supervised classification of images 

• Define areas of interest (ROI) 

6.5.2 Files to be used in the Lab 

• LandsatTM is a Landsat 5 image of the Gulf Islands from south BC acquired in 2006. 

6.5.3 Supervised Classification 

Supervised classification of remotely sensed data begins with delineating boundaries around 

groups of spectrally similar pixels, known as “training areas”, which are representative of specific 
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land-cover types.  The location of training areas might be determined in the field using GPS; 

interpreted directly from other forms of remotely sensed data (e.g., aerial photography); or other 

sources available for GIS software (i.e., existing digital maps). Training areas (i.e., groups of 

spectrally similar contiguous pixels) representing specific land-cover classes, once delineated, are 

used to calculate statistics characterizing the distribution of pixels’ Digital Numbers (DN) in all 

bands/channels representing each particular land-cover type. Some of these statistics include: 

Minimum, Maximum, Mean, Std. Dev. These statistics are used to assign membership to a 

class/category (land-cover type) for each image pixel by applying an image classification 

algorithm (e.g., Maximum Likelihood).   
 

In summary: groups of spectrally similar contiguous pixels are delineated and act as training 

areas representing specific land-cover types/classes/categories. The digital numbers/values 

associated with these training areas are then statistically summarized.  These statistical 

summaries facilitate assigning membership to all other pixels in an image.  Membership for each 

individual pixel is assigned based on the values representing a particular class closest to the 

values contained in an unclassified pixel. The end result is a classified image displayed with 

colors assigned to represent each class/category/land-cover type. 
 

To familiarize your self ith the image, open the LandsatTM file in your main View.  This is a 

layer stack representing 6 bands/channels of Landsat TM imagery acquired on July 23, 2006; 

wherein: b1 (blue); b2 (green); b3 (red); b4 (near-infrared (NIR)); b5 (shortwave infrared 

(SWIR)) and b6 (SWIR).  NOTE: Band 6 in this layer stack is actually Landsat Band 7 (SWIR).   

From the available bands' list, display an RGB color composite, using bands 1 (blue), 2 (green), 

and 3 (red).  This will display a true color composite. In the Main Image View, Adjust 

Radiometry, choose Standard Deviation Stretch. 
 

6.5.4 Exploring spectral properties of land-cover features using Spectral profiles  

 

The Spectral Profile Viewer allows you to visualize the reflectance spectrum of a single pixel. If 

the image is hyperspectral, we can see the reflectance spectrum of each band using the Spectral 

Profile Option.  Similarly, the spectral profile function can be applied to see different features 

(i.e., water, urban areas, forested areas, etc.) that reflect different wavelengths. 

 

1. Left-click on the “landsattm.hdr” on the Content pane. Now you see there are four other 

tabs under the Raster tab. Select Multispectral Tab and go to the Utility group. Select 

the second option from the left (Spectral profile) by clicking the drop-down menu.  

 

2. A separate window will appear, named Spectral Profile. 
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3. From the new window, select + icon and click one of the pixels on the image where you 

are interested to see the spectral profile.  

4. You can continue this step by selecting different landcover types in the image. Now you 

see how the Pixel values are varying with bands. 

5. Next, click Edit on the Spectral Profile window and select the Chart option. Now you 

can change the Title, X-axis, and Y-axis attributes accordingly. 

6. Similarly, select Chart Legend and change the Color, Line Style, and Name of each 

profile. 

 

Q#1(10%).  Include a screenshot of spectral profiles containing pixels from a forest, 

waterbody, sandy beach, and urban areas.  

Add proper legend with different colors to see the spectral profiles. Also, Change the line type 

appropriately. 

 

NOTE: you can insert a base map underneath need the Satellite image (“landsattm.hdr”) by 

Home>Basemap (View group) > OpenStreetMap. This will help you to identify landcover 

features (e.g., Urban Areas). Also, you can use the Google Earth option as well to identify 

landcover features.  
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6.5.5 Exploring spectral properties of land-cover features using 2D Scatter Plots 

A feature space image is simply a graph of the data file values of one band of data against the 

values of another band (often called a scatterplot). The image can be either unsigned 8-bit, 16-bit, 

or 32-bit. A feature space image can be used in any of the utilities, for example, the 2D View, 

Classification, Map View, Spatial Modeler, and so forth). 

When you display a feature space image file (*.fsp.hdr) in a Viewer, the colors reflect the density 

of points for both bands. 

• Bright tones represent a high density 

• Dark tones represent a low density 

  

1. Remove previous images from the main View and load “Landsattm.hdr” again to the 

main View. 

2. Set the Landsattm image to the True color image. 

3. Go to the Help tab and type AOI under the search command. You will see the related 

findings next to the Search Command group. Select the New AOI layer option. 

 

 
4. Now you will see that the AOI layer has been added to the Content pane. Always make 

the AOI layer as the top item in the Content pane list. 

5. Go to the Raster tab and click the Supervised drop-down menu under the classification 

group. Then select Signature editor option. 
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6. A Signature Editor dialog box will open as a separate window.  

7. Now, Click on the AOI layer in the Content Pane. Now you will see the AOI tab has 

activated. Go to AOI | Drawing and click polygon icon  from Insert Geometry 

group.  

8. Identify distinct landcover types from the true color image and draw a polygon covering 

that land cover type (e.g., Select Water)  

9. Go to the Signature Editor dialog box and click the Create New signature icon. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

10. Now you can see the polygon has added to the Signature Editor Table. Click Class 1 

under the Signature Name column and rename it as Water. 

11. Continue the above steps and add two more land cover types (i.e., Forest and Urban) to 

the Signature editor dialog box. 

12. Change the color of each signature appropriately using the drop-down menu in the Color 

column. Do not close the Signature Editor dialog box. 
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13. Select the three signature columns and select Feature > Create > Feature Space Layers. 

 

14. Then Create Feature Space Images dialog box will open. Navigate to the data folder and 

select “landsattm.hdr” image for Input Raster Layer. Type Create_feature for the 

Output Root Name. Keep Other settings as default. 

 

 

 
 
 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

15. Click OK. Once the Process List has been completed, click Close. 

16. Now go to Home Tab and select Add View. Then Select Display Two Views. 

 

NOTE: Feature Space Images provide a graphical view of all x, y combinations associated with 

the spectral values of two channels of remotely sensed data. To explore this utility, we will graph 

two bands that exhibit very different spectral characteristics for the most common component of 

this image (i.e., vegetation).  Landsat TM Band 3 measures reflectance in the red (visible) portion 

of the spectrum, while Band 4 measures reflectance in the NIR portion of the spectrum.  

Typically, healthy vegetation exhibits very low levels of reflectance in the red vs. very high 

levels of reflectance in the NIR.  The area between this low and high reflectance associated with 

the transition from red to NIR is known as the “red edge”. 

 

17. Navigate to your output folder where you saved the Feature Space Images. Select 

create_feature_3_4.  Note that the xxxxxxx_ 3_4 (and other combinations) represent the 

bands that are being plotted in the image. In this case, layer 3 (band 3) will be displayed 

on the x-axis and layer 4 (band 4) on the y-axis. 

 

18. Select File >Open > Raster Layer and navigate to the data folder and select “Create 

feature_3_4.fsp.img” file that you just created.  

19. Now it will add to the Second View (2D View#2) and set Fit to Window by right-clicking 

the View#2.  

20. Now go back to the Signature Editor dialog box. Select Feature >Object. A new 

Signature Objects dialog box will open.  
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21. Change Viewer to 2, because your feature layer is in View 2. 

22. Check Plot means and Label. Click OK. 

23. Now you will see a Feature space graph with labels and with prominent landcover 

areas.  

 

NOTE: In the feature space plot, red (band 3) is on the X-axis and near-infrared (band 4) is on 

the Y-axis. You can explain the positions of your landcover classes (Water, Forest, and Urban) in 

feature space plots as follows:   

• Water: Low values in both band 3 and band 4. 

• Forest: High values in band 4 and low values in band 3 

• Urban: High values in both band 3 and band 4 

 

Q#2 (15%). Include a snapshot of your feature space plot for band 3 and band 4. 

6.5.6 Define areas of training and testing data using Area of Interest (AOIs): Generating 

Signatures  

 

To perform supervised classification of digital remotely sensed data, training (calibration) data 

are required to provide examples of the statistical values representing particular land-cover 

classes. In ERDAS, we delineated individual training sites as “area of interest (AOI)” with a 

particular land cover class. Pixels within the ROI (training site) generate a unique signature, and 

we use AOIs to manually delineate locations that represent areas of training data.   

 

1. To begin this process, in the Main Image window, select Raster Tab, and then 

Signature Editor option by clicking the Supervised drop-down menu.   

2. A signature window will open and expand the window to see all the columns.  
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3. Now go back to the File tab and select New. Select the AOI 

Layer option from 2D View #1 New Options. A new AOI 

layer will appear in the Contents pane. In the next steps, we are 

going to use this layer to draw the training polygons. 
 

 

 
 

• We are going to classify the 2006 Landsat TM image by defining AOIs for several land-

cover categories. There is no specific rule dictating how many land-cover categories one 

should aim for; however, bear in mind that a land-cover class is only realistic if it is 

spectrally unique and observable at the spatial resolution of the imagery.   

 

• In other words, in most cases, spatial and spectral resolution of Landsat imagery allows 

for distinguishing between taxonomic tree types, such as broadleaf and coniferous, but do 

not permit separating specific tree species, such as Douglas-fir and Western redcedar.   

 

• Therefore, defining broadleaf and conifer as target land-cover categories is practical and 

achievable, as these are realistic spectral classes, whereas classes based on specific tree 

species (e.g., Douglas-fir and Western redcedar) are unrealistic as these information 

classes (i.e., species type) are not spectrally distinguishable. 

 

• When considering Landsat imagery, beyond forests, other types of vegetation can be 

distinguished.  For instance, frequently, areas dominated by herbs, shrubs and/or 

agricultural growth will appear spectrally different to forests in Landsat imagery; 

however, these non-forest vegetation types may appear spectrally similar to each other. 
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• An exception to this relates to vegetation health, which can be associated with things such 

as stress (due to water shortage and/or pest infestation).  Furthermore, the time of year is 

important.  Due to phenological properties, vegetation may appear very differently in July 

and January. Beyond vegetation, other types of land-cover features are spectrally 

identifiable in Landsat imagery. These may include classes relatable to water and/or 

human-made features. 
 

4. At this point, open a second View (2D View #2) by selecting Add Views >Display Two 

Views in Home Tab (you can refer to steps as in Lab 1 → 3.4 Multiple Views). Right-

click on the 2D View#2 content pane and select “landsattm.hdr.”  

 

NOTE: If you cannot see the “landsattm.hdr” File after you navigate the correct folder, 

you can select Files of type as “All File-based Raster Formats.” This option will allow 

you to see all the files in the data folder.  

 

 

 

 

 

 

5. Display a false-color RBG composite of red (Layer 4), green 

(Layer 3), and blue (Layer 2) in the Bands group under the 

Multispectral Tab. Similarly, you can select TM False Color 

as the Band combination.  

 

6. Under the Home tab select the Link Views option (next to Add Views 

option) to synchronize both the Views. 

 

NOTE: By adding a second view with a False color composite image, you can easily 

distinguish the landcover features. 

Also, you can insert Google Earth view by clicking the Connect to Google Earth 

option. 



Remote Sensing and Photogrammetry – Forestry Applications 

144 

 

Further, you can use other options such as Match GE to View, Sync GE to View, and 

Export View Footprints to navigate your AOI. This allows you to see the landcover 

features very clearly.  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Series of images below and on the following pages show you examples of basic land-cover types 

present in the Landsat image.   

 

NOTE: The images represent the SAME area and class examples. Use the classes highlighted in 

the series of images to form the basis for your classification.  PLEASE BEAR IN MIND that 

even though two types of Water are presented (i.e., saline (salt) and non-saline (fresh) Water), 

they should be treated as ONE land-cover class when deriving calibration and validation data.   

• Two are only presented to make a distinction that there are 2 water types; however, they 

are not spectrally distinct. Therefore, in total, eight classes are presented.   

• You are encouraged to locate and delineate additional categories; however, failure to do 

so will NOT result in a deduction of marks. Eight classes are certainly enough for this 

introduction's purposes and scope; however, if considering additional classes, they must 

be spectrally distinct in and of themselves and in relation to other defined categories.   

• They must also be land-cover features captured by the spatial resolution inherent to the 

imagery (30 x 30 m pixels), and the time of year of the imagery must be considered (if 

applicable to a particular class). 
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  Location of basic land-cover classes focusing on Landsat TM true color (123) composite.  Five classes 
(including Water) are presented. 

 
Location of basic land-cover classes focusing on Landsat TM false color (234) composite. 

Five classes (including Water) are presented. 
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Location of basic land-cover classes focusing on Landsat TM true color (123) composite. 

Four classes (including Water) are presented. 
 

 
Location of basic land-cover classes focusing on Landsat TM false color (234) composite. 

Four classes (including Water) are presented. 
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7. To delineate AOIs for a specific land-cover category (e.g., broadleaf forest), navigate to 

an area of interest (that you believe in representing a specific land-cover category) and 

select the Polygon icon in located in Insert Geometry group Under Raster | 

Drawing Tab.    

NOTE: Bear in mind that you have to draw the polygons or select the training sites on a 

true-color image (i.e., 2D View#1). It is always better to Scroll and Zoom the image and 

draw the polygon to have a better view of the landcover feature.   

 

In other words: bearing in mind which View your Drawing tool is associated with, use 

the other displays (from which you did not use to draw polygons) to navigate to an area of 

interest, then turn the Polygon tool on and proceed to delineate a polygon around the 

perimeter of a group of pixels representing the land-cover Feature of interest (i.e., specific 

to a land-cover category) using the left mouse button.   

 

8. Once you have outlined the shape/perimeter of a feature/area of interest, two right-clicks 

will close the polygon (the first right click closes the polygon and the second right-click 

accepts the polygon).  If you are unhappy with the polygon that you have just completed, 

at any point, you can navigate back to it and place the cursor over it, and hit the middle 

mouse button, and delete the polygon. 

 

SAVE YOUR FILE OFTEN!  Choose File, Sessions, and Select .ixs. The file should be 

saved as calibration.ixs.  

 

9. Make sure that you have activated the AOI layer all the time. Now you can add a similar 

type of land cover features to the Signature Editor. For example, we can first collect all 

the Signature Files relevant to Water and then move to Forest signature files.  

Once you have completed each polygon, go to the Signature Editor dialog box and 

select Add. 

Alternatively, you can click  to add the Signature features to the Table as follows.  
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Q#3 (15%). Include a snapshot of your main window (similar to the above figure) that 

includes your AOI polygons and the false color image. Also, add the snapshot of the 

Signature editor dialog box as well.  
 

NOTE: To add additional polygons to the AOI representing a specific land-cover category (e.g., 

broadleaf forest) continue to navigate to areas of interest in the image and delineate the 

shape/perimeter of additional groups of pixels representing the land-cover Feature of interest, 

solidifying these additional polygons with two clicks.   
 

• For every land-cover class, you need multiple polygons. It is better (and required!) to have 

numerous small class-specific training areas spread out throughout the image than to have only a 

couple of very large training areas.   
 

• To capture class variability, you should have at least 10 different polygons per class as evenly 

spread throughout the image as possible.   

 

10. Once you have collected an appropriate number of polygons, click the Signature Names 

+ Ctrl key to select the rows. Then click the Merge Selected Signatures icon . This 

will add a new row by combining the Spectral Signatures of polygons that you have 

collected. Now right click on the highlighted rows and delete them. Now you will see 

only the combined class, click it and rename it (e.g., Water). 

 
 

 

 

 

  
 

• For Water and vegetation classes, you are REQUIRED to have 10 polygons per class. 
 

• For all other classes (i.e., barren and exposed; low density developed; high density developed; 

and any additional classes you may have defined), you are required to have 10 polygons per 

class. 

   

NOTE: To delineate AOIs for additional land-cover categories (e.g., conifer forest), select 

appropriate areas in the main window (2D View#1). You can then follow the same process just 

outlined to delineate class-specific polygons for each class. 

 

Color is used to distinguish between different classes. ERDAS picks a default color and name for 

every new region. To change the color of the new region, right-click on the Color field, whereas 

you can change the name of a region by double left-clicking in the Signature Name field and 

typing the desired category name (e.g., coniferous forest). 
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11. Once you have established eight or more classes, each represented by an AOI composed 

of multiple polygons (i.e., 10 depending on class), click File > Save As in the Signature 

editor dialog box. Navigate to your Lab 6 data folder and name as “signature_file,” and 

click OK.  Count column containing an adequate number of pixels (i.e., > 100-500 

depending on class), save signatrure_file one final time.  

12. Also, close the Google Earth Map window and Signature Editor window as well.  

 

Q#4 (15%). Include a snapshot of your final Signature Editor dialog box. 
 

3.1 Image Classification 

We will then classify the Landsat TM image using the Maximum Likelihood classification 

algorithm and all 6 bands as input.  
Maximum Likelihood: This classification algorithm assumes that the statistics for each class in 

each band are normally distributed. This approach also calculates the probability that a given 

pixel belongs to a specific class that we have introduced during collecting trading data. 

Therefore, each pixel in an image is assigned to the class that has the highest probability. 
 

1. From the Raster Tab, choose Supervised Tab 

and select the Supervised Classification option 

from the drop-down list.  

2. Next, the Supervised Classification dialog box 

will appear. From that box, select 

“landsattm.hdr” as the input raster file and 

select “signature_file.sig” as the input signature 

file. You can name the Classified File as 

“classified_image.img” and turn on the Distance 

File option, and name it as “distance_file” in the 

same data folder. This “distance_file” need for 

setting the threshold values for the classification.  

 

 

NOTE: Basically, the Thresholding utility allows you to determine pixels that are most likely 

classified incorrectly. Thresholding in supervised classification requires a distance file. (by 

setting the distance threshold pixels "data distance" from the class mean) 
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This means that if the highest likelihood calculated for all AOIs (i.e., all classes) for a given pixel 

is less than 0.95, then the pixel will remain unclassified 

 

3. Then select the Maximum Likelihood form the Parametric Rule drop-down menu. 

Click OK to proceed.  

4. Right-click on 2D View#2 and add the classified image you just created. Compare the 

classified image vs. satellite image by using options available in the Window group in 

the Home Tab.  

 

Thresholding  

5. Select the Threshold option from the classification menu under Raster Tab, and you 

will see the Threshold dialog box. Select #Band as 6 and Classification Type as 

Maximum Likelihood. 

6. From that dialog box, select File > Open. Select both the classified image and distance 

images that you just created from previous work. Click OK. 

7. Then go to View > Select Viewer in the Threshold dialog box and click on the Viewer 

(i.e., 2D View#2), which displays the supervised classified image. 

8. From the Threshold dialog, select Histograms > Compute. Now you will see a separate 

histogram of the distance image for each class in the classified image is computed. 

 

9. Now select each class in the Threshold dialog box and click the Histogram icon ,a 

new window will open with a histogram for a class (i.e., Water) 

10. You can select the arrow on the X-axis of the histogram and move to the position where 

you want to set up a threshold in the histogram (the chi-square value will automatically 

update as you change the X-axis: try to adjust the Chi-sq. ~11.07 where p=.05 for 6 

spectral bands)  

Source: https://www.mathsisfun.com/data/chi-square-table.html  

11. Continue the above steps for other classes as well. 
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12. Close in the Histogram window, and select View > View Colors > Default Colors in 

the Threshold dialog box.  

13. Select process> to File in the Threshold dialog box and save output image as 

“threshold_image” into the Lab 6 data folder.  

14. Now you can create a new view (i.e., 2D View#2) and add the “threshold.img” file to it.  

 

Q#5 (15%). Include a snapshot of your main window that includes your “threshold.img”.  

 
 

AS ALWAYS, ensure you know WHERE you are saving your files. 

 

Accuracy Assessment  

 

 

1. Click the Raster Tab and select the Supervised drop-down menu under Classification 

Group. 

 

Don’t forget to load your “Landsattm.hdr” image to the 

2D View#1 and set up it to True Color using Bands Group 

under Raster | Multispectral Tab.  

  

2. Select Accuracy Assessment and open it. From the accuracy assessment dialog box, 

select File > Open. Then the Classified Image dialog box will open. You can navigate to 

your Lab 6 data folder and select the classified image you saved before. Click OK, and 

the Accuracy Assessment dialog box for the classified image will be loaded.  

 

3. You will use this for accuracy assessment.  

  

4. Now Select View > Select Viewer From the accuracy assessment viewer. Form the 

Viewer Selection Instructions dialog box and select the classified image.  

 

5. Next, you can choose colors for reference 

pixels. In the Accuracy Assessment 

Viewer, select View > Change Colors.  

Here, you can select White for Points With 

No Reference (These points are just 

random points that have not been assigned a 

reference value) And Yellow for Points 

With Reference (These points are the 

random points the have been assigned a reference class value). Click OK. If you want, 

you can change these default colors. 

 

NOTE: The option Create/Add Random Points available under Edit in the Accuracy Assessment 

dialog box will generate random points throughout the classified image. Once these points are 

generated, you must enter the class values for the points (reference points). Then these reference 

values will be compared to the class values of the classified image. 
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1. Select Edit > Create/Add Random Points in the accuracy 

assessment viewer. Then the Add Random points dialog box 

will open. 

2. Here you can set Search Count as 1024. This value allows 1024 

points to be analyzed to see if they meet the defined requirements 

in the dialog box. You can change this number if you want but 

keep the default valve 1024 for now. 

3. Change the Number of Points to 30. This allows you to 

generate random points over the classified image. However, to 

perform a better accuracy assessment, you may need more than 

250 points. 

 

4. Under the Distribution parameters options, you have three 

options, including "random", "stratified random", and 

"equalized random". You can select the Random option for 

this exercise. Then click OK to generate the points.  

 

5. Now you will see a list of points in the accuracy assessment dialog box. 

6. In the Accuracy Assessment dialog box, select View > Show All. This will show you all 

the random points that are distributed in your classified image. 

NOTE: If you cannot see the random points in the classified image, you may need to select  

icon and select the classified image and then try step 6. 

 
 

7. Go to Home and select Equalize sizes, then select Link Views and Sync Views. 
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Q#6 (15%). Include a snapshot of your main window that includes your true-color image, 

classified image, and Accuracy assessment table.  

 

NOTE: You will see both images along with their points in white color. Now you can zoom in to 

a point in the classified image, and the same point will be zoom in the reference image as well. 

Also, you can add an Attribute table related to the classified image by selecting the classified 

image and Table> Show Attributes.  

• This Table will show up at the bottom of your main window, and you can use this to find 

the class number for each class you defined (e.g., Water: class number 11).  

• You can do the same task by referring to the signature file you saved before your Lab 6 

data folder. Click Supervised > Signature Editor.  

• Now Select Open in Signature Editor dialog box and navigate and select your 

signature file. Now you will see the class with their respective class values in the 

Signature Editor dialog box. You can refer to these values to fill the reference column in 

the Accuracy Assessment dialog box. 

 

8. In the Accuracy Assessment Reference column, you have to enter the best guess of a 

class value for the pixel covered by each reference point.  

9. Once you have filled the reference value for each point, you can see points in the Viewer 

will change it to yellow color. 

 

 
 

 

In order to assess the accuracy of the classification, we can use Error Matrix, Accuracy Totals, 

and Kappa Statistics available in ERDAS. You can take this information as a report. 
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1. Go to Report > Accuracy Report and Report > Cell Report in the Accuracy Assessment 

Viewer. A text file will be created with all the accuracy measurements. If you want to save 

the reports as a text file.  

 

2. Now close the text editors and go to File > Save Table in the Accuracy Assessment viewer 

to save the data. Once you have finished, close the Accuracy Assessment viewer. 

 

 

 

NOTE: The error matrix simply compares the reference points to the classified points. The 

Kappa coefficient expresses the proportionate reduction in error generated by a classification 

process compared with the error of a completely random classification. For example, a value of 

.82 would imply that the classification process was avoiding 82% of the errors that a completely 

random classification would generate (Congalton, 1991.) 

 

Q#7 (15%). Include the snapshot accuracy assessment report  
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7 Unsupervised Classification 
 
Lab developed by Rong Fang from Dr. Strimbu and ENVI documentation.  

7.1 Objectives 

      Generate classification image by using supervised and unsupervised classification and assess 

the accuracy with confusion matrix 

7.2 Files used in this lab  

Files (.dat and .hdr format) Description 

PostFireOLISubset Landsat 8 OLI bands (seven total), from May 25, 2014 

       

The images are related with the wildlife that occurred on May 2014 in San Diego County, CA. In 

May of 2014, close to 20 different wildfires erupted in San Diego County, triggered by SantaAna 

winds and a heatwave. The first fire started on May 5, and the last remaining fires were 

extinguished by May 22. By May 18, the fires had burned more than 27,000 acres (42 square 

miles) of land (Figueroa and Winkley, 2014). Some of the communities affected by the fire 

included Camp Pendleton, Carlsbad, San Marcos, and Escondido. 

7.3 Processing  

7.3.1 Supervised classification 

Execute a maximum likelihood supervised classification of the Landsat 8 OLI bands image 

PostFireOLISubset. The classification should create 6 classes: Water, Bare Land/ Cloud, 

Developed Area, Dense Vegetation, Sparse Vegetation, and Shrubs. Assess the accuracy of 

the classification using the same procedure as you have done in the previous lab. 

7.3.2 Unsupervised classification  

1. Start ArcMap, add image PostFireOLISubset by using Add Data icon . Set the 

display of PostFireOLISubset as false-color (Red: Near-Infrared, Green: Red, and Blue: 

Green) for better visual identification. 

2. Add the base map as a reference. Click Add Data icon , choose Add Basemap 

→Imagery.  

 

3. Enable image classification tool and the Spatial Analyst is also active. In the image 

classification tool, make sure PostFireOLISubset is chosen as the image to be classified.  

 
4. Click classification, choose ISO Cluster Unsupervised Classification. Start with 

Number of classes 12.  Name the output classified raster as PostFire12.    
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The classification of 12 classes is too patchy and noisy. We can see that many patches are too 

small. In the Table of Content, right-click on the layer PostFire12, and open the attribute table. 

Exam the classes with smallest count.  

 
  

Q1 [10%]. How many counts are there in the smallest two classes?  

Q2 [10%]. What land cover do you think is located in the classes with the smallest number of 

pixels?  

Q3 [10%]. Is there any visually identifiable misclassification in these classes? 

 

      Now, please visually determine the majority of land cover type of these classes in the 

PostFire12 file by comparing the classified image with the Base map.  

Class Value Land Cover Type 

1 Water 

2 Bare Land 

3 Developed Area 

4 Dense Vegetation 

5 Sparse Vegetation 

6 Shrub 

7 Bare land 

8 Developed Area 

9 Developed Area 

10 Shrub 

11 Bare Land 

12 Cloud/Bare Land 

7.3.3 Reclass image 

      According to your judgment, do you think you need to merge some of the classes? In my case, I 

decided to merge class#2 7, and 11 as a single class Bare Land, 6, and 10 as Shrub, 3, 8 and 9 as 

Developed. 

Final Classes Original Classes Land Cover Type 

1 1 Water 

2 2, 7, 11, 12 Bare Land/ Cloud 
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3 3, 8, 9 Developed Area 

4 4 Dense Vegetation 

5 5 Sparse Vegetation 

6 6, 10  Shrub 

 

5. Open ArcToolBox, find Spatial Analyst Tools, and choose Reclass →Reclassify. In the 

dialog of Reclassify, input the parameters as below: 

      Input raster: PostFire12 

      Reclass field: Value 

      Reclassification: Input the values according to your reclassification table.  

      Output raster: PostFireNew 

       

       

 

 

 

 

 

 

 

 

 

 

 

6. Click OK once you have finished entering the paprametrs. The reclassified image will be 

displayed.  

 

 

 

 

            

 

 

 

 

 

 

 

 

 

 

 

7. Next step is to set the labels of the different classes to the land cover type. Right, Click on 

the layer PostFireNew in Table of Content. Choose Layer Properties. In the 

symbology tab, change the label to the land cover type.  
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7.3.4  Accuracy assessment  

7.3.4.1 Create Ground Truth Samples 
You should use the same AOI that was created during the supervised classification. 

 

7.3.4.2 Create Accuracy Assessment Points  
In this step, we need to randomly sample some points on the Ground 

Truth polygons for the purpose of assessing the accuracy of the 

classification.  

1. In the main menu, click  to open the search window. Type 

accuracy in the Search window. Open Create Accuracy 

Assessment Points. Enter the parameters as below: 

Input raster or feature class data: PostFireNew 

Output Accuracy Assessment Points: GPoints 

Target Field: Ground_Truth 

Number of Random Points: 500 

Sampling Strategy: Equalized_Stratified_Random.  

Click OK.  
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2. After the points are generated, you will see these points covering on the top of ground 

truth polygons. Right-click the GPoints in the Table of Content, and open the Attribute 

Table. You will see -1 as the default value showing in the column of Classified.  

 

3. Next step, we need to update accuracy assessment points and identify their corresponding 

value in the classified image. Type Accuracy in the Search window again. Open Update 

Accuracy Assessment Points. Enter the parameters as below: 

Input raster or feature class data: PostFireNew 

Input Accuracy Assessment Points: GPoints 

Output Accuracy Assessment Points: AccuracyAssement.shp 

Target Field: Classified 

Click OK. 

 

4. Once the points are updated, in the Table of Content, right-click the AccuracyAssement 

layer, open Attribute Table. You will see both column Classified and GrndTruth 

contain their values 

 

7.3.4.3 Create Confusion Matrix  
1.  In the search Windom, type confusion matrix. Open Compute Confusion Matrix.  

 Input Accuracy Assessment Points: AccuracyAssessment; 

 Output Confusion Matrix: UnClassi. Then click OK. 
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2. A .csv table is generated and added in the Table of Contents. Open the table UnClassi by 

right-clicking the UnClassi.scv file in the Table of Contents., you will see the table 

shows as below:  

  

 

 

 

 

 

 

 

 

The column 

ClassValue is the value in the classified image, and different columns of c_1 to c_6 are the 

ground truth value. User's accuracy shows false positives, where pixels are incorrectly classified 

as a known class when they should have been classified as something else. User's accuracy is also 

referred to as errors of commission, or type 1 error. Producer's accuracy is a false negative, where 

pixels of a known class are classified as something other than that class. Producer's accuracy is 

also referred to as errors of omission, or type 2 error. Kappa index of agreement gives an overall 

assessment of the accuracy of the classification 

 

Q4 [10%]. Briefly describe how does ISO-DATA algorithm determines the classes? 

Q5 [10%]. For supervised classification, what is the class with smallest and largest user 

accuracy?  

Q6 [10%]. For unsupervised classification, what is the class with smallest and largest user 

accuracy?  

Q7 [10%]. For supervised classification, what is the class with the least producer accuracy?  

Q8 [10%]. For unsupervised classification, what is the class with the least producer accuracy?  

Q9 [10%]. What does cause the low producer and user accuracy?  

Q10 [10%]. What is the overall accuracy and Kappa statistics for the two classifications: 

supervised and unsupervised? 

 

7.4 Advanced topics: Unsupervised classification and confusion matrix with 

ERDAS 
 

Lab developed by Sudeera Wickramarathna and Dr. Strimbu from ERDAS documentation 

7.4.1 Objectives 

• Generate classification image by using suppervised and unsupervised classification. 

• Assess the accuracy with confusion matrix 

7.4.2 Files used in this Lab 
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The file needed to complete this Lab are supplied by the U.S. Geological Survey, and are located 

on Canvas, Week 8 Lab. Copy the files to a local drive, such as the Desktop. 

 

Files (.dat and .hdr format) Description 
PostFireOLISubset Landsat 8 OLI bands (seven total), from May 25, 2014 

 

The images are related to the wildlife that occurred in May 2014 in San Diego County, CA. The 

first fire started on May 5, and the last remaining fires were extinguished by May 22. By May 18, 

the fires had burned more than 27,000 acres (42 square miles) of land (Figueroa and Winkley, 

2014).  

7.4.3 Supervised classification 

Using the knowledge acquired in the previous Lab you should classify the image using the 

supervised classification method. You should consider the following six (6) classes: 

 

Class Value Land Cover Type 

1 Water 

2 Bare Land/ Clouds 

3 Developed Area 

4 Dense Vegetation 

5 Sparse Vegetation 

6 Shrub 

Because the new area to be classified is located inside USA a basemap service is available within 

ERDAS. The service can be accessed thru the Web Map Service (WMS) available in ERDAS. To 

connect the WMS to ERDAS you have to provide ERADS with the location of the server. One 

such location is  

https://basemap.nationalmap.gv/arcgis/services/USGSImageryOnly/MapServer/WMSServer?req

uest=GetCapabilities&service=WMS.  

Another link hosting the same information can be accessed by searching with Google “basemaps 

usgs server” which would supply a series of results. The imagery can be accessed from the 

viewer.nationalmap.gov or from the catalog.data.gov.  

If you want to use the catalog.data.gov website, once you click on it, an interface like this could 

appear (depends on where you are pointed inside the website): 

https://basemap.nationalmap.gov/arcgis/services/USGSImageryOnly/MapServer/WMSServer?request=GetCapabilities&service=WMS
https://basemap.nationalmap.gov/arcgis/services/USGSImageryOnly/MapServer/WMSServer?request=GetCapabilities&service=WMS
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You should click the Imagery Topo Base Map Service (WMS) , 

which will open a new page that contains the address of the server: 

 

Copy the url, then open ERDAS. Select File->Open, and from the available option choose Web 

Service… 



Remote Sensing and Photogrammetry – Forestry Applications 

163 

 

 

Within the new window paste the address of the server:  

 

To check the connection with the server, press Test. If the connection was successful a new 

window should appear stating this: 

 

If the connection was successful, the WMS link will be display below the Password. To 

permanentize the connection, such that will be used later, you should press the green cross, 

located at the right of the url box . 

After the cross is pressed, the name of the server will change from New URL to the WMS name: 

 

Once the connection was added to the WMS list, you can click OK. You will see the entire 

planet, but detailed imagery is available only for the USA. For example, the last lab, used a 

Landsat image that covered parts of USA and parts of Canada. If you zoom in to the Vancouver 

Island- Olympic Peninsula area, you will notice that only the USA is rendered: 
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If you select the viewer.nationalmap.gov then you will be directed to the National Map data 

delivery website: 
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From the website you should choose the Apps & Services link:  

 

In the new webpage, you should choose Services, then Web Map Services. 

  

Among the available services, you should choose Base Maps, then select USGS Imagery Topo 

Base Map, the WMS link: 
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Clicking WMS link will open an html interface, from which you should select only the link to the 

server: 
https://basemap.nationalmap.gov:443/arcgis/services/USGSImageryTopo/MapServer/

WmsServer? 

From the code written there: 

 

After you copy the link to the WMS, paste it in the interface of adding Web Map services in 

ERDAS, and follow the similar steps as you did before.  

Q1 (30%): Include a series of snapshots with the main steps used for supervised 

classification. 

https://basemap.nationalmap.gov/arcgis/services/USGSImageryTopo/MapServer/WmsServer
https://basemap.nationalmap.gov/arcgis/services/USGSImageryTopo/MapServer/WmsServer
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7.4.4 Unsupervised classification 

It is customary to classify images using supervised classification and unsupervised to acquire a 

sense of the best spectral separation of the pixels within the image. Therefore, in this Lab we will 

implement an unsupervised classification using the ISODATA classification method, developed 

by Ball and Hall in 1965. The ISODATA algorithm, an abbreviation of Iterative Self-Organizing 

Data Analysis Technique, contains a series of operations that merge pixels or clusters of pixels if 

their separation distance multispectral feature space is less than a predefined value. The 

ISODATA algorithm also split a cluster into two clusters according to user-preset rules. 

 

1. Download the image files and locate them in your Lab 7 data folder on your computer. 

Next, Click File > Open > Raster Layer and select “PostFireOLIsubset.hdr”. Now 

you can see the newly added image in the Content pane and 2D View#1 as well.  

 

2. Next, Click Multispectral Tab and go to Bands group. 

You will see Landsat 8 MS in the Sensor Type window; if not, 

change it to Landsat 8 MS by clicking the drop-down menu 

option. Also, change the Band Combination as True 

Color.  

 

3. To access the ISODATA algorithm, select Unsupervised under the Raster Tab. Click 

Unsupervised Classification from the drop-down menu. Now you will see the 

Unsupervised Classification dialog box.  

 

4. Click the Output Signature Set Checkbox and give the Output Cluster Layer and the 

Output Signature Set a similar name (i.e., Unsupervised_classification).  

 

5. Also, make sure that under Clustering Options, the Initialize from Statistics box is 

selected. 
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6. The Unsupervised Classification window asks for the parameters defining the ISODATA 

algorithm, specifically the number of classes and the variability within a class. However, 

there are several additional options that you should specify. To mirror the unsupervised 

classification, you should choose the number of classes to range from 5 to 10, as 

subsequent merging could be needed.  

 

7. Here, the Number of Classes from shows the lower limit for the number of classes to be 

created while the Number of Classes to show the upper limit for the number of classes to 

be created. 

 

8. Because ISODATA is an iterative algorithm, you should choose the number of iterations. 

For this Lab, you should select 2. The iterative process ends when the stopping rule is 

achieved.  

NOTE: Maximum Iterations is the number of times that the program will re-cluster the 

data. By setting up an appropriate number of iterations, you can prevent the utility from 

running too long, and also it will stop getting stuck in a cycle. 

 

9. ERDAS uses a “Convergence” threshold to end the iterative process, which stops the 

iterations when the number of pixels in each class changes by less than the threshold. The 

ISODATA classification ends when either this threshold is met,or the maximum number 

of iterations is reached. This threshold prevents the Isodata utility from running 

indefinitely (Source: ERDAS IMAGINE help) 

 

It makes sense that classes with few pixels should not exist, as probably are an artifact rather than 

a reality. Minimum Size  field provides you to decide the size requirement for a cluster to be 

deleted at the end of an iteration. The size is measured as a percent of pixels in a cluster relative 

to the total number of pixels in the image. If there are fewer than the minimum size (e.g., 2%) of 

pixels in a class, ERDAS will delete that class, and the pixels will be placed in the class(es) 

nearest to them spectrally. Choose 1% as the Minimize Size for a class to be deleted (Source: 

ERDAS IMAGINE help).  

 

 

10. To ensure that spectrally similar clusters are included in any class, a homogeneity 

measure of each class should be specified. A maximum class standard deviation should be 

entered in the Maximum SD field. You can keep the default value 5.00 for this field. If a 

class's standard deviation is larger than this threshold, then the class is split into two 

classes. 

 

To ensure that classes are not only split but also merged, if they have similar spectral signatures 

and variability, you should select a minimum distance between class means and the maximum 

number of merge pairs. If the distance between class means is less than the minimum value 

entered, then ERDAS merges the classes. The maximum number of class pairs to merge is set by 

the maximum number of Merge Pairs parameter.  

 

11. You could leave the default values for the minimum class distance (i.e., 4) and the 

maximum Merges of merge Pairs (i.e., 1). Click OK. 
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12. Now you can add a second View to display the classified image: Home > Add Views – 

Create New 2D View. Then left-click in the empty view window, select Open Raster 

Layer to add the classified image you just crested (Unsupervised_classification.img) by 

navigating to the data folder.  

 

NOTE: You can determine the class number for each pixel by using the Inquire option in the 

information group under the Home Tab. A cursor display box will appear at the bottom of your 

main window. You can use the pan tool to select the pixel you are interested in.  

 

13. Click on Home > Link Views icon drop-down > Link Views. Activate the Equalize 

Scales option as well. Pan the original image so that you can see the respective class of 

each pixel in the classified image (at the same geographic location in each image). 

 

The following results could be obtained: 

 

 
 

NOTE: You can change the color for each class by using the Attribute Table (at the bottom of 

your main window) color option.  

 

To perform this task, you can go to the Raster | Table Tab and click the Show Attribute option. 

You will see an attribute table at the bottom of your main window. Left-click on the color tab for 

each class and select the appropriate color from the color pallet. 

 

NOTE: Alternatively, you can try table> Colors in Query group to assign color ramp. You can 

select Start Color and End Color; ERDAS will create a color ramp for you. 
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Q2(15%): Include a snapshot of your classified image at this stage. Also, include another 

snapshot of the attribute table. 

14. As you see, the number of classes produced is 10, which is larger than the desired 

number. Therefore, some merging should be done. But before any merger is executed, 

you should compare the result with the supervised image and decide if the classification 

meets your visual requirements. (you can synchronize the views). 

 

 
 

15. If not, and most likely, this will be the case, rerun the classification by changing some 

parameters, such as the Maximum size (%), Maximum SD, Minimum Distance, and 

Maximum Merges.  

 

A given class/cluster may represent more than one land cover class in the Ture color image. You 

can decide if there is a major or small shift between the classified image and the Ture color 

image. So, you should try several sets of parameters to ensure that the classified image is close to 

your expectations. Once you made your selection for the classified image, you should start 

improving it.  

   

As you see, you have no unclassified pixels because you have chosen the option that forces 

ERDAS to classify all pixels. For example, examining the Attribute table, you noticed that all 

classes have more than 300,000 pixels, except for class 3, which has less than 70,000. 

Considering that a pixel's size is 30 m x 30 m, this class covers more than 15,000 ac. You could 

leave the class as it is. 
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However, to mirror the supervised classification results, which has only 6 classes, you should 

merge some classes. To identify the classes to be merged, you should compare the classified 

image with the Landsat image and see similarities between them. To merge classes, you should 

focus on smaller classes, which are likely candidates to be merged. Therefore, you will start with 

class #3.  

 

16. Now you can remove the secondary view (i.e., 2D View#2, classified image window). Go 

to Contents pan, select and right-click on 2D View#1. Then add the Unsupervised 

Classified file to it. 

17. Click the Home tab and go to View group, and select Swipe option .  

Alternatively, you can go to Utility | Transition Tab and select different Swipe options. 

You can also add the Swipe line so that you can see the Transition between two images. 

 

18. Now you will see the unsupervised classified image top of the True Color image 

(“postfireolisubnet.hdr”). You can swipe the top image and can observe the features of 

the True color image. 

 

19.  By swiping the images, you noticed that class#3 reflects the areas that suffered intense 

burning (Green colored patches). Therefore, if you are interested in burn severity, you 

could leave it as a separate class. However, if you are interested only in the burn vs. not 

burned, then you could merge it with class#5 (Cyan colored patches) 

 

  

  

 

Class 3 and 5 reflect 

burns that happened. 

 

  

 

 

 

 

 

 

 

 

20. Likewise, you can find classes that can be combined as a single class. Once you have 

identified combined classes, rename them (e.g., Class 3 and 5 renamed as Forest_burn) in 

the Attribute table and assign a color as well as follows: 
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21. Once you have finalized the classes by assigning the names and colors, click save to save 

the file. Then uncheck the true color image in the Content pane. 

 

22. For example, to merge class#3 with class#5, you 

could use the Thematic > Recode option under the 

Raster GIS group located in Raster Tab. The 

recode dialog box will open. Navigate to the data 

folder and use “unsupervised_classifcation.img” 

as input file. Name output file as “recode.img” in 

the same data folder. Also, activate Ignore Zero in 

Stats. Option. 

 

 

23. Then click Setup Recode, and another window will open with all the updates you just 

made to the Attribute table.  

24. You can update the new table using following steps: 

1. Select a class (e.g., Forest) 

2. Select the row in this class by clicking them in the Row column; if you have 

more than one row you can use Shift + Row Click to select them all. 

3. Then change the value in the New Value box. You can use a desired unique 

value for this class (e.g., Forest = 1) 

4. Finally, select Change Selected Rows. This will change any row(s) that have 

been selected to a New Value. You can observe the changes in the New Value 

column.  

5. You can continue this process until you finalized your classes. Once you have 

finished updating the process, make sure there are no rows that have not been 

selected in the Recode Table. You can do this by right-clicking the Value 

Column and select None.  

25. Click OK in Thematic Recode table and again click on in Record Table to crate your 

Record file. 
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Record File 

 

1. Now, remove all images from the 2D Views that you have been working with so far. 

2. Reload the Record file you just saved and open the Attribute Table. 

3. You may notice this attribute table does not have a Class_Name attribute column. Now 

you can add a new attribute column by using the table> Column properties in the 

Query Group. 

4. You can click New and type an appropriate 

title (e.g. “Class_Name”) and select String 

as Type. Click OK. 

5. A new column will appear, and you can 

name the classes with appropriate names. 

Also, you can change the class colors as 

well.  

6. Now Save your changes by clicking the 

Save button.  
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Q#3 (15%): Include a series of snapshots with the main steps used in unsupervised 

classification 

Q#4 (10%): Is unsupervised classification an iterative process or not? Justify your answer. 

Q#5 (10%): Which classification is more accurate: supervised or unsupervised? Justify 

your answer. 

7.4.5 Classification accuracy 

ERDAS has a built-in function that computes the classification accuracy, namely the confusion 

matrix.  

 

In ERDAS you can compute the confusion matrix using the Signature file for ground truth. To 

execute this task, first, you have to create the signature file, as you did for the supervised 

classification. The new signature file created on the LandsatTM image, must contain the same 

classes as the classified image. If different classes are made, you have to manually match them 

with the classes from the image.  

The confusion matrix is computed after you select the Confusion Matrix Using Ground Truth 

signature file. If there are unmatched classes between signature file and image classes, you 

should establish their correspondence manually. The output will be the entire confusion matrix 

with all the parameters computed for you: 

 

You can refer to Lab6 Image Classification > Accuracy Assessment steps to perform an 

accuracy assessment task.     

 

Q#6 (10%). What is the difference between omission errors and commission errors? What 

are the other names for these errors?  

 

Q#7 (10%). Cut and paste the confusion matrix in the Word document that you would 

submit on Canvas. Compute the percentage of false positives and false negatives using the 

Confusion matrix. Based on the omission and commission errors, what is your conclusion 

regarding the accuracy of your classification?  
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8 Classification enhancement using Remote Sensing Indices 
 
Lab developed by Dr. Strimbu.  

8.1 Objectives 

The week 8 lab has two objectives: 

• classify an image using recorded spectral reflectance and derived indices.  

• assess the accuracy of the classification using the confusion matrix 

8.2 Files used in this lab  

Files (.dat and .hdr format) Description 

Sentinel2bDetroitLake Sentinel 2B image east of Salem from Oct 29, 2020 

 

Q1 [5%]. What are the wavelengths of the Sentinel 2B instrument? 

Q2 [5%]. What are the wavelengths included in the Sentinel2bDetroitLake image? 

Q3 [5%]. What is the spatial resolution of the image? 

Q4 [5%]. Do you think that a post processing of the image occurred? Justify your answer. 

8.3 Classification using only spectral data 

Execute a maximum likelihood supervised classification and an ISO-DATA unsupervised 

classification of the Sentinel 2B image Sentinel2bDetroitLake. Both classifications should have 

the same classes, which should contain at least the following classes: Water, Bare ground/ 

Clearcut, Burned areas, Mature forest, Young Forest, and Clouds.  

Q5 [10%]. Include a snapshot of approximately 1 square mile for both, supervised and 

unsupervised.  

Assess the accuracy of both classifications using a confusion matrix. 

Q6 [20%]. Include the confusion matrices for both classifications.  

8.4 Compute remote sensing indices 

Image classification is enhanced when in addition to the spectral information other data is added 

to the classification. The easiest data to be added to the classification is the one based on the same 

information as the original image, namely the remote sensing indices. Remote sensing indices are 

combination of the reflectance in various bands. The most famous index is the normalized 

difference vegetation index (NDVI), which delineates the vegetation from other land features. 

The NDVI, which is the ration between a combination of near-infrared and red reflectance, is an 

important vegetation index because is coupled with some physiological parameters describing the 

vegetation, is species-specific, and reduces many forms of multiplicative noise (e.g., sun 

illumination differences, cloud shadows etc.). 

𝑁𝐷𝑉𝐼 =
𝜌𝑁𝐼𝑅 − 𝜌𝑅𝑒𝑑

𝜌𝑁𝐼𝑅 + 𝜌𝑅𝑒𝑑
 

Beside NDVI, there are other indices that can be used to enhance image classification. In this lab 

we will be computing three more indices: transformed Modified Soil Adjusted Vegetation Index 

(MSAVI2), transformed Red-edge Vegetation Stress index (RVSI), and transformed normalized 

difference water index (NDWI):  
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𝑀𝑆𝐴𝑉𝐼2 =
1

2
(2(𝑁𝐼𝑅 + 1) − √(2𝑁𝐼𝑅 + 1)2 − 8(𝑁𝐼𝑅 − 𝑅𝑒𝑑)) 

𝑅𝑉𝑆𝐼 =
𝜌704 + 𝜌782

2
− 𝜌740 

𝑁𝐷𝑊𝐼 =
𝜌864 − 𝜌1610

𝜌864 + 𝜌1610
 

The three indices are a transformation of the original indices, as the wavelengths do not match 

exactly the definition of the two indices. 

1. To compute the two indices in ArcGIS you can use two 

options: Map Algebra and Image Analysis. The Map Algebra 

option is used when multiple rasters are combined, whereas 

the Image Analysis is used when the bands are merged into 

one image.  

In this lab we will be using the Image Analysis tool, which combines 

the digital numbers from multiple bands within one image to produce 

a raster with only one band.  

2. To turn on the Image Analysis, you simply select Windows from the menu bar followed 

by the Image Analysis option. 

The image analysis window contains 4 areas: 1) the area where the rasters are located, 2) the 

Display area, which is used to enhance the displayed image, 3) the processing area, where various 

functions are developed, and 4) the Mensuration area, where measurements on the image can be 

done.  

3. To compute various indices, you must combine the digital numbers of various bands into 

a new band. To achieve this task, first, you should choose the image subject to algebraic 

manipulations, which in this case would be the Sentinel2BDetrait Lake.  

4. After you have selected the image, the Processing area will have many options turned on, 

one of which will be the NDVI button: . NDVI is not the only index readily available 

in ArcGIS, as many other are already implemented, however, the default option assumes a 

certain correspondence between the bands, such as the NIR would be band 4 and red band 

3. 

If the bands are not allocated according to the imbedded formula, the computations will be 

incorrect; therefore, always check the validity of the equation used to compute the index. In this 

lab we will be using the built-in NDVI index, and we will compute the NDWI by explicitly 

entering the formula.  

The NDVI is immediately computed once the  is pressed, which will add the image to the 

Table of Contents and the raster to the image area: 
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5. To check the validity of the NDVI values, select 

NDVI_sentinel2bdetroitlake.tif from the Image Analysis window, then 

right-click when the mouse is over the name of the raster, and select the 

Properties … option. From the Layer properties window, select the 

Functions tab. Within the Functions window, right-click over the NDVI function, then 

choose the Properties… option.  

 
 

6. Because the NDVI formula is well established, the only check should be done if the NIR 

and red bands are properly identified within the list (stack) of available bands. The NDVI 

tab will show the bands that are used to compute the NDVI, which in this case is band 3 

for Red and band 4 for Infrared.  

 

7. Checking the specifications of the sentinel 2B instrument, you notice that band 3 is the 

red band from the Sentinel2bdetroitlake image, therefore it should be left unchanged. 

However, band 4 is not NIR, but the red-edge (i.e., 704 nm). In fact, the NIR, which 

formally starts at 750 nm wavelength, could be any of the band 6 to10 from the 

Sentinel2bdetroitlake image. It makes sense that among all the NIR bands to choose the 

one with the smallest wavelength, namely the 780 nm, which is band 6. Therefore, you 

should change band 4 from Infrared band to band 6, then press OK. To update the NDVI 
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computations and see them on the screen press Apply in the Layer Properties/ Functions 

tab. 

 
8. Once the image was updated, you can press OK in the Functions tab, as the NDVI 

computations are completed.  

Q7 [5%]. Include a snapshot with the map showing the NDVI and the Functions tab from the 

Layer properties.  

9. Next, let's compute the MSAVI2. The formula of the MSAVI2 is already implemented in 

ArcGIS, all that you have to do is access it. Therefore, again select the 

Sentinel2bdetroitlake image, but now instead of clicking the NDVI icon, you will select 

the function icon from the Processing area .  

 

10. After you choose it, the default function is displayed in the Function Template Editor, 

which is normally the Identify function (will leave the original image unchanged). To 

access the MSAVI2 function, right-click on the Identify Function, then select Insert 

Function. 
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11. From the available functions, choose the Band Arithmetic Function. Within the Raster 

Function Properties, select the Band Arithmetic tab and make sure that the input raster is 

the Sentinel2bdetroitlake image, and choose from the dropped down Method, the 

MSAVI2, or Modified SAVI. 

 
12. Once you have selected Modified SAVI, the formula and the corresponded bands are 

displayed. To properly allocate the NIR and Red bad, you should type “6 3”, which means 

that band 6 is NIR, and band 3 is red. 

  
13. After you press OK, a new image is added to the display, which shows the MSAVI2. If 

you want to change the name of the displayed layer, right-click on it in the Image 

Analysis window, then select Properties. Inside the General tab, change the Layer name to 

“MSAVI2”, then click Apply. 
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Q8[5%]. Include a snapshot with the Layer Properties showing the MASVI2 inside the 

Functions tab and the raster displaying the MSAVI2 using a color scheme different than the 

default grey ramp. 

The last two indices to compute before the formal image classification starts are RVSI and 

NWSI. The two indices are computed in this case by entering the formula yourself using an 

approach similar to MSAVI2.  

14. Therefore, first select the sentine2bdetraitlake image, followed by the function icon . 

Within the Function Template Editor right-click on the Identify Function, and from the 

functions available thru the Insert Function window also choose Band Arithmetic 

Function.  

However, this time instead of searching for a predefined index, you should choose the User 

Defined option from the drop-down menu. In the expression box type in the formula for the 

RVSI: (B4 + B6) / 2 - B5 

 
The image showing the RVSI values is displayed using a greyscale: 
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15. Rename the image as RVSI using the same steps from the MSAVI2 and change the 

symbology of the image to a more colorful scheme.  

 
Q9 [5%]. Include a snapshot showing the RVSI inside the Functions tab and the raster 

displaying the RVSI using a color scheme different than the default. 

16. For the NDWI, you should follow the same steps as for RVSI, with the exception that in 

the Expression box you should enter the formula for: (B8 – B9) / (B8 + B9). 

 
17. Rename the function computing NDWI and NDVI as “NDWI” and “NDVI”, respectively, 

using the same procedure as above. 
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Q10[5%]. Include a snapshot with the Layer Properties showing the NDWI inside the 

Functions tab and the raster displaying the NDWI using a color scheme different than the 

default grey ramp. 

Now that you have finished computing the four indices, you are ready to create an image that 

contains not only the reflectance in various wavelengths but also the indices, which will serve as 

input in the subsequent classification.  

18. To create a multiple band image, you should select from the ArcToolbox the Raster 

folder, within which choose Raster Processing followed by Composite Bands.  

 

19. After you open the Composite Bands windows, you should select the rasters that will be 

included in the new image, which are either added to the Input Raster by navigating to the 

respective files, if they are not in the Table of Contents, or by using the drop-down menu, 

if they are in the Table of Contents.  

 

20. Because all our rasters are in the Table of Contents, you should add them using the drop-

down menu. Be sure that you will sort them such that will make sense later during the 

classification. For example, it is good practice to have the spectral bands separated from 

the indices. Therefore, you could place the original 10 bands image first, then add the 

indices after that. Once you are done, save the new image as 

sentinel2bdetroitlake14bands.tif.  

 
Q11 [5%] Insert a snapshot with the 14 bands within the sentinel2bdetroitlake14bands image.  
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8.5 Classify the image using spectral bands and remote sensing indices 

Execute a maximum likelihood supervised classification and an ISO-DATA unsupervised 

classification of the sentinel2bdetroitlake14bands image. The two classifications should have the 

same classes as the classification without the remote sensing indices.  

Q12 [10%]. Include a snapshot of approximately 1 square mile for both classifications based 

on 14 bands, supervised and unsupervised.  

Assess the accuracy of both classifications based on the 14 bands image using a confusion 

matrix. 

Q13 [15%]. Include the confusion matrices for both classifications based on 14 bands (i.e., 

supervise and unsupervised). What is your opinion: did the classification accuracy improved or 

not by including the remote sensing indices? 
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8.6 Advanced topics:  Multispectral and thermal bands – Remote Sensing 

Indices  
 

Lab developed by Sudeera Wickramarathna and Dr. Strimbu from Nelson and Khorram, 2018 and ERDAS 

documentation. 

 

8.6.1 Objectives 

• Create binary masks to exclude pixels. 

• Create different image indices, including NDVI, NBR. 

• Recombining classification components.  

• Assessing (qualitatively) the effect of wildfires using image indices.  

8.6.2 Files used in this Lab 

The files needed to complete this Lab are supplied by the U.S. Geological Survey, and are located 

on Canvas, Week 8 Lab. Copy the files to a local drive. 

Files (.dat and .hdr format) Description 
PostFireOLISubset Landsat 8 OLI bands (seven total), from May 25, 2014 
PreFireNBR Normalized Burn Ratio image from May 9, 2014 

 

The images are related with the wildlife that occurred on May 2014 in San Diego County, CA. In 

May of 2014, close to 20 different wildfires erupted in San Diego County, triggered by Santa Ana 

winds and a heat wave. The first fire started on May 5, and the last remaining fires were 

extinguished by May 22. By May 18, the fires had burned more than 27,000 acres (42 square 

miles) of land (Figueroa and Winkley, 2014). Some of the communities affected by the fire 

included Camp Pendleton, Carlsbad, San Marcos, and Escondido. 

 

8.6.3 Background on Burn Indices 

Land resource managers and fire officials use burn severity maps from remote sensing 

instruments to predict areas of potential fire hazards, to map fire perimeters, and to study areas of 

vegetation regrowth after fires. Landsat imagery has traditionally been used to create indices that 

indicate burn severity because of its repeated coverage, ease of access, and spectral wavelengths. 

In this Lab, you will create burn severity images using a variety of different indices, such as burn 

area index, normalized burn ratio, and normalized burn ratio thermal. 

8.6.3.1 Normalized Difference Vegetation Index (NDVI), or greenness map 
 

“The NDVI is a popular tool used in forest vegetation health assessments and represents an index 

of vegetation greenness. Chlorophyll pigments (light-absorbing pigments) found in the leaves of 

healthy vegetation absorb incoming radiation (visible light) in the blue (0.45 μm) and red range 

(0.67 μm) of the electromagnetic spectrum (EMS). Green (0.5 μm) is reflected more so in the 

near-infrared (0.7–1.3 μm) ranges of the EMS. Particularly in the near-infrared portion of the 

EMS, there is a strong reflection of light largely due to the internal makeup of a leaf’s structure. 
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When vegetation becomes stressed due to drought, infestation, disease, and other reasons, the 

leaves typically decrease reflection in the near-infrared range as the leaf’s internal structure 

begins to change. A NDVI image is created for specific image dates through the division of the 

image’s red and near-infrared spectral bands (NIR – RED/NIR + RED). Multiple NDVI images 

can be generated to determine the spectral signatures for areas of healthy vegetation vs. areas of 

stressed vegetation. This type of application is useful for identifying areas 

where vegetation is under stress” (Nelson and Khorram, 2018).  

8.6.3.2 Normalized Burn Ratio 
The Normalized Burn Ratio index highlights burned areas in large fire zones. The formula is 

similar to a normalized difference vegetation index (NDVI), except that it uses near-infrared 

(NIR) and shortwave-infrared (SWIR) wavelengths (Lopez, 1991; Key and Benson, 1995). 

NIR SWIR
NBR

NIR SWIR

−
=

+  

The NBR was originally developed for use with Landsat TM and ETM+ bands 4 and 7, but it will 

work with any multispectral sensor (including Landsat 8) with a NIR band between 0.76-0.9 µm 

and a SWIR band between 2.08-2.35 µm. 

 

References 
Key, C. and N. Benson. "Landscape Assessment: Remote sensing of severity, the Normalized Burn Ratio; and ground measure of severity, the Composite Burn Index." 

In FIREMON: Fire Effects Monitoring and Invenstory System, RMRS-GTR, Ogden, UT: USDA Forest Service, Rocky Mountain Research Station (2005). 

Lopez Garcia, M.J., and Caselles, V. "Mapping Burns and Natural Reforestation using Thematic Mapper Data. Geocarto International 6 (1991): 31-37. 

Nelson, S.A. and Khorram, S., 2018. Image Processing and Data Analysis with ERDAS IMAGINE®. CRC Press. 

 

8.6.3.3 Land-Only Image  
Generally, the presence of water or water bodies in an image can cause potential issues in land 

cover classification. Mainly due to the broad spectral range of reflectance values. Therefore, 

removing the water pixels from the image would help in focusing the classification only on the 

terrestrial area. 

 

1. Open ERDAS Imagine and click File → Open → Raster Layer. Then navigate to the 

week 8 data folder and select PostFireOLISubset. Then display the false-color 

composite (FCC → Red:5, Green: 4,Blue: 3). 

 

2. Next, we will create a new unsupervised classification of the Landsat 8 subset image by 

selecting Raster → Unsupervised → Unsupervised Classification. 

3. Specify an output file name of PostFireOLISubset_unsupclass in the lab 8 folder. In this 

lab, we do not need to use the output signature file. Therefore you do not need to check 

the Output Signature Set in the Unsupervised Classification dialog box.  

 

4. Now, click on the Color Scheme Options button in the Unsupervised Classification 

dialog box. Change the output color values to 5, 4, 3. You may keep all other settings as 

default. Then click, OK. 

5. Next, you will see the process list window and processing of unsupervised classification.  

Once processing is complete, you can close the process list window. 
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6. Once the process is completed, you can open the classified image by navigating the File 

→ Open → Raster Layer. Then select the PostFireOLISubset_unsupclass image. 

 

NOTE: If you have selected the default “Color Scheme Options → Approximate True Color” 

during the Unsupervised Classification, the output color coding of the classified image follows 

the color scheme of the Landsat 8 FCC subset image. Therefore, the unsupervised classified 

PostFireOLISubset_unsupclass image will look almost similar to the original image. 

 

Q1 (10%). Include a snapshot of the PostFireOLISubset_unsupclass image. 

 

8.6.3.4 Thematic Image Recode 
In the next steps, we are going to recode the values of classes in an unsupervised classification 

image. During this process, we will recode the initial classes (i.e., 36 in this case) into two major 

classes, particularly, either land = 2 or water = 1. 

 

1. You can right-click on the PostFireOLISubset_unsupclass image and select the 

Display Attribute Table option. Now you can explore which classes are water and which 

are land.  

 

2. Next, you can change the color of each class by clicking on each row in the attribute 

table to see which classes are “water” and which are “land.” You can assign blue for 

water and Brown color for land.   
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3. Once you have determined the classes belong to water, change them to “1” in the 

“Class_Name” column of the attribute table. Then, you can rename the classes belongs to 

land as “2” in the “Class_Name” column of the attribute table. Do not change the box 

labeled “0” or “unclassified”.  

  
 

NOTE: You may need to save the work once you changed the classes into water and land.  You 

can perform this by right-clicking on the file name in the Contents Pane and then Save Layer 

and close the attribute table. 

 

4. Go to Raster → Thematic under the Raster GIS category grouping and click Recode 

option. The Recode dialog box will open and select PostFireOLISubset_unsupclass as 

the input file. Name the output file PostFireOLISubset _recode and select Ignore Zero 

in Stats option. Do not close the Recode dialog window yet. 

 

5. Next, click the Setup Recode option. Now we are going to recode the image so that we 

can differentiate water from land. You can select and highlight the water classes by 

holding the Shift key and clicking rows belonging to the water class (water=2). Next, 

select “1” for New Value box and click Change Selected Rows. You will see that 

changes are updated in the New Value column.  For example, the New Value column 

will show 1 for all the water classes.  
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6. Next, you can change the New Value column for land classes. You can highlight the 

land classes using the Shift key and then change the number in the New Value box as 2. 

Then select Change Selected Rows and click OK. Now, you will see that all the classes 

belong to land converted into “2” in the New Value column.  

Click OK again in the Recode dialog window. Now the new classes will simply be 

displayed as water = 1 and land = 2.  

 

NOTE: You may need to maximize the Thematic Record window so that you can select 

the rows quickly.  

 

 
 

7. Open a second View by clicking Home → Add View → Display Two Views. Next, you 

can open the newly recoded classified image by selecting File → Open → Raster Layer. 

Then select the PostFireOLISubset_recode image.  

8. Next, we are going to assign the colors to the main two classes: water and land. You can 

open the attribute table and change the color of class 1 (water) to blue and class 2 (land)to 

brown. 

9. Now, you can compare the recoded image with the original image. For better comparison, 

you can link the views and synchronize two views.  

 

8.6.3.5 Binary Image Mask to Remove Water 
 

1. Click Raster → Subset & Chip →Mask in the Geometry category group. Select the 

original Landsat 8 subset image (PostFireOLISubset) as the input file and 

PostFireOLISubset_recode as the input mask file. 

 

2. Then select Setup Recode. Next, click on class “1” in the Value column to highlight it 

(Class 1 = water features). Enter “0” in the New Value box and click on Change Selected 
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Rows. Now you will see the New Value column with the updated value of 0 for water 

class.  

3. Similarly, you can click on class “2” in the Value column to highlight it. Then change 

class 2 to a value of “1” (Class 2 =land features) in the New Value box and click on 

Change Selected Rows. Now you will see the New Value column with the updated value 

1 for land class.  

4. Name the output file PostFireOLISubset_land. Make sure to activate Ignore Zero in 

Output Stats option and click OK. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

5. Next, add the new PostFireOLISubset_land file to 2DView#2  and make false-color 

composite as (Red: 5, Green: 4, Blue: 3) to compare the output, you can do this by 

swiping between PostFireOLISubset_recode and PostFireOLISubset_ land files. Use 

the Swipe option under Home → Swipe . Now you have created a 

classification mask image that contains only the land features, as the water features are 

now masked out.  

 

Q2 (10%) Insert the screenshot of your masked  out image.  

0 
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8.6.4 Create a Normalized Difference Vegetation Index 

 

From previous steps, we have removed the water features from the image. Now we are going to 

perform a specialized type of unsupervised classification on just the land area. “This specialized 

type of unsupervised classification is a vegetation index representing the amount of greenness 

within the image and is known as a Normalized Difference Vegetation Index or NDVI.” 

 

1. First, clear the 2D View#1 and select Raster → Unsupervised → NDVI under the 

Classification category group. Use PostFireOLISubset_land as the input file and name 

the output file PostFireOLISubset_ndvi. 

 

NOTE: Remember, the PostFireOLISubset_land file contains only the land features, as the 

water features were masked out in the previous steps. 

 

2. Next, make the following selections in the Indices dialog window: select Senor as 

Landsat 8 MS and Category asVegetation. 

 

NOTE: The image that the PostFireOLISubset_land image was originally derived from the 

Landsat 8 sensor. Because this option does not show up, it is necessary to ensure the correct 

bands that relate to the Landsat 8 (Red (Band 4) = 636–673 nanometers and NIR (Band 5) = 851–

879 nanometers) are specified (Nelson and Khorram, 2018). 

 

Useful link: https://www.usgs.gov/core-science-systems/nli/landsat/landsat-8 

3. Index: NDVI—Normalized Difference Vegetation Index as the function should be: (NIR - 

RED)/(NIR + RED). 
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Band Selection: In the NIR column check Band 7, and in the Red column check Band 5. 

4. Click the I/O Options tab and select Map as the coordinate type and check. You can leave 

other settings as default.  

5. Select 2D View#2 and then go to File → Open → Raster as Image Chain.. 

. Navigate to your folder and open the newly created 

PostFireOLISubset_ndvi. 

 

6. 
You will notice that the new Preview|Pseudocolor toolbar will open.  

7. You can click the Image Chain icon  and then select  Pseudocolor. Then use the options 

available under Color Table to visualize the NDVI image.  

NOTE: Based on your interest or purpose, you can select the options under Color Table.  

1. Raster as Image Chain 
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You can apply enhancements, apply color ranges, and extract features from raster images using 

the Raster as Image Chain option. When you open a Raster image using the Raster as Image 

Chain option, one of the following tabs becomes available depending on which image chain is 

currently selected. 

 

2. Pseudocolor tab contains tools for applying a color table onto grayscale, elevation, and 

thematic images in addition to single layers of multispectral images after their stretches are 

applied. It is generally intended for use with data that is ordinal in nature, such as digital 

elevation models (DEMs), brightness / reflectance / radiance imagery, thermography, and so 

forth, so that you can apply a color ramp to help you visually interpret data that would otherwise 

be displayed as grayscale. 

 

This tab is available when you use the Pseudocolor image chain to view your image. This 

happens by default when you open a thematic Raster that does not have a color table using 

either File > Open > Raster as Image Chain or through connecting a thematic Raster output 

that does not have a color table with the Preview operator in the Spatial Model Editor. This tab 

also opens when you select the Thematic image chain from the Image Chain menu on another 

Image Chain tab. 

The Pseudocolor tab is grouped into these categories (see below for details): 

• Settings 

• Save 

• View 

• Enhancement 

• Color 

3.  Color Table - Open the Color Table  gallery as well as the Color Ramp Panel. Note that 

any stretches are applied prior to applying the color ramp mapping. Consequently any input data 

range can still be mapped through a color ramp which might only consist of 256 colors. This is 

possible because the stretch, such as a 2 Standard Deviation stretch, maps the input data into the 

range used by the color table. This also means that altering the stretch will alter the distribution of 

colors that are applied and can be used to assist in interpreting the data visually. (source: ERDAS 

Imagine).  

 

 

Q3 (15%): As mentioned earlier, this PostFireOLISubset image was captured after a 

wildfire and we use that image to derive PostFireOLISubset_ndvi. Now, select an 

appropriate option (color ramp) from Color Table to detect the wildfire patches using 

PostFireOLISubset_ndvi.  Insert a screenshot of your screen which has the orginal 

PostFireOLISubset image and PostFireOLISubset_ndvi image. (similar to the above 

figure). 

 

Q5 (5%) Write a short description of how you delineate or estimate the impact (area) of 

wildfire using ERADS Imagine options you learned so far.  

 

8.6.5 Classify the image using Normalized Difference Vegetation Index 
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Next, you are going to perform an unsupervised classification on the previously created 

PostFireOLISubset_ndvi.  

 

8. Now select Raster → Unsupervised→ Unsupervised Classification option available under 

the Classification category group. Select PostFireOLISubset_ndvi as input image and 

select PostFireOLISubset_veg as the output file name.  

 

9. Then specify the number of output classes and select 10 for classes for this exercise. Keep the 

other settings as in the following figure (settings). Next, select Color Scheme Options and 

choose Grayscale. Also, the output signature file is no need for this exercise. So you can 

uncheck the box for that option and click OK. 

 

 
 

10. Next, the Process List window will appear once the processing is complete. Close the process 

list window. 

 

11. Now you can open the newly classified image by the following File  → Open → Raster 

Layer and select the PostFireOLISubset_veg image. 
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12. Right-click on the PostFireOLISubset_veg in the content pane and open the attribute table. 

You should see 10 classes and one unclassified labeled as 0. 

 

13. You can change the colors of classes 1–10 and try to differentiate between different 

vegetation classes. You should be able to separate a minimum of five classes: For example, 

you can select classes such as forest (deciduous forest or evergreen forest), herbaceous 

grass, burned areas, developed (non-vegetated), and barren land (mostly beech areas).  

 

14. Think and decide whether if you need to combine more classes for better classification 

output.  

 

NOTE: Alternatively, you can try Raster > Table> Colors in Query group to assign color 

ramp. You can select Start Color and End Color; ERDAS will create a color ramp for you. 

 

 
 

15. In this exercise, you are not required to perform an image classification that you have done in 

Lab 6 or Lab 7. But if you are interested, you can perform a detailed image classification as 

we have done in Lab 7, by recoding the 10 classes into 5 classes.   

 

16. To see just the output, you can assign similar colors to the classes that you want to combine, 

as explained in the following images:  

 

Save your work frequently! 
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Q6 (15%). Include screenshots of the attribute table with combined classes (as above figure) 

and the classified image.  

 

 

8.6.6 Create an Impervious Surface Map (Remove Vegetation)  

 

Since we have completed the NDVI output, we can now continue our work to determine if the 

developed areas (such as impervious land cover) can be better isolated by removing vegetation 

features. 

8.6.6.1 Create an Impervious Surface Map (Remove Vegetation) 
 

1. This section, we are going to mask out all vegetative features while leaving only the developed 

features remaining in the image. 

 

2. First, go to Raster → Subset & Chip → Mask. Then Mask dialog box will open and select 

the PostFireOLISubset image as the input file. Then select PostFireOLISubset_veg as the 

input mask file. 

 

3. Next, click on setup Recode and highlight all the vegetative classes (i.e., deciduous, 

evergreen, and farmland…etc.).  
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4. Now, enter “0” in the New Value box and then click Change Selected Rows. Similarly, 

highlight all the developed classes/non-vegetation features (i.e., developed and barren) and enter 

“1” in the New Value box and click on Change Selected Rows. Once you finished this step, you 

will see the updated values in the Value column.  

 

5.You can name the output file as PostFireOLISubset_devmask. Also, select Ignore Zero in 

Output Stats and select OK to create the mask.  

 

6. Next, you can see the new PostFireOLISubset_devmask by adding it to the 2D View#2. Try 

to swiping between PostFireOLISubset_devmask and PostFireOLISubset_veg. 

 

 

Q7 (10%). Include a Screenshot of PostFireOLISubset_devmask image with 

PostFireOLISubset_veg underneath (use Swipe tool, so you can see both the images)  

 

8.6.6.2 Classify the Impervious Surface Map 
 

In this section, we are going to perform unsupervised classification just considering the 

developed or non-vegetated categories. We will be using an unsupervised classification and the 

mask created in the previous step. 

 

6. First, we have to choose a false-color band combination for displaying the 

PostFireOLISubset_devmask image you just created. This step will help you to separate 

different intensities of development or types of impervious surfaces (i.e., 5, 4, 2).  

 

7. Then go to Raster → Unsupervised → Unsupervised Classification under the 

Classification category group. Select input file as PostFireOLISubset_devmask and 

name the output file name as PostFireOLISubset_impervious. 
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8. Next, you can specify the number of output classes. For this exercise, choose 

6 (for low, medium, and high-intensity urban cover) and uncheck the output signature file 

box.  

 

9. You need to adjust the Color Scheme Options → Approximate True Color to match 

the band combinations (e.g., Red:5, Green: 4, Blue: 2) and click OK. 

 

10. A Process List window will appear. Within a short time, processing will complete and 

you canclose the process list window.  

 

11. You can open the newly classified image by selecting File → Open → Raster Layer and 

select the PostFireOLISubset_impervious image. 

 

12. Now you can zoom into the image to observe the different class of impervious cover. You 

can change each classes color in the attribute table if needed.  

 

Q8 (10%). Include a screenshot of your classified PostFireOLISubset_impervious image.  
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8.6.6.3 Recombine Classification Components 
 

Under this section, we will recombine the three classification components in the viewer (i.e., 

water-only, NDVI-veg, and other-Impervious). This will provide a final output with a more 

detailed classification. 

 

1. You can just try to visualizing a combined dataset by selecting 

PostFireOLISubset_unsupclass, PostFireOLISubset _veg, and 

PostFireOLISubset_impervious in the 2D View#2 window. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

8.6.7 Task automation in ERDAS: Model Maker 

 

In many instances you are faced with creating of a succession of tasks that most likely will be 

repeated. In this case Model Maker tool can be used in ERDAS. Model Maker is a spatial 

modeler language that is presented as a graphical interface rather than as a code. Model Maker 

allows you to develop customized algorithms (succession of tasks) by recoding each output layer 

and then combining them. For example, suppose the analyst wants to create an image to strongly 

accentuate impervious features possibly. In that case, the PostFireOLISubset_impervious 

image (containing only impervious features masking out all other non-impervious features) could 

be added to the recoded the PostFireOLISubset_veg file containing all 10-land cover class, plus 

the unclassified class.  

The resultant image would produce a combined image that has the impervious-only layer added 

into the vegetation recoded original image, which also contains the impervious data, thus 

theoretically increasing/improving the impervious signature (Nelson and Khorram, 2018). 

 

The following steps will perform this operation with Model Maker: 
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1. First, you need to start Model Maker by navigating to Model Maker → Toolbox 

tab.  

 

 

 

 

 

 

 

2. Next New Model dialog box will open. Select the Place a Raster object in the 

model object in the model space. Add this object three times, as shown in the 

following figure.  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

3. Now, you need to double-click on each Raster Object to specify the input layers 

(PostFireOLISubset_impervious and PostFireOLISubset_veg), as well as name the 

output image layer (such as PostFireOLISubset_combined_veg_imperv or combine).  

4. A raster dialog box will open, and you can enter your respective image file each time, 

as shown in the above figure.  
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5. Then, you have to select the Place a function in 

the model option to connect the raster objects. You 

can use the cursor to draw a function circle in the 

middle of the model space.  

 

6. Next, select the Connect inputs to function or 

function to outputs option  to connect the two 

input image layers 

(PostFireOLISubset_impervious and 

PostFireOLISubset _veg) to the function as shown 

in the image.  

 

Q9 (10%). Insert a screenshot of your model (similar to 

the above figure)  

 

Also, add a single arrow to connect the function to the output raster object 

(PostFireOLISubset_combined_veg_imperv or combine) 

 

7. Double-click the function circle in the model space. Then the Function Definition 

dialog box will open. In the Function Definition dialog box, you can select Arithmetic 

from the Function dropdown list and create the expression:  

$n2_ PostFireOLISubset _veg + $n1_ PostFireOLISubset _impervious. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

8. Then click OK in the Function Definition dialog and click the red lightning bolt  in 

the New Model window to run the model. 
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9. Once the Process List is completed, you can close this list and the New Model window. 

Then open the new image layer in ERDAS Image. You may compare this image to the 

original PostFireOLISubset_impervious image.  

 

 
 

NOTE: If you want to add the colors to the output, you can follow the following steps.  

Select 2D View#2 and then go to File → Open → Raster as Image Chain.. 

. Navigate to your folder and open the newly created 

PostFireOLISubset_ndvi. 

 

Q10 (15%) Include the output of your PostFireOLISubset_combined_veg_imperv image. 

 

Extra Credits (20%): Working with NBR- Normalized Burn Ratio index 

 

1. First, select Raster → Unsupervised → Indices under the Classification category 

group. Use PostFireOLISubset_land as the input file and Choose the sensor as 

Landsat 8MS. 

2. Select the Index as NBR-Normalized Burn Ratio and name the output file as 

PostFireOLISubset_nbr. You can keep the other settings as default (refer to the 

following figure) and click OK. Now open the image using the following steps.  
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3. Select 2D View#2 and then go to File → Open → Raster as Image Chain.. 

. Navigate to your folder and open the newly created 

PostFireOLISubset_nbr. 

4. You can click the Image Chian icon  and then select Pseudocolor. Then use the 

options available under Color Table to visualize the PostFireOLISubset_nbr image. 

  

5. Compare PostFireOLISubset_nbr vs. PostFireOLISubset_ndvi, you created either 

using two View windows or Swipe tool (You have to use the same color ramp for this 

step). 

EC1 (10%). Describe with few steps how you can use this approach to determine 

(qualitatively) the damage that occurred due to the wildfire.  

6. Now, navigate to the data folder and add the Prefirenbr to the 2D View#2 window by 

using the following above step 3. 

7. You can click the Image Chian icon  and then select Pseudocolor. Then use the 

options available under Color Table to visualize the Prefirenbr image. When you select 

a color table, select IMAGINE color ramp from Color Table for both the images. 
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NOTE: Prefirenbr is Normalized Burn Ratio image from May 9, 2014.  

PostFireOLISubset_nbr is Normalized Burn Ratio image you just created from 

Landsat 8 OLI bands (seven total) from May 25, 2014.  

 

EC2 (10%). Now you have Normalized Burn Ratio images from two dates to compare. 

Think of a possible method that you can implement to estimate the spread of wildfire from 

May 9 through May 25, 2014. (You can answer this with a few sentences) 

Hint: Estimating the burned area by demarcating the burned patches.  
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9 Introduction to Lidar  
 

Lab developed by Dr. Strimbu from USFS documentation.  

 

9.1 Objectives 

• Understanding and accessing the information stored in a las file 

• Basic processing of point cloud 

• Introduction to Fusion, the USFS lidar processing software 

9.2 Files used in this Lab 

The files needed to complete this Lab are supplied by the U.S. Forest Service, and are located on 

Canvas under Week9 module.  

Files  Description 

lda_4800k_data.las Point cloud  

Orthophoto_4800k.jpg Ortho-rectified image 

Orthophoto_4800k.jpgw Ortho-rectified image georeferenced 

4800k_DSM Digital surface model 

4800k_ground_surface Digital terrain model 

three_plots.shp (shx, dbf etc) Shapefile 

 

Lab Content 

9.3 Part I: Introduction to Fusion  

9.3.1 Download and Install Fusion (this step may not be necessary if you are in the lab or 

access Fusion through Citrix). 

9.3.2 Download Fusion 

Open a Browser  

1. Connect to: http://forsys.sefs.uw.edu/fusion/fusionlatest.html to open “The Latest 

Version” Fusion webpage.  

2. Click the Install File hyperlink to open the File Download dialog for 

Fusion_Install.exe.  

3. Click the Save button to open the Save As dialog.  

4. Navigate to a location of your choosing (one that you will remember) and/or create a 

new folder and click Save. The file (Fusion_Install.exe) will download.  

When the download is complete, Open (or Run) Fusion_Install.exe.  

1. The first screen of the Fusion Setup dialog will display.  

2. Keep the default installation Components and click Next  

3. Keep the default Install Location and click Next   

4. And, keep the defaults for the Start Menu Folder and click Install.  

5. After the installation completes, click Close. 

9.3.3 Add Fusion.exe to the Environmental Variables 
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1. Open the Start Menu and Right-Click on My Computer or This PC, depending on the 

Windows version.  

2. Select Properties from the drop-down menu and then click Advanced system settings in 

the left sidebar.  

3. In the System Properties dialog box select the Advanced tab.  

4. Under the Advanced tab click the Environment Variables button at the bottom.  

5. In the Environmental Variables dialog box, under “User variables for (your username)” 

(see following graphic), if there is a path variable click Edit. If not, click New and call the 

Variable name: path.  

 
6. For Variable value, enter the directory for Fusion.exe, (ideally c:\FUSION) and click 

OK.  

7. Click OK in the remaining dialog boxes to close them and retain the edit. Now let’s 

quickly test the new environment variable.  

8. Open a Command Prompt by clicking Start > Programs > Accessories > Command 

Prompt and type catalog and press Enter. If you are using Windows 10, you can type 

“Command Prompt” in the search bar, then press Enter. You should now see a description 

of the Fusion command line executable “catalog.exe”.  

9. If the command prompt did not recognize catalog as a command, the edits you made to 

the path environmental variable were not successful. If this is the case, you can repeat the 

above steps and try again, ask the course instructor or TA. You may need administrative 

privileges to edit the user Environmental Variables. 

9.3.4 Download LAStools 

1. Connect to the LAStools site: https://rapidlasso.com.  

2. On the main menu, click LAStools > download.  

3. Unzip the downloaded file and navigate to LAStools > LASzip > dll.  

4. Copy the LASzip.dll file. 

5. Navigate to the folder where you installed Fusion and paste the LASzip.dll file in there 

9.4 Getting started with Fusion and Loading the Example Lidar Data 

A. Click the shortcut to start Fusion  

1. Click the Raw Data button on Fusion toolbar to display the Open dialog box.  
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2. Navigate to your data folder (for example, C:\lidar\SampleData\) and Select the sample 

dataset (lda_4800k_data.las) and click Open. This will open the Data Files dialog.  
* The Data Files dialog allows you to change the display Symbology of the lidar data in the 

Fusion window—but, I recommend that you accept the defaults for now. 

3. Click OK (read the note below before making any changes).  

4. Save your Fusion project by clicking the Save icon or File > Save As.  

5. Name the project exer1.dvz and Save it somewhere easy to find. 

B. Examine las header 

 Besides xyz coordinates of each return, a las file store information about the way how the 

point cloud was created, as well as some summary statistics, such as the number of points or min 

and maximum elevation. To see the las header, you should click Tools->Miscellaneous utilities-

>Examine las file header: 

 
 

In the window that appears after you select Examine LAS headers, navigate to 

lda_4800k_data.las. After you click Open you will see the information stored in the header. 

 

9.5 Load a Reference Image 

Click the Image button  
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1. Select the sample orthophoto (orthophoto_4800k.jpg) from your sample data folder and 

click Open. The image will automatically display in the Fusion viewer. Fusion requires a 

reference image before you can view your lidar data in Lidar Data Viewer (LDV). If you don’t 

have a reference image available, you can create an intensity image from the raw lidar data to use 

as your reference image. This capability can be accessed through the FUSION interface: Tools > 

Miscellaneous Utilities > Create an image using LIDAR point data. 

i. If you want to zoom-in to any part of the image, Right Click on the location you 

want to zoom to. Zoom-out by holding down shift and right-clicking the image.  

ii. You’re now ready to view the lidar data in the Lidar Data Viewer (LDV) 

9.6 View a Sample in LDV 

To create a sample and view the corresponding Lidar data in 3D:  

1. Position the cursor over an area of interest in the orthophoto, left click and drag a small box 

(called a stroked box) over the area and release the left mouse button—this is your sample 

(see the following figure).  

 

Note: a small sample works better (faster) than a large sample. If the area you selected is not a 

square, it means that the shape of selection is set to a fixed box, fixed circle, stroked circle, or 

corridor. To change it to a stroked box (basically a rectangle with side not preset) click on 

Sample Options, then change the shape of sampled points to Stroked box. 

 
2. The sample box will be highlighted in the Fusion viewer and LDV; Fusion’s 3D viewer will 

automatically appear and load the Lidar data within your sample boundary, similar to the 

following figure. The default coloring scheme is color the points based on height, in actuality 

elevation, but if you want to change it, you can select Sample options, then choose a different 

option, such as color by classification or intensity. 
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3. Use the Basic LDV Navigation Tips 

(see below) until you are comfortable 

with your ability to control the data 

cloud. The LDV contains two image 

areas: the point cloud, the largest image 

displayed in the LDV, and the summary 

statistics associated with the point 

cloud, which is the colored bar on the 

left. Depending on the selected attribute, 

the bar could show the height or 

intensity. In the image above, the height 

is displayed. The largest value is the 

largest elevation, which depends on whether or not the ground is subtracted from the 

elevation of each point. The process of subtracting the ground from each point is called 

normalization of the point cloud, and the product is a normalized point cloud. A normalized 

point cloud has the ground at 0, and if you look at it from the side it will have a flat bottom. 

a. Tips with Basic LDV (Note: LMB = Left Mouse Button, RMB = Right Mouse 

Button): 

i. LMB + move mouse: “Grab” and rotate the displayed data (rotation can be 

up/down and left/right) 

ii. It may be easiest to imagine that the data is contained in a glass ball. To rotate 

the data, use the mouse to roll the ball and thus manipulate the data. 

iii. LMB + ctrl + move mouse down: Zoom in 

iv. LMB + ctrl + move mouse up: Zoom out 

v. RMB: Activate the pop-up options menu for LDV 

vi. For a complete list of LDV keystrokes, Click the About LDV and Keystroke 

guide button in the bottom left corner of the LDV (highlighted in red in the 

graphic to the right). 

9.7 Add a Bare Earth Model 

Close the LDV and return to FUSION (it will still be running & your last sample will be 

displayed).  

1. Click the Bare earth button (located on the Fusion toolbar).  

2. Select the terrain model (4800K_ground_surface.dtm) from the folder and click Open.  

3. Within the Surface model options window, you can accept the defaults or define contour 

intervals and line colors. Once you have chosen intervals and colors or accepted the defaults, 

click OK.  

i. The terrain model will be displayed in the viewer as a contour map over the orthophoto.  

4. Click the Repeat last sample button (located on the Fusion toolbar). This will display the 

same lidar data cloud as before.  

5. Right-Click within the LDV viewer to access the “Right Click Menu”.  

6. Click on Surfaces (or use the Alt-U keyboard option). The bare earth surface will 

automatically display with your lidar data cloud (see the following figure). 
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7. Access the right-click menu again and Click on Data to toggle the data off (or type Alt-D). 

This will allow you to inspect the bare earth surface without the data cloud (see the following 

figure). To turn the data back on using the right-click menu and click on Data again or type 

Alt D again. 

 
 

9.8 Explore Fusion’s Sampling Options 

A. Change sample options  

1. In the FUSION window, Click the Sample options button to open the Sample Options 

dialog.  

2. Under the Sample shape section, select Stroked circle (the default is Stroked box) and 

click OK.  

3. Select a small stroked-circle sample in the Fusion window and view the results in the 

LDV.  

4. Close the LDV.  

B. Return to the Sample options  

1. Change the sample shape back to a Stroked box.  

2. In the Decimation section, increase the value to 200 and click OK.  

3. In the Fusion window, select a large stroked-box sample (make the stroked box cover 

about half the size of the reference image).  
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i. It may take a few minutes to extract the sample, but the results display very fast 

in LDV. Notice that the ground is not flat within the sample area as you view the data in 

the LDV; you’ll make it flat in the next sample.  

4. Return to the Sample options and select (check) the Subtract ground elevations from 

each return in the Options section and click OK.  

5. FUSION Tip - you can only use the Subtract ground elevations option if you’ve loaded 

a Bare Earth Surface (which you’ve done).  

6. Click the Repeat Last Sample button. This will repeat the last sample area, but now the 

data will appear in LDV as flat terrain—this is very useful for comparing heights above ground 

level.  

7. Return to the Sample options and change the Decimation value back to 1 and deselect 

the option to Subtract ground elevations.  

8. Select the Bare Earth Filter option to Exclude points close to surface and increase the 

tolerance to 2.  

9. Click OK to close the sample options dialog.  

10. Select a small stroked box sample in the Fusion window  

      Note that the points close to the ground have been excluded from displaying in LDV.  

11. Return to the Sample options and select the Include all points option under Bare Earth 

Filter, and select the color using image option under the color menu.  

12. Click the Repeat last sample button. You should notice that each lidar return is now 

painted the color of the corresponding reference image. Keep the LDV open.  

13. FUSION Tip - Some of the sampling and display options can be very computer-

intensive and are appropriate only with a fast computer and a small sample area. You will have to 

be the judge of what your computer is capable of handling. A class 3 computer is recommended 

for general lidar data exploration and analysis. 

 

9.9 Explore Fusions Display Options 

A. Explore a few of the display options within LDV  

1. Access the right-click menu and toggle (either on or off) the Draw all points when 

moving option. Click-and-drag to move the data sample. If you’ve toggled the Draw all points 

option on, the responsiveness of your display may be sluggish (but it looks good), and if you 

toggle the option off, the LDV display will be very responsive (but it won’t look as good).  

2. Set the Draw all points option to suit your computer and your preferences.  

3. Access the right-click menu again and click the Marker option.  

4. Experiment with the Marker Type and Marker Size options—however, be aware that 

some of the marker types only work well with fast computers. If in doubt, keep the marker type 

set to Points.  

5. Back in the Fusion window, Click the Sample Options button.  

6. Enable the Color by Intensity option.  

7. Click OK and then Click Repeat Last Sample.  

i. The LDV viewer will display returns according to their intensity value (or the near-

infrared spectral value). The intensity information can be helpful to interpret ground features. 

However, because the intensity information of the ground features are clustered on only a small 

portion of the displayed intensity range, the default display parameters make the data difficult to 

interpret. Let’s adjust the intensity display parameters to improve interpretation. 



Remote Sensing and Photogrammetry – Forestry Applications 

211 

 

 

B. Click the Histogram checkbox on the left side of the LDV viewer (see following graphic). 

1. The histogram will display (black) along with the color legend  

2. You should see that most of the intensity values are clustered in the lower half of the 

available intensity range. Let’s truncate the available range to the approximate range of the 

intensity values (so that we can interpret the LiDAR data better).  

3. Write down the approximate low and high-intensity values that capture most of the 

histogram.  

4. Click the Sample Options button in the Fusion window.  

5. Enable Truncate Attribute Range (in the Color section).  

6. Enter your approximate minimum and maximum histogram values.  

7. Click OK and then Click Repeat Last Sample.  

ii. Now, you’ve effectively stretched your intensity data to cover the full-color legend for 

improved interpretation (see following graphic). High intensity values (or high near-infrared 

values) for natural communities most likely represent photosynthetically active vegetation, and in 

some cases, may represent dry bare soil. Lower intensity values likely represent: 1) wet, bare soil 

2) water or 3) less photosynthetically active vegetation. 

 
 

 

C. Continue to interact with the data in LDV and experiment with the following items on 

the right-click menu.  

1. Wiggle-vision (Alt-W)  

2. Overhead View (Alt-O)  

3. Reset Orientation (Alt-R)  

4. Reset Zoom (Alt-Z)  

5. Image Plate (Alt-P)  

6. Turn the truncate function off and choose the color by the option that seems most 

appropriate for general visualization (color by height is recommended).  

7. Save the project: File > Save. 
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9.10 Extracting Plot Subsets 

This exercise builds upon the previous exercise and uses the same sample data. You should have 

FUSION up and running with the Orthophoto_4800k.jpg image file displayed and the 

lda_4800K_data.las raw data file loaded (but not displayed). We have coordinates of the center 

points of three plots that have been converted to a shapefile (three_plots.shp). 

9.10.1 Subsetting One to a Few Plots 

A. Loading a shapefile as a POI (Point of Interest) in Fusion  

1. Click the POI button.  

2. Navigate to the location of the three_plots.shp shapefile.  

3. Select the file and click Open.  

4. Change the attributes (color and size) of the POI if desired (see following graphic) and 

click OK. The three plot locations will display over the orthophoto.  

** If you’ve already loaded the bare earth surface for this project area, skip to step 9. 

 

 
 

5. Click the Bare earth… button. 

6. Navigate to and select 4800K_ground_surface.dtm. 

7. Click Open. 

8. Accept all of the surface model default options and click OK. Topo lines representing the 

ground surface elevations will display over the orthophoto image. 

9. Now, we only want to select the lidar data within our plots rather than the entire lidar 

dataset. 
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B. Click the Sample options button (see following graphic) and select the following options 

 
1. Sample shape: Fixed circle. 

2. Size: 120 (diameter in feet) Note: in future projects, make sure the units of the data and 

the plot are the same. If the data are in UTM meters, convert the plot diameter to meters as well. 

3. Options: activate (put a checkmark in the box) Snap sample points to nearest POI point. 

4. Options: activate Subtract ground elevation from each return. 

5. Click OK at the bottom left to accept the sample settings. 

6. Next, within the Fusion display window, click on one of the plot locations (note which 

one you select). The POI changes color and an LDV window pop up showing the lidar points 

within the 120-meter diameter circle around the plot center. 

i. These lidar data points are simultaneously written to three temporary files named 

tempdat with three different extensions (.lda, .lgd, .xyz) in the user’s temporary folder 

(e.g., C:\documents and settings\user name\local settings\temp) as in the following figure. 

 
ii. Potentially, you could locate and rename the 3 temporary files with a corresponding 

plot identifier: ex Plot1.* and move them into a working directory. You would then have a 

subset (for each plot) of lidar data. It is good to be aware that FUSION writes these temp 

files and deletes them when FUSION closes (if you want the temp files, make sure you move 

and rename them!) In the next lab, we will work through a process that will allow you to 

automate the subsetting of many plots and subsequently calculate statistics for each plot. 
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9.11 Measurements of individual trees 

In many situations, you are asked to measure the height of individual trees. Fusion can execute 

this task easily, as it has a dedicated feature for manual measurements of tree height. To start this 

process first, you have to subset the data such that the focus will be only on a  small number of 

points.  

In the main Fusion window, click the Sample options button and select the following options:  

1. Sample shape: Fixed circle.  

2. Sample Size: 120 (diameter) Note: make sure the units of the data and the plot are the same, if 

the data are in UTM meters, convert the plot diameter to meters as well.  

3. Options: Subtract ground elevation from each return.  

4. Options: Snap sample points to nearest POI point.  

5. Options: Show POI layers in sample image.  

6. Bare earth filter: Exclude points close to the surface.  

7. Bare earth filter: Tolerance 1 (the tolerance is the distance from the surface in the same units 

used for LIDAR data elevations).  

8. Click OK at the bottom left.  

 
9. Toggle the checkmark for Plot mode on.  

10. Toggle the checkmark for Display sample on.  

11. Then click on the location of the plot from which tree information will be extracted (the 

lower-right most of the three plots is the easiest of the plots to use). The subset of data will pop 

up in the LDV window (see following graphic). 
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Note: if the axis and plot cylinder do not show, right-click in the LDV window to display the 

LDV right-click menu. Click on Colors menu item and set the axis color to a different color than 

the background color, let say white. If the axis shows but the plot cylinder does not, then ensure 

that the Plot mode button is checked in the Fusion window.  

You should notice that the height of the points is between a small negative value and less than 

200 (the colored bar on the left), which indicates that the values represent the actual height of the 

points above ground rather than elevation. The presence of negative values for height is due to 

the ground interpolation algorithm, which creates a surface best adjusted to the data. Therefore, 

some points could be above, some below, and some on the surface. Also, most of the ground 

points are excluded from the data set. If you wish to include them in the sample display, return to 

the Sample options and select the Include all points under the Bare earth filter options, and then 

click the Repeat last sample button. However, when you are doing individual tree measurements, 

it is advisable not to display the ground points because the focus is on the top part of the crown.  

 

To measure individual trees, Fusion has a special tool called Trea Measurement. To turn on the 

Trea Measurement window, you should either press F9. The Tree Measurement tool allows us to 

isolate a single tree within the plot and make measurements for that tree and more. The 

Measurement marker will display automatically—however, you can right-click anywhere in the 

LDV window to bring up the right-click menu and click on the Measurement marker to toggle the 

Measurement marker on. A cylinder will show in the LDV window. 

 

 
 

Note: The yellow histogram represents the lidar points within the measurement cylinder; the 

black histogram represents all of the lidar points within the data subset (in this case, the circular 

plot). The yellow histogram can be proportionally scaled relative to the entire plot histogram by 

sliding the control below the histogram. 

12. Center the cylinder over a tree within the plot:  

i. This cylinder can be moved by using the combination of ctrl + right mouse + movements. Tip: 

once you have the cylinder centered over a tree, it’s a good idea to click the Lock measurement 
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area center checkbox on (remember to unlock it when you want to move the cylinder to another 

tree).  

ii. The diameter can be changed by shift-ctrl-right mouse.  

iii. The shape or aspect ratio can be changed from circle to ellipse by using ctrl and up or down 

arrows. 

iv. The orientation of the ellipse is modified with ctrl + left and right arrows.  

Note: Using these key and mouse combinations is not immediately intuitive (to put it 

mildly). However, it is important to fit the 3D measurement cylinder as closely as possible to the 

3D shape of the tree.  

v. As you change the position, shape, and size of the cylinder, note how the histogram changes in 

the Tree Measurement window.  

vii. After the cylinder is centered over a tree, measurements can be made from the data using the 

red lever manipulated by the mouse wheel. Some keystrokes to snap the marker to the top or 

bottom are available too. The list of keystrokes can be accessed by clicking on the lower-left 

button of the LDV window. 

 

To use the Tree Measurement tool to record some tree measurements, you should follow a series 

of steps: 

1. In the Tree Measurement tool: Add an entry for a Tree identifier (the default of 1 is sufficient 

since this is the first tree of this plot).  

2. Location: set the location of the cylinder center by clicking the adjacent Set button.  

3. Elevation at tree base: press “l” (lower-case L) to drop the marker to the lowest point in the 

cylinder (don’t press upper-case L or you’ll move the cylinder) and then scroll the Measurement 

marker up/down to the tree base (check that this is set to zero or a number slightly above zero 

else tree models that you will soon create won’t display) and click the adjacent Set button.  

4. Total height: press “h” to raise the marker to the highest point in the cylinder (don’t press “H” 

or you’ll move the cylinder) and scroll the Measurement marker to the top of the tree and click 

the adjacent Set button.  

5. Height to crown base: scroll the Measurement marker down to the crown base and click the 

adjacent Set button.  

6. Tip: try moving the measurement plate to the base of a crown (up/down), then make sure the 

cylinder is larger than the crown and press the “F” key. This fits the cylinder to the crown points.  

7. Crown diameter: min, max, and crown rotation: These three values are extracted from the 

cylinder diameter measurements when you click the adjacent Set button (Note: if min and max 

are the same value, you’ve used a simple circular tree crown model (not an ellipse). If the crown 

rotation angle is zero, you’ve not rotated the ellipse.).  

8. Comment: add an optional comment if you notice something that is special about tree, such as 

broken top, or curvature of the stem. 

9. Create a new .csv file or select an existing .csv file to save the measurements by clicking on 

the Browse button.  

10. Click Save tree parameters. Note: After the parameters are saved, the points belonging to the 

just measured tree disappear from the screen (they can be brought back by hitting the show all 

data points but they cannot be turned off again. Therefore, while you are in the measurement 

mode, you should refrain from bringing back the points of measured trees, as it will hinder the 

measurements). The tree identifier increments automatically.  

11. Uncheck the Lock measurement area center checkbox.  
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12. Move the cylinder to the next tree and check the Lock measurement area center checkbox. 13. 

Adjust the size, shape, and orientation of the cylinder to fit this next crown 

14. Set all of your measurements in the Tree Measurement dialog for this tree.  

15. Click Save tree parameters. The measurements and comments (if any) will be appended to the 

previous .csv file.  

16. Repeat these last five steps (beginning with uncheck the Lock measurement area center…) for 

each tree in the plot.  

17. Once done, open your recently created .csv file. For a plot with only three trees, the content of 

the .csv file should be similar to the following: 

 

 

Questions 
Submit a Word document that answers the following questions (each worth 10%): 

Q1. How many points are stored in the lda_4800k_data.las file? 

Q2. How many return points are in the lda_4800k_data.las file? 

Q3. What is the coordinate system on which the points were stored in the lda_4800k_data.las 

file? You should know that the image and the points cloud have the same coordinate system, 

and you could use ArcGIS to find the information needed. 

Q4. What is the maximum tree height on each plot? 

Q5. What is the maximum and minimum elevation on each plot?  

Q6. What is the maximum intensity value for the entire las file? There is a chance that 

rendering process will take some time, have patience. It is important to have the data stored 

locally. 

Q7. Include a snapshot with the points from LDV before and after the ground elevation was 

subtracted from each return.  

Q8. How many trees are in each plot? 

Q9. What is the height of the second largest tree in each plot? 

Q10. Why there are points with negative values after normalization of the point cloud. 
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10 Introduction to Lidar: Command line 
 

Lab developed by Dr. Strimbu from USFS documentation.  

 

10.1 Objectives 

• Working with shapefile in Fusion 

• Extract points from las file using a shapefile 

• Normalize a point cloud 

• Estimate tree metrics 

10.2 Files used in this Lab 

The files needed to complete this Lab are supplied by the U.S. Forest Service, and are on Canvas. 

Copy the files localy; such an address could be T:\Teach\Temp\JaneDoe\FE444\Lab10, where 

Jane Doe should be replaced with your name. This path would be used for all the subsequent 

examples, but you should customize to your settings. 

Files (dat and hdr format) Description 

lda_4800k_data.las Point cloud  

Orthophoto_4800k.jpg Ortho-rectified image 

Orthophoto_4800k.jpgw Ortho-rectified image georeferenced 

4800k_DSM Digital surface model 

4800k_ground_surface Digital terrain model 

three_plots.shp Shapefile for plots 

 

10.3 Lab Procedure 

By now, you should be familiar with the basic features of Fusion. As with all new programs, it is 

helpful to play around and get a feel for the program. Today we will be diving further into the 

weeds of command-line interfacing with Fusion. 

10.3.1 Files in Windows  

If you are not familiar with Windows environment you should know that there are two types of 

files: some that perform a task, which are called executable, and files that store information. The 

information can be defined by the used or can be accessed by the executable files, as they store 

critical pieces of data needed for correct running of the task. The executable files are identified 

with the extension exe while the batch files with the extension bat. By default a file is executed if 

it is enter at the prompt, as we will see later, or by double clicking it, in Windows explorer. In 

fact any time when you start a program an executable file is triggered. If only the name of the 

executable file is entered at the command line, then the file have to be located in the current 

directory listed by the prompt. If the executable file is located in a different folder then either the 

path to that location is typed or the location of the prompt is changed to the respective folder. 
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10.4 DOS 

DOS, which stands for Disk Operating System, (or Command Prompt in Windows) is a 

command driven computing language. It can be found by opening the START menu and 

typing in “cmd.exe”; you should see a black window that looks something like this: 

 
The directory you start in may change from computer to computer; the example above has 

us in the “N:\” directory. Type in ‘help’ to see a list of available commands, or “help 

<command>” for more information on that command: 

 
 

To navigate the computer folder structure using DOS you have to use a particular syntax. First, it 

is recommended to change to the appropriate drive, if by default DOS is not pointing the  drive 

that you want. In the example from above, DOS points to the N drive, whereas all Fusion tools 

are on C drive. To change from N to C you simply type c: or cd c:\. Once on the appropriate 

drive you should go to the Fusion folder by typing either cd c:\Fusion. The cd DOS command 

stands for Change Directory.  

 

Subsetting the LIDAR points for a substantial amount of plots can best be done from the 

DOS command line using FUSION’s command-line executable clipdata.exe, which can be run 

on one plot at a time or on multiple plots by using a batch process. One method for doing this is 

by using MS Excel to create large batch files. The advantage of creating such a file in a 

spreadsheet is the capability to generate a series of incremented field entries and to be able to 

concatenate several fields into a single text string (this technique can save you a lot of time if you 
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are trying to analyze hundreds of plots!). Please refer to Appendix 1 (at the end of this lab) if you 

are interested in learning more about creating batch files in a spreadsheet environment.  

Before you go on to run the clip data command, it’s critical that you have a sound 

understanding of why and how to use the DOS command prompt and batch files to run Fusion 

utilities. If you aren’t proficient with the basic skills needed to work in the DOS environment, 

you won’t be able to efficiently handle Fusion projects. The following are some important facts 

and tips for using the FUSION commands: 

• The FUSION command line utilities and processing programs are collectively referred to 

as the FUSION LIDAR Toolkit or FUSION-LTK. 

• First of all, you must know which Fusion utilities will give you the most useful 

information for your project. To study Fusion utilities, click the Fusion Manual shortcut. 

Page 16 provides an introduction to using command line utilities and pages 17-20 give an 

overview of all Fusion utilities and processing programs. The more you understand the 

capabilities of the FUSION commands, the more efficient you will be at extracting 

useful information from lidar data. You will need to understand each command line 

utility enough to customize it for your data by manipulating the parameters and switches. 

The defaults will usually produce poor results!  

• The FUSION-LTK programs are designed to run from a command prompt or using batch 

files. There is no friendly GUI available!  

• Remember to follow these three guidelines as you work in DOS:  

o Good file organization– make sure your folders are organized and named in a 

simple and intuitive manner.  

o Correct Syntax– take your time and check before you run. Incorrect syntax can 

overwrite and delete your input file!!!  

o Directory navigation- call the correct directory. A good file structure and proper 

syntax will make this much easier.  

• Most of FUSION’s command line *.exe files can be batched to facilitate/automate 

repetitive data processing steps from the DOS prompt. A batch file (see graphic below) is 

simply a text file containing a separate line for each DOS command or each time the 

command should be executed. These files can be created with a text editor or any other 

program that can save the output as a text file (i.e. Notepad or Excel). They are easy to 

edit and improve efficiency for large projects.  

• The extension of the batch file has to be .bat to let DOS know it has to process every line 

consecutively. Running the batch file is easy--simply navigate to the directory containing 

the batch file in the command prompt and type the name of the batch file. 

 

Recommendations on working with Fusion LTK 

As I said, to run a task in Fusion you have to enter the name of the file executing the task at the 

command prompt or double clicking in Windows explorer, if no parameters are needed. 

However, Fusion LTK requires parameters which suggest that only the command prompt should 

be used. Typing on DOS is not easy, pleasant, and is prone to errors. Furthermore, once you 

submit the command, if wrong, you have to type it again, which in many cases is really 

frustrating. A work around this issue is either usage of text files or the creation of a batch file. In 

many instances you could run only one LTK command in batch mode, just because is easy to 

debug, if needed. Remember that a batch file, also called bat file, is an ASCII file that contains 
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the succession of operations to be executed and is submitted to the CPU with the extension bat. 

We will see later how to use the bat files. 

3.2 Explore the Clipdata command 

1. Let’s start by initially exploring the Clipdata command.  

2. For the complete syntax, click the DOS prompt shortcut and type in Clipdata. However, if you 

are in a folder that does not contain the clipdata exe file then the command will not work. 

Therefore, either navigate to the folder where the clipdata command is located, usually in 

C:\Fusion or type the entire path: c:\fusion\clipdata. 

3. Refer to the Clipdata section of the Fusion manual for more info. 

DOS tip: You can use the up and down arrows to recall previous commands executed in the same 

command prompt window. This is very useful when you mess up the syntax and only need to 

change a character or two. You can edit the commands by moving the cursor with left and right 

arrows and using the insert key to control insert/overstrike 

 

3.3 Example syntax 

If you are in the Fusion folder then you can clip the lidar data by submitting the following 

command:  

clipdata /shape:1 c:\lidar\sampledata\lda_4800K_data.las 

T:\Teach\Temp\JaneDoe\FE444\Lab10\clipplot1.las 975984 567628 976184 567828. 

However, if you are not in the Fusion folder to run the same command you have to type the 

following command (considering that you do not want to navigate to the Fusion folder in DOS: 

 C:\Fusion\clipdata /shape:1 T:\Teach\Temp\JaneDoe\FE444\Lab10\lda_4800K_data.las 

T:\Teach\Temp\JaneDoe\FE444\Lab10\clipplot1.las 975984 567628 976184 567828. 

If the Fusion folder is installed under the folder Program files, or any other folder that contains 

spaces, then the syntax has to be changed to  

“C:\Program Files\Fusion\clipdata” /shape:1 

T:\Teach\Temp\JaneDoe\FE444\Lab10\lda_4800K_data.las 

T:\Teach\Temp\JaneDoe\FE444\Lab10\clipplot1.las 975984 567628 976184 567828 

As you see the path now is within quotation marks because a space means something for DOS, 

which means that you should specifically state that the space is a part of a path not part of the 

DOS command. This task is completed by including within quotation marks the path.  

The parameters, or the switch as they are called in Fusion, required by the clipdata command and 

present in the example above are the following:  

• clipdata is the FUSION executable command  

• /shape:1 denotes a circular shape.  

• T:\Teach\Temp\JaneDoe\FE444\Lab10\lda_4800K_data.las specifies the input las file. 

• T:\Teach\Temp\JaneDoe\FE444\Lab10\clipplot1.las defines the output (sample) las file. 

• The last four numbers are geo-coordinates that define the bounding box of the circular 

shape. 

 

If you want to have the point cloud normalized, meaning subtract the ground from the elevation 

of each return then you could enhance your command by adding the following switches: 

/dtm:T:\Teach\Temp\JaneDoe\FE444\Lab10\4800k_ground_surface.dtm /height. The final 

command should look like: 
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C:\Fusion\clipdata /shape:1 

/dtm:T:\Teach\Temp\JaneDoe\FE444\Lab10\4800k_ground_surface.dtm /height 

T:\Teach\Temp\JaneDoe\FE444\Lab10\lda_4800K_data.las 

T:\Teach\Temp\JaneDoe\FE444\Lab10\clipplot1.las 975984 567628 976184 567828 

 

• clipdata is the FUSION executable command  

• /shape:1 denotes a circular shape.  

• /dtm:T:\Teach\Temp\JaneDoe\FE444\Lab10\4800k_ground_surface.dtm denotes the 

bare-earth surface model used to normalize the LIDAR data (subtract the bare-earth 

surface elevation from each lidar point elevation).  

• /height is used in conjunction with the specified dtm to convert all elevation values to 

height above ground.  

• T:\Teach\Temp\JaneDoe\FE444\Lab10\lda_4800K_data.las specifies the input las file. 

• T:\Teach\Temp\JaneDoe\FE444\Lab10\clipplot1.las defines the output (sample) las file. 

• The last four numbers are geo-coordinates that define the bounding box of the circular 

shape. 

After submission and complete execution of clipdata command, navigate to the output folder 

directory (T:\Teach\Temp\JaneDoe\FE444\Lab10) and verify that the files clipplot1.las was 

created. 

 

 

REMEMBER: make sure that you use the proper slashes. Forward slashes ( / ) for switches and 

back slashes ( \ ) for file paths. Bad things can happen if you use the wrong slash! Also 

remember to place a single space between all commands, switches, and file paths. 

 

10.4.1 clipplots batch file in ‘Notepad’ 

You can create the three las files with points for each plot by typing the command on DOS three 

times and changing the coordinates. However, you can do the same task in Notepad, which is 

way more user friendly than DOS, then submit the all the code at once as a batch file. 

 

To create a batch file simply copy the syntax for plot 1 three times, then change the coordinates. 

The syntax should look similar to the following code where 3 plots are clipped and normalized 

(the color shows the there is one line of code for each plot, even that it is on two lines in Word): 

 
c:\Fusion\clipdata /shape:1 /dtm:T:\Teach\Temp\JaneDoe\FE444\Lab10\4800k_ground_surface.dtm /height 
T:\Teach\Temp\JaneDoe\FE444\Lab10\lda_4800K_data.las T:\Teach\Temp\JaneDoe\FE444\Lab10\clipplot1.las 975984 567628 976184 567828 

c:\Fusion\clipdata /shape:1 /dtm:T:\Teach\Temp\JaneDoe\FE444\Lab10\4800k_ground_surface.dtm /height 

T:\Teach\Temp\JaneDoe\FE444\Lab10\lda_4800K_data.las T:\Teach\Temp\JaneDoe\FE444\Lab10\clipplot1.las 977110 566582 977230 566701 
c:\Fusion\clipdata /shape:1 /dtm:T:\Teach\Temp\JaneDoe\FE444\Lab10\4800k_ground_surface.dtm /height 

T:\Teach\Temp\JaneDoe\FE444\Lab10\lda_4800K_data.las T:\Teach\Temp\JaneDoe\FE444\Lab10\clipplot1.las 974760 566560 974880 566680 

 

Tip: An easy way to avoid typos when entering file paths is to navigate to the file in windows 

explorer and then copy and paste the path into your batch file from the address line 

10.4.2 View plot data in Fusion 
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1. Ensure that the Image File (Orthophoto_4800k.jpg) and that the three POI’s from Part 1 

of this exercise are loaded and visible.  

2. Click the Raw data button in the Fusion window.  

3. If the file lda_4800K_data.las is still loaded, click the Delete button to remove it.  

4. Click the Add File button.  

5. Navigate to and select clipplot1.las.  

6. Hold the shift key down and select the last file, clipplot3.las, to select all three lidar plot 

subset files.  

7. Click the Open button.  

8. Give each data file a different color and change the Symbology. Select one of the rows 

(each row is a data file) in the Data Files dialog and for each selected row:   

a. Click the Properties button (or double-click the item).  

b. Change the Symbol to Single Pixel.  

c. Change the line color to a distinct color.  

d. Click OK. 

9. Click the check box next to the Raw data button to display the three lidar subsets. Your 

results should be similar to the following graphic. 

 
10. In your Sample options dialog ensure that you have selected a Stroked box sample shape 

and click OK.  

11. Now, drag a sample over one of the plots and the lidar subset will display in the LDV, as 

in the following graphic. 
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10.5 Plot Metrics 

Various plots metrics can be computed with LTK. By now you should know that typing a LTK 

command anywhere on DOS will not work, except if you are located in the proper folder, which 

as I said, is likely to be C:\Fusion. To extract the cloud metrics using the command prompt first 

open the DOS Command prompt, navigate to c:\Fusion folder, and type cloudmetrics to explore 

the syntax of the cloudmetrics command.  

 

Navigate to the CloudMetrics section in the Fusion manual for more info.  

1. The syntax for the cloudmetrics command is:  

CloudMetrics [switches] InputDataSpecifier OutputFileName  

2. The InputDataSpecifier can be a LIDAR data file, name of a text file containing a list of 

lidar file names (must have .txt extension), a catalog file, or individual file name. In our 

case, we will use a text file containing a list of lidar file names. Let’s create that now.  

3. Use Notepad to create the InputDataSpecifier: a text file containing the list of the three 

clipplot#.las files you created in Lab 9. (see following snapshot). 

 
* They may also be called “Plot1.las” “Plot2.las” and “Plot3.las” 
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4. Name the file plot_metrics.txt and save it in the 

T:\Teach\Temp\JaneDoe\FE444\Lab10\ folder. 

5. Open Notepad to create a cloudmetrics batch file. Use the following switches and 

parameters to create your batch file:  

a. C:\Fusion\cloudmetrics Fusion’s command line executable  

b.  /id, use file name to identify output  

c. /new, creates a new output file and deletes any existing file with the same name.  

d.  /above:12, compute various cover estimates using the specified height break, in 

this case the height break is 12 feet. Please refer to Appendix 1 of this chapter for 

how cover metrics are computed.  

e. /minht:3, only use returns above a certain height to compute metrics. By choosing 

3 feet we will exclude “ground” returns from our output stats. The units are in feet 

because the las file has the coordinates x and y in m and the elevation in feet. 

Fusion does not know how to convert from one coordinate system to another, so 

you should always be aware that all input files should be in the same coordinate 

system. 

f. T:\Teach\Temp\JaneDoe\FE444\Lab10\plot_metrics.txt InputDataSpecifier, in 

this case we have used a text file containing a list of the multiple file names, with 

full file paths included. 

g. T:\Teach\Temp\JaneDoe\FE444\Lab10\outmetrics.csv Output Data File, this 

designates the output file name. Note: we include the full file path, if the path is 

incorrect, or doesn’t exist, the output file will not be created!  

Your syntax should look similar to the following: 

C:\Fusion\cloudmetrics /id /new /above:12 /minht:3 

T:\Teach\Temp\JaneDoe\FE444\Lab10\plot_metrics.txt 

T:\Teach\Temp\JaneDoe\FE444\Lab10\outmetrics.csv 

 

6. Once completed save the file as clmetrics.bat. The csv part is missing from the 

screenshot to ensure legibility. 

 
7. In DOS at the T:\Teach\Temp\JaneDoe\FE444\Lab10\ prompt, type clmetrics and hit 

Enter. Conversely, navigate to the location of the clmetrics.bat file and double click it.  

a. If you receive an error or the command will not run (after you have checked your 

syntax, please refer to Appendix 1 of this document).  

8. After the program finishes, open the output file (outmetrics.csv) in Excel. The output .csv 

file looks close to the follows screen shot (one output line for each of the input data files): 
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Not only does FUSION calculate metrics for elevation of each return, it also calculates the 

metrics for intensity if the information is available. At this point in the development of aerial 

discrete return lidar technology, the intensity values are not normalized, so they are not ideally 

suited for analytical work. Hopefully in the future this will change and these metrics can be used 

in more analysis  

Lidar has proven itself, through validated research, to directly and accurately measure 

height and % canopy cover of forest vegetation. So let’s now take a closer look at our plots to see 

if we can understand how the metrics reflect what we see in the field and the lidar point cloud.  

We have presented a variety of information for each plot in the following figure. Our 

hope is that by presenting the lidar point cloud visualizations, a site photo, and a selection of the 

cloudmetrics all together you will start to understand how lidar technology measures/collects 

information about forest landscapes. Let’s point out some obvious correlations: 

• % Canopy Cover ranges from 90% (plot 1) on the old growth site to 15% (plot 2) on the site 

that was treated with heavy thinning. Plot 3 falls somewhere in the middle, which makes 

sense. This is easily visualized when you inspect the overhead view of the point cloud. 

Remember the point clouds are colored by height, hence any blue is the ground below the 

canopy. 

• The standard deviation is lowest in the lightly thinned stand (plot 3), this would indicate that 

the returns are more evenly distributed through the canopy. Could that be an indication of an 

evenly distributed vertical canopy structure? Take some time to explore some of the other 

metrics in outmetrics.csv. Can you find any interesting correlations? Refer to the 

CloudMetrics section of the Fusion manual for more explanation. 

 

The cloudmetrics output is most often used with the output from the ClipData program to 

compute metrics (just as we did in part 1) that will be used for regression analysis. The next step 

in the regression analysis would be to explore relationships between field data recorded at the 

plots and the plot metrics we calculated using FUSION. Once these relationships are established 

using any number of analysis techniques (linear regression, random forest, etc….) you can apply 

the resulting equations across your whole study area. To do this you would need to compute the 

same metrics you did for the plots across the lidar acquisition. The GridMetrics FUSION 

command computes the same metrics as CloudMetrics, but the output is a raster (grid) format 

with each record corresponding to a single grid cell. In this part of the exercise, we will compute 

GridMetrics for the example data set. 
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10.6 Grid Metrics 

1. Open DOS, navigate to c:\Fusion folder and type in gridmetrics to explore the full syntax.  

2. Go to the GridMetrics section in the Fusion manual for more info.  

3. Start a new Notepad document and save it as grdmetrics.bat in the Lab10 folder. Use the 

following switches and parameters to create your batch file:  

a. C:\Fusion\Gridmetrics: Fusion’s command line executable  

b. /minht:3 Switch to only use returns above a certain height to compute metrics. By 

choosing 3 feet we will exlude “ground” returns from our output stats.  

c. /nointensity: Switch for excluding intensity metrics.  

d. T:\Teach\Temp\JaneDoe\FE444\Lab10\4800k_ground_surface.dtm: File path 

for the bare-earth surface model used to normalize the LIDAR data (subtract the 

bare-earth surface elevation from each lidar point elevation).  

e. 12: Parameter for a 12 foot height break for calculating cover metrics.  

f. 20: Parameter for a 120 foot cell size, usually correlated with a fixed plot size.  

g. T:\Teach\Temp\JaneDoe\FE444\Lab10\metrics.csv: Output data file path. 

Note: we include the full file path. If the path is incorrect, or doesn’t exist, the 

output file will not be created.  

h. T:\Teach\Temp\JaneDoe\FE444\Lab10\lda_4800k_data.las: Input data file 

path. In this case we have used our single lidar tile. In a project scenario you will 

probably designate a number of tiles.  

i. Your syntax should look similar to the following: 

C:\Fusion\Gridmetrics /minht:3 /nointensity 

T:\Teach\Temp\JaneDoe\FE444\Lab10\4800k_ground_surface.dtm 12 120 

T:\Teach\Temp\JaneDoe\FE444\Lab10\metrics.csv 

T:\Teach\Temp\JaneDoe\FE444\Lab10\lda_4800k_data.las 

 

j. In DOS navigate to T:\Teach\Temp\JaneDoe\FE444\Lab10\ and type in 

grdmetrics to run the command.  

k. After the program finishes, navigate to T:\Teach\Temp\JaneDoe\FE444\Lab10\. 

l. Open the output file (metrics_all_returns_elevation_stats.csv) in Excel. The 

output csv file looks as the figure below (one output line for each grid cell): 

 
4. Let’s note a few things about the output CSV file.  

a. You should notice that each row has a column denoting the center x and center y 

for that grid cell.  

b. As you scroll through the file you may see some rows that have –9999 values, this 

is FUSION’s nodata value.  
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c. Cloudmetrics and GridMetrics produce the same metrics. This capability in 

FUSION makes it possible to model relationships observed between lidar plot 

metrics and field plot measurements and then apply them across the entire lidar 

acquisition. Any of the rows in the CSV file can be converted into ASCII files and 

exported into a GIS for analysis/modeling. Let’s export one of the metrics 

(columns) now. 

10.7 OPTIONAL. Prepare the CSV2GRID command to export one of the 

columns and create an asci file representing the % Canopy Cover Metric 

1. Open DOS and navigate to c:\Fusion. Then type CSV2Grid to study the syntax.  

2. Go to the CSV2Grid section of the Fusion Manual for more info.  

3. Let’s create our script to extract the metrics from our study area. Start a new Notepad 

(.txt) document and save it as covergrd.bat in the lab 10 folder. Use the following 

switches and parameters to create your batch file:  

a. C:Fusion\csv2grid Fusion’s command line executable  

b. T:\Teach\Temp\JaneDoe\FE444\Lab10\metrics_all_returns_elevation_stats.c

sv InputDataFile, our output from the Gridmetrics command  

c. 49 denotes column 49 in the gridmetrics csv output file. Column 49 correlates to 

the % cover calculation for each cell or “Percentage first returns above 12.00”.  

d. T:\Teach\Temp\JaneDoe\FE444\Lab10\cover_grid.asc Output Data File, output 

grid in ascii format. This will allow us to use the data in a GIS. 

e. Your syntax should look similar to the following: 

C:Fusion\csv2grid 

T:\Teach\Temp\JaneDoe\FE444\Lab10\metrics_all_returns_elevation_stats.csv 49 

T:\Teach\Temp\JaneDoe\FE444\Lab10\cover_grid.asc 

 

f. In DOS navigate to c:\fusion and copy the command above then execute it or 

navigate to T:\Teach\Temp\JaneDoe\FE444\Lab10 and double click the 

covergrd.bat file.  

g. Now open ArcMap, navigate to and load your new ASCII file (cover_grid.asc). 

Ignore the spatial reference warning. Note: In the future you will want to define 

the projection of your lidar derivatives, which will be the same as the raw lidar 

data. ArcMap does not recognize FUSION’s projection so you have to manually 

redefine it!  

h. In the Search bar type in Calculate Statistics and run that tool for cover_grid.asc 

(there is no need to define an area of interest).  

i. Right click on cover_grid.asc in the index and select Properties from the drop 

down menu.  

j. Under the Symbology tab, select Classified and your desired color ramp. Click 

Apply. Your ArcMap display should now look somewhat similar to the following 

graphic.  
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k. Add the lidar reference image, orthophoto_4800K.jpg, to your map display.  

l. Explore both layers together for a few moments. Based on your image 

interpretation skills does the % Canopy Cover lidar derivative layer correlate 

with the photo. Do you think this would be a good GIS layer for your whole 

forest?! 

m.  Any of the metrics calculated in the Gridmetrics CSV output file can be exported 

into grid format and added to your GIS for analysis. 

 

10.8 Appendix: Create an Excel spreadsheet 

A very effective method for creating a batch file is by using MS Excel. The advantage of 

creating such a file in a spreadsheet is the facility to generate series of incremented field entries 

and to be able to concatenate several fields into a single text string. We’re only extracting LIDAR 

subsets for three plots in order to keep this exercise relatively quick and manageable. However, 

the real value of this batching process will only become obvious when you want to extract a large 

number of LIDAR subsets. The three plot centers (made up for the sake of this exercise) have the 

following locations (Xc, Yc in the same units and coordinate system as the lidar data) and they 

have a diameter (D) of 120 meters shown below in the table: 

Xc       Yc D 

975463 568226 120 

977170 566641 120 

974820 566620 120 

1. Open Excel 

2. Name the first Worksheet tab boxcalc 

3. Name the second Worksheet tab batcomp 
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4. Create column headings labeled: Command, Input File, and Output File.  

5. Command Column: this contains the path to and name of the fusion command line 

executable— in this case clipdata.  

6. Input File Column: contains the path and name of the lidar data set. This example 

contains only one file from which data will be subset (lda_4800K_data.las) but more 

can be used as required.  

7. Output File Column: contains the path and filename of the output file (the plot 

subsets). They were built by concatenating the path, the plot-id listed in the boxcalc 

worksheet and the extension of the file: =CONCATENATE("b.

 T:\Teach\Temp\JaneDoe\FE444\Lab10",boxcalc!A2,".las") 

8. The values in the next four columns are the column headings and min and max values 

for the bounding box copied from the boxcalc worksheet.  

9. Referencing a cell from another worksheet in the same spreadsheet is done by adding 

the name of the worksheet followed by an exclamation mark: ex: =boxcalc!F2  

10. The final column will be labeled Full Syntax which will be a concatenation of all of 

the previous columns and the insertion of the /shape:1 switch=CONCATENATE(A2," 

/shape:1 ",B2," ",C2," ",D2," ",E2," ",F2," ",G2) 

 

The results for the first row of the Full Syntax Column should look like: 

..\clipdata /shape:1 b. T:\Teach\Temp\JaneDoe\FE444\Lab10\lda_4800K_data.las c b.

 T:\Teach\Temp\JaneDoe\FE444\Lab10\clipplot1.las 975403 568166 975523 

568286 

 

11. Next, copy Column H (the Full Syntax Column) and paste its values (Paste Special | 

Values) in another worksheet named bat:  

12. Save your Excel spreadsheet (any name and location that makes sense to you) but 

don’t close the spreadsheet.  

13. Save the bat worksheet, which should look like the following graphic (it should be a 

text file named clipplots1.bat in your batch file directory). 

 

14. Type clipplots1 in the command prompt and hit enter to let it run.  

15. Using Windows Explorer, navigate to the output folder directory 

(T:\Teach\Temp\JaneDoe\FE444\Lab10) and verify that the files clipplot1.las, 

clipplot2.las and clipplot3.las were created. 
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10.9 Questions 

 

1. How many points are stored in each of the three plot las files? 

2. What is the area of plot #2? 

3. What is a normalized points cloud?  

4. Do you need to normalize the point cloud if you plan to measure the height of the trees 

using Fusion? Justify your answer with 2-3 sentences at the most 

5. What is the average height of plot #1? 

6. What is the height of the tallest tree in plot #1, 2, and 3? 

7. What is the height of the smallest tree in plot #1? 

8. What are the factors affecting tree heights from lidar point cloud? (look at the notes) 

9. Is the height computed from lidar overestimating or underestimating the tree height? 

10. What is the expected accuracy of height estimated from lidar point cloud? 

 

 

 


